aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/samba
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2009-05-30 14:08:53 +0200
committerKoen Kooi <koen@openembedded.org>2009-05-30 14:08:53 +0200
commit22f2fe8b5b835a86ce64105661f978f976a7b1ba (patch)
tree339fbed02f25deedf9e5fbc378abb29bd18d0b17 /recipes/samba
parentabd27ee079540ef9159bc305ba38ccf824036b99 (diff)
downloadopenembedded-22f2fe8b5b835a86ce64105661f978f976a7b1ba.tar.gz
samba 3.3.0: tdb fixes from poky
Diffstat (limited to 'recipes/samba')
-rw-r--r--recipes/samba/files/tdb.pc11
-rw-r--r--recipes/samba/files/tdbheaderfix.patch14
-rw-r--r--recipes/samba/samba.inc6
-rw-r--r--recipes/samba/samba_3.3.0.bb4
4 files changed, 33 insertions, 2 deletions
diff --git a/recipes/samba/files/tdb.pc b/recipes/samba/files/tdb.pc
new file mode 100644
index 0000000000..6307a20a03
--- /dev/null
+++ b/recipes/samba/files/tdb.pc
@@ -0,0 +1,11 @@
+prefix=/usr
+exec_prefix=/usr
+libdir=/usr/lib
+includedir=/usr/include
+
+Name: tdb
+Description: A trivial database
+Version: 1.1.2
+Libs: -L${libdir} -ltdb
+Cflags: -I${includedir}
+URL: http://tdb.samba.org/
diff --git a/recipes/samba/files/tdbheaderfix.patch b/recipes/samba/files/tdbheaderfix.patch
new file mode 100644
index 0000000000..e37c9b0d5c
--- /dev/null
+++ b/recipes/samba/files/tdbheaderfix.patch
@@ -0,0 +1,14 @@
+Index: source/lib/tdb/include/tdb.h
+===================================================================
+--- source.orig/lib/tdb/include/tdb.h 2009-05-17 17:42:41.000000000 +0100
++++ source/lib/tdb/include/tdb.h 2009-05-17 17:42:46.000000000 +0100
+@@ -1,6 +1,9 @@
+ #ifndef __TDB_H__
+ #define __TDB_H__
+
++#include <signal.h>
++
++
+ /*
+ Unix SMB/CIFS implementation.
+
diff --git a/recipes/samba/samba.inc b/recipes/samba/samba.inc
index 36de08beca..ec21ed70b0 100644
--- a/recipes/samba/samba.inc
+++ b/recipes/samba/samba.inc
@@ -6,6 +6,7 @@ SRC_URI = "http://samba.org/samba/ftp/stable/samba-${PV}.tar.gz \
file://volatiles.03_samba \
file://smb.conf \
file://init \
+ file://tdb.pc \
"
S = "${WORKDIR}/samba-${PV}/source"
@@ -55,6 +56,8 @@ do_compile () {
}
do_install_append() {
+ install -d ${D}${libdir}/pkgconfig/
+ cp ${WORKDIR}/tdb.pc ${D}${libdir}/pkgconfig/
mv ${D}${libdir}/libsmbclient.so ${D}${libdir}/libsmbclient.so.0 || true
ln -sf libsmbclient.so.0 ${D}${libdir}/libsmbclient.so
mkdir -p ${D}${base_sbindir}
@@ -83,4 +86,7 @@ do_stage() {
oe_libinstall -C bin -a -so libtdb ${STAGING_LIBDIR}
oe_libinstall -C bin -a -so libtalloc ${STAGING_LIBDIR}
oe_libinstall -C bin -so libwbclient ${STAGING_LIBDIR}
+ install -d ${STAGING_LIBDIR}/pkgconfig/
+ install -m 0644 ${WORKDIR}/tdb.pc ${STAGING_LIBDIR}/pkgconfig/
+ install -m 0644 ${S}/lib/tdb/include/*.h ${STAGING_INCDIR}/
}
diff --git a/recipes/samba/samba_3.3.0.bb b/recipes/samba/samba_3.3.0.bb
index c561d95524..87a7c5e7f7 100644
--- a/recipes/samba/samba_3.3.0.bb
+++ b/recipes/samba/samba_3.3.0.bb
@@ -11,9 +11,9 @@ DEFAULT_PREFERENCE = "-1"
SRC_URI += "file://configure-3.3.0.patch;patch=1 \
file://config-h.patch;patch=1 \
file://mtab.patch;patch=1 \
- "
+ file://tdbheaderfix.patch;patch=1 "
-PR = "r2"
+PR = "r3"
EXTRA_OECONF += "\
SMB_BUILD_CC_NEGATIVE_ENUM_VALUES=yes \