aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/samsung-soc-utils
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/samsung-soc-utils
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/samsung-soc-utils')
-rw-r--r--recipes/samsung-soc-utils/s3c2410-boot-usb-native_svn.bb31
-rw-r--r--recipes/samsung-soc-utils/s3c24xx-gpio_svn.bb18
-rw-r--r--recipes/samsung-soc-utils/s3c64xx-gpio_svn.bb18
-rw-r--r--recipes/samsung-soc-utils/sjf2410-linux-native_svn.bb32
4 files changed, 99 insertions, 0 deletions
diff --git a/recipes/samsung-soc-utils/s3c2410-boot-usb-native_svn.bb b/recipes/samsung-soc-utils/s3c2410-boot-usb-native_svn.bb
new file mode 100644
index 0000000000..675d07c910
--- /dev/null
+++ b/recipes/samsung-soc-utils/s3c2410-boot-usb-native_svn.bb
@@ -0,0 +1,31 @@
+DESCRIPTION = "Boots a S3C2410 device with a user supplied kernel zImage"
+DEPENDS = "libusb-native"
+SECTION = "devel"
+AUTHOR = "Harald Welte <laforge@openmoko.org>"
+LICENSE = "GPL"
+PV = "0.1.0+svnr${SRCREV}"
+PR = "r1"
+
+SRC_URI = "svn://svn.openmoko.org/trunk/src/host/;module=s3c2410_boot_usb;proto=https"
+S = "${WORKDIR}/s3c2410_boot_usb"
+
+inherit native
+
+do_compile() {
+ ${CC} ${CFLAGS} ${LDFLAGS} -lusb -o s3c2410-boot-usb boot_usb.c
+}
+
+do_deploy() {
+ install -d ${DEPLOY_DIR_TOOLS}
+ install -m 0755 s3c2410-boot-usb ${DEPLOY_DIR_TOOLS}/s3c2410-boot-usb-${PV}
+}
+
+do_stage() {
+ :
+}
+
+do_install() {
+ :
+}
+
+addtask deploy before do_build after do_compile
diff --git a/recipes/samsung-soc-utils/s3c24xx-gpio_svn.bb b/recipes/samsung-soc-utils/s3c24xx-gpio_svn.bb
new file mode 100644
index 0000000000..0a57d2c0e6
--- /dev/null
+++ b/recipes/samsung-soc-utils/s3c24xx-gpio_svn.bb
@@ -0,0 +1,18 @@
+DESCRIPTION = "A user-space tool to show and modify the state of GPIOs on the S3c24xx platform"
+SECTION = "console/utils"
+AUTHOR = "Werner Almesberger <werner@openmoko.org>"
+LICENSE = "GPL"
+PV = "1.0+svnr${SRCREV}"
+PR = "r2"
+
+SRC_URI = "svn://svn.openmoko.org/trunk/src/target;module=gpio;proto=http"
+S = "${WORKDIR}/gpio"
+
+do_compile() {
+ ${CC} ${CFLAGS} ${LDFLAGS} -static -o ${PN} gpio.c
+}
+
+do_install() {
+ install -d ${D}${sbindir}
+ install -m 0755 ${PN} ${D}${sbindir}
+}
diff --git a/recipes/samsung-soc-utils/s3c64xx-gpio_svn.bb b/recipes/samsung-soc-utils/s3c64xx-gpio_svn.bb
new file mode 100644
index 0000000000..92110691cf
--- /dev/null
+++ b/recipes/samsung-soc-utils/s3c64xx-gpio_svn.bb
@@ -0,0 +1,18 @@
+DESCRIPTION = "A user-space tool to show and modify the state of GPIOs on the S3c64xx platform"
+SECTION = "console/utils"
+AUTHOR = "Werner Almesberger <werner@openmoko.org>"
+LICENSE = "GPL"
+PV = "1.0+svnr${SRCREV}"
+PR = "r0"
+
+SRC_URI = "svn://svn.openmoko.org/trunk/src/target;module=gpio;proto=http"
+S = "${WORKDIR}/gpio"
+
+do_compile() {
+ ${CC} ${CFLAGS} ${LDFLAGS} -static -o ${PN} gpio-s3c6410.c
+}
+
+do_install() {
+ install -d ${D}${sbindir}
+ install -m 0755 ${PN} ${D}${sbindir}
+}
diff --git a/recipes/samsung-soc-utils/sjf2410-linux-native_svn.bb b/recipes/samsung-soc-utils/sjf2410-linux-native_svn.bb
new file mode 100644
index 0000000000..fcfbba923d
--- /dev/null
+++ b/recipes/samsung-soc-utils/sjf2410-linux-native_svn.bb
@@ -0,0 +1,32 @@
+DESCRIPTION = "JTAG utility to interface w/ a S3C2410 device"
+SECTION = "devel"
+AUTHOR = "Harald Welte <laforge@openmoko.org>"
+LICENSE = "GPL"
+PV = "0.1+svnr${SRCREV}"
+PR = "r0"
+
+SRC_URI = "svn://svn.openmoko.org/trunk/src/host/;module=sjf2410-linux;proto=https"
+S = "${WORKDIR}/sjf2410-linux"
+
+inherit native
+
+CFLAGS += "-DLINUX_PPDEV"
+
+do_compile() {
+ oe_runmake
+}
+
+do_deploy() {
+ install -d ${DEPLOY_DIR_TOOLS}
+ install -m 0755 sjf2410 ${DEPLOY_DIR_TOOLS}/sjf2410-${PV}
+}
+
+do_stage() {
+ :
+}
+
+do_install() {
+ :
+}
+
+addtask deploy before do_package after do_install