aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/sapwood/sapwood
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/sapwood/sapwood
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/sapwood/sapwood')
-rw-r--r--recipes/sapwood/sapwood/sockets.patch68
1 files changed, 68 insertions, 0 deletions
diff --git a/recipes/sapwood/sapwood/sockets.patch b/recipes/sapwood/sapwood/sockets.patch
new file mode 100644
index 0000000000..4e3a8e2d41
--- /dev/null
+++ b/recipes/sapwood/sapwood/sockets.patch
@@ -0,0 +1,68 @@
+Index: sapwood/configure.in
+===================================================================
+--- sapwood.orig/configure.in 2007-03-29 16:04:12.000000000 +0200
++++ sapwood/configure.in 2007-03-29 16:04:15.000000000 +0200
+@@ -13,63 +13,6 @@
+ AC_PROG_INSTALL
+ AC_PROG_MAKE_SET
+
+-dnl abstract sockets namespace checks, from dbus
+-AC_ARG_ENABLE(abstract-sockets,
+- [AC_HELP_STRING([--enable-abstract-sockets],
+- [use abstract socket namespace (linux only)])],
+- [enable_abstract_sockets=$enableval],
+- [enable_abstract_sockets=auto])
+-
+-AC_MSG_CHECKING(abstract socket namespace)
+-AC_RUN_IFELSE([AC_LANG_PROGRAM(
+-[[
+-#include <sys/types.h>
+-#include <stdlib.h>
+-#include <stdio.h>
+-#include <sys/socket.h>
+-#include <sys/un.h>
+-#include <errno.h>
+-]],
+-[[
+- int listen_fd;
+- struct sockaddr_un addr;
+-
+- listen_fd = socket (PF_UNIX, SOCK_STREAM, 0);
+-
+- if (listen_fd < 0)
+- {
+- fprintf (stderr, "socket() failed: %s\n", strerror (errno));
+- exit (1);
+- }
+-
+- memset (&addr, '\0', sizeof (addr));
+- addr.sun_family = AF_UNIX;
+- strcpy (addr.sun_path, "X/tmp/sapwood-fake-socket-path-used-in-configure-test");
+- addr.sun_path[0] = '\0'; /* this is what makes it abstract */
+-
+- if (bind (listen_fd, (struct sockaddr*) &addr, SUN_LEN (&addr)) < 0)
+- {
+- fprintf (stderr, "Abstract socket namespace bind() failed: %s\n",
+- strerror (errno));
+- exit (1);
+- }
+- else
+- exit (0);
+-]])],
+- [have_abstract_sockets=yes],
+- [have_abstract_sockets=no])
+-AC_MSG_RESULT($have_abstract_sockets)
+-
+-if test x$enable_abstract_sockets = xyes; then
+- if test x$have_abstract_sockets = xno; then
+- AC_MSG_ERROR([Abstract sockets explicitly required, and support not detected.])
+- fi
+-fi
+-
+-if test x$enable_abstract_sockets = xno; then
+- have_abstract_sockets=no
+-fi
+-
+ if test x$have_abstract_sockets = xyes; then
+ AC_DEFINE(HAVE_ABSTRACT_SOCKETS,1,[Have abstract socket namespace])
+ fi