summaryrefslogtreecommitdiffstats
path: root/recipes/schroedinger
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/schroedinger
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/schroedinger')
-rw-r--r--recipes/schroedinger/schroedinger_0.2.0.0.bb10
-rw-r--r--recipes/schroedinger/schroedinger_1.0.5.bb22
2 files changed, 32 insertions, 0 deletions
diff --git a/recipes/schroedinger/schroedinger_0.2.0.0.bb b/recipes/schroedinger/schroedinger_0.2.0.0.bb
new file mode 100644
index 0000000000..78653783d9
--- /dev/null
+++ b/recipes/schroedinger/schroedinger_0.2.0.0.bb
@@ -0,0 +1,10 @@
+HOMEPAGE = "http://schrodinger.sourceforge.net/"
+LICENSE = "MPL GPL LGPL MIT"
+DEPENDS = "liboil gstreamer gst-plugins-base"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/schrodinger/${P}.tar.gz"
+
+inherit autotools pkgconfig
+
+FILES_${PN} += "${libdir}/gstreamer-0.10/libgstschro.so"
+
diff --git a/recipes/schroedinger/schroedinger_1.0.5.bb b/recipes/schroedinger/schroedinger_1.0.5.bb
new file mode 100644
index 0000000000..defb758046
--- /dev/null
+++ b/recipes/schroedinger/schroedinger_1.0.5.bb
@@ -0,0 +1,22 @@
+HOMEPAGE = "http://schrodinger.sourceforge.net/"
+LICENSE = "MPL GPL LGPL MIT"
+DEPENDS = "liboil gstreamer gst-plugins-base"
+
+PR = "r1"
+
+SRC_URI = "http://www.diracvideo.org/download/schroedinger/${P}.tar.gz"
+
+inherit autotools
+
+PACKAGES =+ "gst-plugin-schroedinger gst-plugin-schroedinger-dev gst-plugin-schroedinger-dbg"
+FILES_gst-plugin-schroedinger += "${libdir}/gstreamer-0.10/libgstschro.so"
+FILES_gst-plugin-schroedinger-dev += "${libdir}/gstreamer-0.10/libgstschro.*"
+FILES_gst-plugin-schroedinger-dbg += "${libdir}/gstreamer-0.10/.debug/libgstschro.so"
+
+AUTOTOOLS_STAGE_PKGCONFIG = "1"
+
+do_stage() {
+ autotools_stage_all
+}
+
+