aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/scummvm/scummvm_0.9.1.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/scummvm/scummvm_0.9.1.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/scummvm/scummvm_0.9.1.bb')
-rw-r--r--recipes/scummvm/scummvm_0.9.1.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/recipes/scummvm/scummvm_0.9.1.bb b/recipes/scummvm/scummvm_0.9.1.bb
new file mode 100644
index 0000000000..b64ac1d93b
--- /dev/null
+++ b/recipes/scummvm/scummvm_0.9.1.bb
@@ -0,0 +1,30 @@
+require scummvm.inc
+
+DEPENDS = "virtual/libsdl libvorbis libogg zlib \
+ ${@base_conditional('ENTERPRISE_DISTRO', '1', '', 'libmad mpeg2dec', d)}"
+
+SRC_URI += "file://makefile-nostrip.patch;patch=1 \
+ file://scummvm-targetcheck.patch;patch=1"
+SRC_URI_append_openmoko = " file://openmoko-scummvm \
+ file://scummvm.desktop"
+
+SRC_URI_OVERRIDES_PACKAGE_ARCH = "1"
+
+EXTRA_OECONF += "--enable-lure \
+ --enable-agi \
+ --enable-cine \
+ "
+
+do_install_append() {
+ if [ -f ${WORKDIR}/openmoko-scummvm ]; then
+ install -d ${D}${bindir}
+ install -m 0755 ${WORKDIR}/openmoko-scummvm ${D}${bindir}/openmoko-scummvm
+ fi
+ if [ -f ${WORKDIR}/scummvm.desktop ]; then
+ install -d ${D}${datadir}/applications
+ install -m 0644 ${WORKDIR}/scummvm.desktop ${D}${datadir}/applications
+ fi
+ install -d ${D}${datadir}/scummvm
+ install -m 0644 gui/themes/modern.ini ${D}${datadir}/scummvm/
+ install -m 0644 gui/themes/modern.zip ${D}${datadir}/scummvm/
+}