summaryrefslogtreecommitdiffstats
path: root/recipes/scummvm
diff options
context:
space:
mode:
authorThomas Zimmermann <ml@vdm-design.de>2009-11-27 10:24:48 +0000
committerKlaus Kurzmann <mok@fluxnetz.de>2009-11-28 10:07:33 +0100
commit5c0217046abddee3cd8196613866791171da1847 (patch)
tree27e37fd9d55c2d70cb9e46274b8fd4c003647573 /recipes/scummvm
parent74ecf8c0f89651926e377f0bafc45669d9c9c410 (diff)
downloadopenembedded-5c0217046abddee3cd8196613866791171da1847.tar.gz
scummvm: copy config from openmoko to shr
Signed-off-by: Klaus Kurzmann <mok@fluxnetz.de>
Diffstat (limited to 'recipes/scummvm')
-rw-r--r--recipes/scummvm/files/shr/openmoko-scummvm19
-rw-r--r--recipes/scummvm/files/shr/scummvm.desktop12
-rw-r--r--recipes/scummvm/scummvm_0.12.0.bb1
3 files changed, 32 insertions, 0 deletions
diff --git a/recipes/scummvm/files/shr/openmoko-scummvm b/recipes/scummvm/files/shr/openmoko-scummvm
new file mode 100644
index 0000000000..58eb2bbded
--- /dev/null
+++ b/recipes/scummvm/files/shr/openmoko-scummvm
@@ -0,0 +1,19 @@
+#!/bin/sh
+
+# Save current AUX Key mapping
+SAVE_KEY="$(xmodmap -pke | grep 'keycode 177')"
+
+# Map AUX Key to F5
+xmodmap -e "keycode 177 = F5"
+
+# Turn LCD feft
+xrandr -o left
+
+# Start the scummvm in fullscreen mode
+scummvm --fullscreen --themepath=/usr/share/scummvm/
+
+# Turn LCD normal
+xrandr -o normal
+
+# Restore the AUX Key mapping
+xmodmap -e "$SAVE_KEY"
diff --git a/recipes/scummvm/files/shr/scummvm.desktop b/recipes/scummvm/files/shr/scummvm.desktop
new file mode 100644
index 0000000000..96c025050e
--- /dev/null
+++ b/recipes/scummvm/files/shr/scummvm.desktop
@@ -0,0 +1,12 @@
+[Desktop Entry]
+Encoding=UTF-8
+Name=ScummVM
+Name[pl]=ScummVM
+Comment=Interpreter for several adventure games
+Comment[pl]=Interpreter graficznych gier przygodowych
+Exec=openmoko-scummvm
+Icon=scummvm.xpm
+Terminal=false
+Type=Application
+Categories=Application;Game;AdventureGame;
+StartupNotify=false
diff --git a/recipes/scummvm/scummvm_0.12.0.bb b/recipes/scummvm/scummvm_0.12.0.bb
index 630db67f21..9d76426ab1 100644
--- a/recipes/scummvm/scummvm_0.12.0.bb
+++ b/recipes/scummvm/scummvm_0.12.0.bb
@@ -9,6 +9,7 @@ SRC_URI += " file://scummvm.desktop \
file://no-strip.patch;patch=1"
SRC_URI_append_openmoko = " file://openmoko-scummvm "
+SRC_URI_append_shr = " file://openmoko-scummvm "
SRC_URI_OVERRIDES_PACKAGE_ARCH = "1"