aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/sdcc
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/sdcc
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/sdcc')
-rw-r--r--recipes/sdcc/files/gcc4.patch13
-rw-r--r--recipes/sdcc/files/use-native-tools.patch80
-rw-r--r--recipes/sdcc/sdcc-2.8.0/use-native-tools.patch129
-rw-r--r--recipes/sdcc/sdcc-native_2.5.0.bb16
-rw-r--r--recipes/sdcc/sdcc-native_2.8.0.bb16
-rw-r--r--recipes/sdcc/sdcc_2.5.0.bb21
-rw-r--r--recipes/sdcc/sdcc_2.8.0.bb21
7 files changed, 296 insertions, 0 deletions
diff --git a/recipes/sdcc/files/gcc4.patch b/recipes/sdcc/files/gcc4.patch
new file mode 100644
index 0000000000..31eed50df8
--- /dev/null
+++ b/recipes/sdcc/files/gcc4.patch
@@ -0,0 +1,13 @@
+Index: sdcc/sim/ucsim/cmd.src/newcmdcl.h
+===================================================================
+--- sdcc.orig/sim/ucsim/cmd.src/newcmdcl.h
++++ sdcc/sim/ucsim/cmd.src/newcmdcl.h
+@@ -124,7 +124,7 @@ public:
+ cl_console(int portnumber, class cl_app *the_app);
+ #endif
+ virtual ~cl_console(void);
+- virtual class cl_console *cl_console::clone_for_exec(char *fin);
++ virtual class cl_console *clone_for_exec(char *fin);
+ virtual int init(void);
+
+ virtual bool accept_last(void);
diff --git a/recipes/sdcc/files/use-native-tools.patch b/recipes/sdcc/files/use-native-tools.patch
new file mode 100644
index 0000000000..d3b02c4a44
--- /dev/null
+++ b/recipes/sdcc/files/use-native-tools.patch
@@ -0,0 +1,80 @@
+Index: sdcc/device/lib/Makefile.in
+===================================================================
+--- sdcc.orig/device/lib/Makefile.in
++++ sdcc/device/lib/Makefile.in
+@@ -18,8 +18,8 @@ ifndef PORTINCDIR
+ PORTINCDIR = $(INCDIR)/mcs51
+ endif
+
+-CC = $(PRJDIR)/bin/sdcc
+-CPP = $(PRJDIR)/bin/sdcpp
++CC = sdcc
++CPP = sdcpp
+
+ prefix = @prefix@
+ exec_prefix = @exec_prefix@
+Index: sdcc/device/lib/mcs51/Makefile
+===================================================================
+--- sdcc.orig/device/lib/mcs51/Makefile
++++ sdcc/device/lib/mcs51/Makefile
+@@ -1,8 +1,8 @@
+
+ TOPDIR = ../../..
+
+-SAS = $(TOPDIR)/bin/asx8051
+-SCC = $(TOPDIR)/bin/sdcc
++SAS = asx8051
++SCC = sdcc
+
+ OBJ = crtstart.rel crtxinit.rel crtxclear.rel crtclear.rel crtxstack.rel \
+ crtpagesfr.rel
+Index: sdcc/device/lib/ds390/Makefile
+===================================================================
+--- sdcc.orig/device/lib/ds390/Makefile
++++ sdcc/device/lib/ds390/Makefile
+@@ -1,4 +1,4 @@
+-CC = ../../../bin/sdcc
++CC = sdcc
+
+ #VERBOSE = --verbose
+
+Index: sdcc/device/lib/ds400/Makefile
+===================================================================
+--- sdcc.orig/device/lib/ds400/Makefile
++++ sdcc/device/lib/ds400/Makefile
+@@ -1,4 +1,4 @@
+-CC = ../../../bin/sdcc
++CC = sdcc
+
+ #VERBOSE = --verbose
+
+Index: sdcc/device/lib/z80/Makefile
+===================================================================
+--- sdcc.orig/device/lib/z80/Makefile
++++ sdcc/device/lib/z80/Makefile
+@@ -2,8 +2,8 @@
+
+ TOPDIR = ../../..
+
+-SCC = $(TOPDIR)/bin/sdcc -mz80
+-SAS = $(TOPDIR)/bin/as-z80
++SCC = sdcc -mz80
++SAS = as-z80
+
+ OBJ = div.o mul.o putchar.o shift.o stubs.o crt0_rle.o heap.o fstubs.o
+
+Index: sdcc/device/lib/gbz80/Makefile
+===================================================================
+--- sdcc.orig/device/lib/gbz80/Makefile
++++ sdcc/device/lib/gbz80/Makefile
+@@ -2,8 +2,8 @@
+
+ TOPDIR = ../../..
+
+-SCC = $(TOPDIR)/bin/sdcc -mgbz80
+-SAS = $(TOPDIR)/bin/as-gbz80
++SCC = sdcc -mgbz80
++SAS = as-gbz80
+
+ OBJ = div.o mul.o putchar.o printf.o shift.o stubs.o crt0_rle.o heap.o fstubs.o
+
diff --git a/recipes/sdcc/sdcc-2.8.0/use-native-tools.patch b/recipes/sdcc/sdcc-2.8.0/use-native-tools.patch
new file mode 100644
index 0000000000..3572f5ea5a
--- /dev/null
+++ b/recipes/sdcc/sdcc-2.8.0/use-native-tools.patch
@@ -0,0 +1,129 @@
+diff -Nurd sdcc.orig/device/lib/Makefile.in sdcc/device/lib/Makefile.in
+--- sdcc.orig/device/lib/Makefile.in 2007-06-03 22:38:18.000000000 +0200
++++ sdcc/device/lib/Makefile.in 2008-04-01 10:05:17.352552206 +0200
+@@ -27,8 +27,8 @@
+ PORTINCDIR = $(INCDIR)/mcs51
+ endif
+
+-CC = $(top_builddir)/bin/sdcc
+-CPP = $(top_builddir)/bin/sdcpp
++CC = sdcc
++CPP = sdcpp
+
+ prefix = @prefix@
+ exec_prefix = @exec_prefix@
+diff -Nurd sdcc.orig/device/lib/ds390/Makefile.in sdcc/device/lib/ds390/Makefile.in
+--- sdcc.orig/device/lib/ds390/Makefile.in 2007-06-03 22:38:18.000000000 +0200
++++ sdcc/device/lib/ds390/Makefile.in 2008-04-01 10:06:23.287688808 +0200
+@@ -1,7 +1,7 @@
+ VPATH = @srcdir@
+ srcdir = @srcdir@
+
+-CC = ../../../bin/sdcc
++CC = sdcc
+
+ #VERBOSE = --verbose
+
+diff -Nurd sdcc.orig/device/lib/ds400/Makefile.in sdcc/device/lib/ds400/Makefile.in
+--- sdcc.orig/device/lib/ds400/Makefile.in 2007-06-03 22:38:18.000000000 +0200
++++ sdcc/device/lib/ds400/Makefile.in 2008-04-01 10:06:44.282796254 +0200
+@@ -1,4 +1,4 @@
+-CC = ../../../bin/sdcc
++CC = sdcc
+
+ VPATH = @srcdir@
+ srcdir = @srcdir@
+diff -Nurd sdcc.orig/device/lib/gbz80/Makefile.in sdcc/device/lib/gbz80/Makefile.in
+--- sdcc.orig/device/lib/gbz80/Makefile.in 2007-04-18 21:56:32.000000000 +0200
++++ sdcc/device/lib/gbz80/Makefile.in 2008-04-01 10:07:40.539249456 +0200
+@@ -5,8 +5,8 @@
+
+ TOPDIR = ../../..
+
+-SCC = $(TOPDIR)/bin/sdcc -mgbz80
+-SAS = $(TOPDIR)/bin/as-gbz80
++SCC = sdcc -mgbz80
++SAS = as-gbz80
+
+ OBJ = div.o mul.o putchar.o printf.o shift.o stubs.o crt0_rle.o heap.o fstubs.o
+
+diff -Nurd sdcc.orig/device/lib/hc08/Makefile.in sdcc/device/lib/hc08/Makefile.in
+--- sdcc.orig/device/lib/hc08/Makefile.in 2007-04-18 21:56:32.000000000 +0200
++++ sdcc/device/lib/hc08/Makefile.in 2008-04-01 10:09:20.336580262 +0200
+@@ -5,8 +5,8 @@
+
+ TOPDIR = ../../..
+
+-SCC = $(TOPDIR)/bin/sdcc -mhc08
+-SAS = $(TOPDIR)/bin/as6808
++SCC = sdcc -mhc08
++SAS = as6808
+
+ OBJ = _ret.rel _divuint.rel _divulong.rel _mulint.rel _mullong.rel
+
+diff -Nurd sdcc.orig/device/lib/mcs51/Makefile.in sdcc/device/lib/mcs51/Makefile.in
+--- sdcc.orig/device/lib/mcs51/Makefile.in 2007-04-18 21:56:32.000000000 +0200
++++ sdcc/device/lib/mcs51/Makefile.in 2008-04-01 10:05:53.603952030 +0200
+@@ -4,8 +4,8 @@
+ top_srcdir = @top_srcdir@
+ top_builddir = @top_builddir@
+
+-SAS = $(top_builddir)/bin/asx8051
+-SCC = $(top_builddir)/bin/sdcc
++SAS = asx8051
++SCC = sdcc
+
+ OBJ = crtstart.rel crtxinit.rel crtxclear.rel crtclear.rel crtxstack.rel \
+ crtpagesfr.rel crtbank.rel crtcall.rel
+diff -Nurd sdcc.orig/device/lib/pic/Makefile.common.in sdcc/device/lib/pic/Makefile.common.in
+--- sdcc.orig/device/lib/pic/Makefile.common.in 2007-05-05 09:41:17.000000000 +0200
++++ sdcc/device/lib/pic/Makefile.common.in 2008-04-01 10:10:10.375857197 +0200
+@@ -68,8 +68,8 @@
+
+ #################################################
+ ### programs to use
+-CPP = $(top_builddir)/../../../bin/sdcpp
+-CC = $(top_builddir)/../../../bin/sdcc
++CPP = sdcpp
++CC = sdcc
+ AS = @GPASM@
+ LD = @GPLINK@
+ LIB = @GPLIB@
+diff -Nurd sdcc.orig/device/lib/z80/Makefile.in sdcc/device/lib/z80/Makefile.in
+--- sdcc.orig/device/lib/z80/Makefile.in 2007-04-18 21:56:32.000000000 +0200
++++ sdcc/device/lib/z80/Makefile.in 2008-04-01 10:07:15.147644058 +0200
+@@ -5,8 +5,8 @@
+
+ TOPDIR = ../../..
+
+-SCC = $(TOPDIR)/bin/sdcc -mz80
+-SAS = $(TOPDIR)/bin/as-z80
++SCC = sdcc -mz80
++SAS = as-z80
+
+ OBJ = div.o mul.o putchar.o shift.o stubs.o crt0_rle.o heap.o fstubs.o
+
+diff -Nurd sdcc.orig/support/regression/Makefile.in sdcc/support/regression/Makefile.in
+--- sdcc.orig/support/regression/Makefile.in 2008-02-21 19:51:18.000000000 +0100
++++ sdcc/support/regression/Makefile.in 2008-04-01 10:08:38.665755305 +0200
+@@ -155,7 +155,7 @@
+
+ # Defaults. Override in spec.mk if required.
+ # Path to SDCC
+-SDCC = $(top_builddir)/bin/sdcc
++SDCC = sdcc
+ # Base flags.
+ SDCCFLAGS += --fverbose-asm -DNO_VARARGS
+ # Extension of object intermediate files
+diff -Nurd sdcc.orig/support/tests/dhrystone/Makefile sdcc/support/tests/dhrystone/Makefile
+--- sdcc.orig/support/tests/dhrystone/Makefile 2001-10-22 03:14:16.000000000 +0200
++++ sdcc/support/tests/dhrystone/Makefile 2008-04-01 10:08:55.786456870 +0200
+@@ -3,7 +3,7 @@
+
+ PROC = z80
+
+-CC = $(TOPDIR)/bin/sdcc
++CC = sdcc
+
+ # -DNOENUM is here to make the results more predictable
+ CFLAGS += -DREG= -DNOSTRUCTASSIGN -DNOENUM -V -m$(PROC) --profile --dumpall --stack-auto
diff --git a/recipes/sdcc/sdcc-native_2.5.0.bb b/recipes/sdcc/sdcc-native_2.5.0.bb
new file mode 100644
index 0000000000..3b41c33930
--- /dev/null
+++ b/recipes/sdcc/sdcc-native_2.5.0.bb
@@ -0,0 +1,16 @@
+require sdcc_${PV}.bb
+inherit native
+DEPENDS = ""
+
+# don't need native-tools patch here
+SRC_URI = "${SOURCEFORGE_MIRROR}/sdcc/sdcc-${PV}.tar.gz \
+ file://gcc4.patch;patch=1"
+
+do_stage() {
+ oe_runmake install
+}
+
+#do_stage() {
+# find bin -type f -perm -0755 -exec install -m 0755 {} ${STAGING_BINDIR} \;
+#}
+
diff --git a/recipes/sdcc/sdcc-native_2.8.0.bb b/recipes/sdcc/sdcc-native_2.8.0.bb
new file mode 100644
index 0000000000..dbecffa4e5
--- /dev/null
+++ b/recipes/sdcc/sdcc-native_2.8.0.bb
@@ -0,0 +1,16 @@
+require sdcc_${PV}.bb
+inherit native
+DEPENDS = ""
+
+# don't need native-tools patch here
+SRC_URI = "${SOURCEFORGE_MIRROR}/sdcc/sdcc-src-${PV}.tar.bz2 \
+ "
+
+do_stage() {
+ oe_runmake install
+}
+
+#do_stage() {
+# find bin -type f -perm -0755 -exec install -m 0755 {} ${STAGING_BINDIR} \;
+#}
+
diff --git a/recipes/sdcc/sdcc_2.5.0.bb b/recipes/sdcc/sdcc_2.5.0.bb
new file mode 100644
index 0000000000..3347fb9f6e
--- /dev/null
+++ b/recipes/sdcc/sdcc_2.5.0.bb
@@ -0,0 +1,21 @@
+DESCRIPTION= "SDCC - Small Device C Compiler"
+LICENSE = "GPL"
+SECTION = "devel"
+HOMEPAGE = "http://sdcc.sourceforge.net"
+DEPENDS = "sdcc-native"
+PR = "r1"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/sdcc/sdcc-${PV}.tar.gz \
+ file://gcc4.patch;patch=1 \
+ file://use-native-tools.patch;patch=1"
+S = "${WORKDIR}/sdcc"
+
+PARALLEL_MAKE = ""
+
+inherit autotools
+
+do_configure() {
+ gnu-configize
+ oe_runconf
+}
+
diff --git a/recipes/sdcc/sdcc_2.8.0.bb b/recipes/sdcc/sdcc_2.8.0.bb
new file mode 100644
index 0000000000..07993eb0a1
--- /dev/null
+++ b/recipes/sdcc/sdcc_2.8.0.bb
@@ -0,0 +1,21 @@
+DESCRIPTION= "SDCC - Small Device C Compiler"
+LICENSE = "GPL"
+SECTION = "devel"
+HOMEPAGE = "http://sdcc.sourceforge.net"
+DEPENDS = "sdcc-native"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/sdcc/sdcc-src-${PV}.tar.bz2 \
+ file://use-native-tools.patch;patch=1"
+
+S = "${WORKDIR}/sdcc"
+
+PARALLEL_MAKE = ""
+
+inherit autotools
+
+
+do_configure() {
+ gnu-configize
+ oe_runconf
+}
+