aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/sdr/hamlib_1.2.12.bb
diff options
context:
space:
mode:
authorPaul Menzel <paulepanter@users.sourceforge.net>2010-12-31 12:02:46 +0100
committerKoen Kooi <koen@openembedded.org>2010-12-31 13:33:34 +0100
commit17da16b6b1229044773661bd1060febf113297c8 (patch)
tree5ff815ac19901a919c0626c84be2ba5caebed41b /recipes/sdr/hamlib_1.2.12.bb
parent2378d69c8da90e821eeb23e840efae59fca332a6 (diff)
downloadopenembedded-17da16b6b1229044773661bd1060febf113297c8.tar.gz
hamlib: fix indentation and whitespace; move `SRC_URI[*sum]` to common place
With this patch using these recipes as templates in the future will not pass on these cosmetic errors. Signed-off-by: Paul Menzel <paulepanter@users.sourceforge.net> Signed-off-by: Koen Kooi <koen@openembedded.org>
Diffstat (limited to 'recipes/sdr/hamlib_1.2.12.bb')
-rw-r--r--recipes/sdr/hamlib_1.2.12.bb6
1 files changed, 2 insertions, 4 deletions
diff --git a/recipes/sdr/hamlib_1.2.12.bb b/recipes/sdr/hamlib_1.2.12.bb
index 69e5e6e208..f2774bf18b 100644
--- a/recipes/sdr/hamlib_1.2.12.bb
+++ b/recipes/sdr/hamlib_1.2.12.bb
@@ -17,8 +17,8 @@ do_compile_prepend() {
for i in $(find ${S} -name "Makefile") ; do
sed -i -e 's:${STAGING_LIBDIR_NATIVE}:${STAGING_LIBDIR}:g' \
-e s:-L/usr/local/lib::g \
- -e 's:\"$(CC)\":\"${CC}\" LD=\"${LD}\" LDFLAGS=\"${LDFLAGS}\":g' \
- -e s:${STAGING_INCDIR_NATIVE}/python2.6:${STAGING_INCDIR}/python2.6:g $i
+ -e 's:\"$(CC)\":\"${CC}\" LD=\"${LD}\" LDFLAGS=\"${LDFLAGS}\":g' \
+ -e s:${STAGING_INCDIR_NATIVE}/python2.6:${STAGING_INCDIR}/python2.6:g $i
done
}
@@ -35,5 +35,3 @@ python populate_packages_prepend () {
do_split_packages(d, hamlib_libdir, '^lib(.*)\.a$', 'lib%s-dev', 'hamlib %s development package', extra_depends='${PN}-dev')
do_split_packages(d, hamlib_libdir, '^lib(.*)\.so\.*', 'lib%s', 'hamlib %s library', extra_depends='', allow_links=True)
}
-
-