aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/settings-daemon
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/settings-daemon
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/settings-daemon')
-rwxr-xr-xrecipes/settings-daemon/files/70settings-daemon3
-rw-r--r--recipes/settings-daemon/settings-daemon_svn.bb23
2 files changed, 26 insertions, 0 deletions
diff --git a/recipes/settings-daemon/files/70settings-daemon b/recipes/settings-daemon/files/70settings-daemon
new file mode 100755
index 0000000000..044d88ace5
--- /dev/null
+++ b/recipes/settings-daemon/files/70settings-daemon
@@ -0,0 +1,3 @@
+#!/bin/sh
+
+/usr/bin/settings-daemon
diff --git a/recipes/settings-daemon/settings-daemon_svn.bb b/recipes/settings-daemon/settings-daemon_svn.bb
new file mode 100644
index 0000000000..27931dcd32
--- /dev/null
+++ b/recipes/settings-daemon/settings-daemon_svn.bb
@@ -0,0 +1,23 @@
+DESCRIPTION = "Settings-daemon provides a bridge between gconf and xsettings"
+LICENSE = "GPL"
+DEPENDS = "gconf glib-2.0 gtk+"
+RDEPENDS = "xrdb"
+SECTION = "x11"
+PV = "0.0+svnr${SRCREV}"
+
+PR = "r2"
+
+SRC_URI = "svn://svn.o-hand.com/repos/matchbox/trunk;module=${PN};proto=http \
+ file://70settings-daemon"
+
+S = "${WORKDIR}/${PN}"
+
+inherit autotools pkgconfig gettext gconf
+
+FILES_${PN} = "${bindir}/* ${sysconfdir}"
+
+do_install_append () {
+ install -d ${D}/${sysconfdir}/X11/Xsession.d
+ install -m 755 ${WORKDIR}/70settings-daemon ${D}/${sysconfdir}/X11/Xsession.d/
+}
+