aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/sharp-binary-only
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2010-06-02 15:04:25 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2010-06-03 07:33:27 +0200
commitd4276bed389b7db06db58c7acebb83f92bff86a5 (patch)
tree2386574b6ab0c36a58a314a24d31f6b5c9291a65 /recipes/sharp-binary-only
parent823aa270059259ca619e21a5d9b22e86afb12f3b (diff)
downloadopenembedded-d4276bed389b7db06db58c7acebb83f92bff86a5.tar.gz
recipes: conform to OE packaging guidelines with RDEPENDS/RRECOMMENDS
* there is probably very few cases when it's needed without _${PN}, if you find one in attached patch, please enlighten me * usually we want those only for ${PN} not for all ${PACKAGES} ie ${PN}-dev, ${PN)-doc etc * there is a check for this in recipe-sanity.bclass * there is maybe few possible fixes also in bbclasses cpan-base.bbclass:RDEPENDS += "${@["perl", ""][(bb.data.inherits_class('native', d))]}" distutils-base.bbclass:RDEPENDS += "python-core" gtk-icon-cache.bbclass:RDEPENDS += "hicolor-icon-theme" image.bbclass:RDEPENDS += "${IMAGE_INSTALL} ${IMAGE_BOOT}" module.bbclass:RDEPENDS += "kernel (${KERNEL_VERSION}) update-modules" ?opie_i18n.bbclass: rdepends = bb.data.getVar("RDEPENDS", d, 1) ?opie_i18n.bbclass: bb.data.setVar('RDEPENDS_%s' % x[0].lower(), pn, d) ?opie_i18n.bbclass: bb.data.setVar('RDEPENDS', rdepends, d) rubyextension.bbclass:RDEPENDS += "ruby" Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Acked-by: Koen Kooi <k-kooi@ti.com>
Diffstat (limited to 'recipes/sharp-binary-only')
-rw-r--r--recipes/sharp-binary-only/sharp-camera-support_2.4.18-rmk7-pxa3-embedix.bb2
-rw-r--r--recipes/sharp-binary-only/sharp-compat-libs_0.5.bb2
-rw-r--r--recipes/sharp-binary-only/sharp-sdmmc-support.bb2
3 files changed, 3 insertions, 3 deletions
diff --git a/recipes/sharp-binary-only/sharp-camera-support_2.4.18-rmk7-pxa3-embedix.bb b/recipes/sharp-binary-only/sharp-camera-support_2.4.18-rmk7-pxa3-embedix.bb
index 78f9d2aecd..d63b515fb1 100644
--- a/recipes/sharp-binary-only/sharp-camera-support_2.4.18-rmk7-pxa3-embedix.bb
+++ b/recipes/sharp-binary-only/sharp-camera-support_2.4.18-rmk7-pxa3-embedix.bb
@@ -2,7 +2,7 @@ DESCRIPTION = "Driver for the SHARP CG-AG06 digital compact flash camera for lin
SECTION = "kernel/modules"
PRIORITY = "optional"
LICENSE = "CLOSED"
-RDEPENDS = "kernel (${KERNEL_VERSION})"
+RDEPENDS_${PN} = "kernel (${KERNEL_VERSION})"
PR = "r4"
SRC_URI = "http://openzaurus.sf.net/mirror/camera-modules-2.4.18-rmk7-pxa3-embedix.tar.bz2 \
diff --git a/recipes/sharp-binary-only/sharp-compat-libs_0.5.bb b/recipes/sharp-binary-only/sharp-compat-libs_0.5.bb
index 9e637253af..d0541369b0 100644
--- a/recipes/sharp-binary-only/sharp-compat-libs_0.5.bb
+++ b/recipes/sharp-binary-only/sharp-compat-libs_0.5.bb
@@ -4,7 +4,7 @@ Library program in the Settings menu to make them use these libraries."
SECTION = "opie/settings"
PRIORITY = "optional"
DEPENDS = "opie-sh"
-RDEPENDS = "opie-sh"
+RDEPENDS_${PN} = "opie-sh"
RPROVIDES = "oz-compat"
RCONFLICTS = "oz-compat"
LICENSE = "GPL"
diff --git a/recipes/sharp-binary-only/sharp-sdmmc-support.bb b/recipes/sharp-binary-only/sharp-sdmmc-support.bb
index 407f71794e..7cbfc9d11b 100644
--- a/recipes/sharp-binary-only/sharp-sdmmc-support.bb
+++ b/recipes/sharp-binary-only/sharp-sdmmc-support.bb
@@ -2,7 +2,7 @@ DESCRIPTION = "Driver for the SHARP Zaurus SD/MMC Slot for linux ${PV}"
SECTION = "kernel/modules"
PRIORITY = "optional"
LICENSE = "CLOSED"
-RDEPENDS = "kernel (${PV})"
+RDEPENDS_${PN} = "kernel (${PV})"
PR = "r23"
PACKAGE_ARCH = "${MACHINE}"