aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/shr/etk-theme-shr_git.bb
diff options
context:
space:
mode:
authorStefan Schmidt <stefan@datenfreihafen.org>2009-09-17 18:12:18 +0000
committerStefan Schmidt <stefan@datenfreihafen.org>2009-09-17 18:38:25 +0000
commit08678a65e417b0826a088c3f787180ed7d77497d (patch)
tree9267aa46a121a4c5b0dd2eb54da1d740b1044e78 /recipes/shr/etk-theme-shr_git.bb
parenta86973493bcff0d87c1beb8302ab7cf8f499b8bc (diff)
downloadopenembedded-08678a65e417b0826a088c3f787180ed7d77497d.tar.gz
etk-theme-shr: Add recipe (from SHR)
Diffstat (limited to 'recipes/shr/etk-theme-shr_git.bb')
-rw-r--r--recipes/shr/etk-theme-shr_git.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/recipes/shr/etk-theme-shr_git.bb b/recipes/shr/etk-theme-shr_git.bb
new file mode 100644
index 0000000000..d146765c94
--- /dev/null
+++ b/recipes/shr/etk-theme-shr_git.bb
@@ -0,0 +1,22 @@
+DESCRIPTION = "etk SHR theme"
+SECTION = "e/utils"
+DEPENDS = "edje-native"
+LICENSE = "MIT BSD"
+PV = "1.1-${EFL_SRCREV}-gitr${SRCREV}"
+
+SRC_URI = "git://git.shr-project.org/repo/shr-themes.git;protocol=http;branch=master"
+
+S = "${WORKDIR}/git/etk/${PN}"
+
+do_compile() {
+ ${STAGING_BINDIR_NATIVE}/edje_cc -id ${S}/. -fd ${S}/. ${S}/default.edc -o ${S}/default.edj
+}
+
+do_install() {
+ install -d ${D}${datadir}/etk/themes/
+ install -m 0644 ${S}/default.edj ${D}${datadir}/etk/themes/
+}
+
+FILES_${PN} = "${datadir}/etk/themes/default.edj"
+
+