aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/shr
diff options
context:
space:
mode:
authorStefan Schmidt <stefan@datenfreihafen.org>2009-09-17 21:21:29 +0000
committerStefan Schmidt <stefan@datenfreihafen.org>2009-09-17 21:24:30 +0000
commit4884db8974dd9d3e157d9692d10266384ad5e5b7 (patch)
tree9a2279e81c77b4b91c984f14dcbdac1b067379b7 /recipes/shr
parent0bea79bae67c907cfad13b62c2df51b280d9b83d (diff)
downloadopenembedded-4884db8974dd9d3e157d9692d10266384ad5e5b7.tar.gz
libframeworkd-phonegui*: Abstraction libs for fso and efl (from SHR)
Diffstat (limited to 'recipes/shr')
-rw-r--r--recipes/shr/libframeworkd-phonegui-efl2_git.bb18
-rw-r--r--recipes/shr/libframeworkd-phonegui-efl_git.bb19
-rw-r--r--recipes/shr/libframeworkd-phonegui_git.bb15
3 files changed, 52 insertions, 0 deletions
diff --git a/recipes/shr/libframeworkd-phonegui-efl2_git.bb b/recipes/shr/libframeworkd-phonegui-efl2_git.bb
new file mode 100644
index 0000000000..207658f807
--- /dev/null
+++ b/recipes/shr/libframeworkd-phonegui-efl2_git.bb
@@ -0,0 +1,18 @@
+DESCRIPTION = "frameworkd EFL phonegui 2"
+SECTION = "e/apps"
+DEPENDS += " dbus-glib libframeworkd-glib libframeworkd-phonegui etk evas ecore edje edje-native elementary"
+PV = "0.0.1+gitr${SRCREV}"
+PR = "r1"
+
+SRC_URI = "git://shr.bearstech.com/repo/libframeworkd-phonegui-efl2.git;protocol=http;branch=master"
+S = "${WORKDIR}/git"
+
+inherit pkgconfig autotools autotools_stage
+
+EXTRA_OECONF = "--with-edje-cc=${STAGING_BINDIR_NATIVE}/edje_cc"
+
+
+do_configure_prepend() {
+ autopoint --force
+}
+
diff --git a/recipes/shr/libframeworkd-phonegui-efl_git.bb b/recipes/shr/libframeworkd-phonegui-efl_git.bb
new file mode 100644
index 0000000000..f8adabf415
--- /dev/null
+++ b/recipes/shr/libframeworkd-phonegui-efl_git.bb
@@ -0,0 +1,19 @@
+DESCRIPTION = "frameworkd EFL phonegui"
+HOMEPAGE = "http://shr-project.org/"
+LICENSE = "GPL"
+SECTION = "e/apps"
+DEPENDS += " dbus-glib libframeworkd-glib libframeworkd-phonegui etk evas ecore edje edje-native elementary"
+PV = "0.0.2+gitr${SRCREV}"
+PR = "r33"
+
+inherit pkgconfig autotools autotools_stage
+
+SRC_URI = "git://git.shr-project.org/repo/shr.git;protocol=http;branch=master"
+S = "${WORKDIR}/git/${PN}"
+
+EXTRA_OECONF = "--with-edje-cc=${STAGING_BINDIR_NATIVE}/edje_cc"
+
+do_configure_prepend() {
+ autopoint --force
+}
+
diff --git a/recipes/shr/libframeworkd-phonegui_git.bb b/recipes/shr/libframeworkd-phonegui_git.bb
new file mode 100644
index 0000000000..50b546512a
--- /dev/null
+++ b/recipes/shr/libframeworkd-phonegui_git.bb
@@ -0,0 +1,15 @@
+DESCRIPTION = "Frameworkd phonegui library"
+HOMEPAGE = "http://shr-project.org/"
+LICENSE = "GPL"
+SECTION = "libs"
+PV = "0.0.2+gitr${SRCREV}"
+PR = "r10"
+
+DEPENDS="glib-2.0 dbus-glib libframeworkd-glib libphone-utils"
+
+inherit pkgconfig autotools autotools_stage
+
+SRC_URI = "git://git.shr-project.org/repo/shr.git;protocol=http;branch=master"
+S = "${WORKDIR}/git/${PN}"
+
+CONFFILES_${PN} = "${sysconfdir}/frameworkd-phonegui.conf"