aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/shr
diff options
context:
space:
mode:
authorStefan Schmidt <stefan@datenfreihafen.org>2009-09-17 16:54:01 +0000
committerStefan Schmidt <stefan@datenfreihafen.org>2009-09-17 18:38:24 +0000
commit80c55c2574e99f025d88608966b09fcc578ed4f5 (patch)
tree955f383c21938aeda03d69fcbd34b813de808f43 /recipes/shr
parent0393c7cc15c233154ea0b8add2820eabf89d63b3 (diff)
downloadopenembedded-80c55c2574e99f025d88608966b09fcc578ed4f5.tar.gz
e-wm-theme-illume-shr: Add recipe (from SHR)
Diffstat (limited to 'recipes/shr')
-rw-r--r--recipes/shr/e-wm-theme-illume-shr_git.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/recipes/shr/e-wm-theme-illume-shr_git.bb b/recipes/shr/e-wm-theme-illume-shr_git.bb
new file mode 100644
index 0000000000..0c59feb876
--- /dev/null
+++ b/recipes/shr/e-wm-theme-illume-shr_git.bb
@@ -0,0 +1,23 @@
+DESCRIPTION = "illume SHR theme"
+SECTION = "e/utils"
+DEPENDS = "edje-native"
+LICENSE = "MIT BSD"
+PV = "1.1-${EFL_SRCREV}-gitr${SRCREV}"
+PR = "r6"
+
+SRC_URI = "git://git.shr-project.org/repo/shr-themes.git;protocol=http;branch=master"
+
+S = "${WORKDIR}/git/e-wm/${PN}"
+
+do_compile() {
+ ${STAGING_BINDIR_NATIVE}/edje_cc -id ${S}/images/. -fd ${S}/fonts/. ${S}/illume-shr.edc -o ${S}/illume-shr.edj
+}
+
+do_install() {
+ install -d ${D}${datadir}/enlightenment/data/themes/
+ install -m 0644 ${S}/illume-shr.edj ${D}${datadir}/enlightenment/data/themes/
+}
+
+FILES_${PN} = "${datadir}/enlightenment/data/themes/illume-shr.edj"
+
+