aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/simh
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/simh
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/simh')
-rw-r--r--recipes/simh/files/makefile.patch36
-rw-r--r--recipes/simh/simh_3.7-1.bb47
2 files changed, 83 insertions, 0 deletions
diff --git a/recipes/simh/files/makefile.patch b/recipes/simh/files/makefile.patch
new file mode 100644
index 0000000000..dce99d81f5
--- /dev/null
+++ b/recipes/simh/files/makefile.patch
@@ -0,0 +1,36 @@
+diff --git a/makefile b/makefile
+index 4973273..10cc672 100644
+--- a/makefile
++++ b/makefile
+@@ -10,19 +10,15 @@ OS_CCDEFS = -lsocket -lnsl -lpthread -D_GNU_SOURCE
+ else
+ OS_CCDEFS = -D_GNU_SOURCE
+ endif
+-ifeq ($(OSTYPE),macos)
+-CC = gcc -std=c99 -O2 -U__STRICT_ANSI__ -g -lm -lrt $(OS_CCDEFS) -I .
+-else
+-CC = gcc -std=c99 -O2 -U__STRICT_ANSI__ -g -lm $(OS_CCDEFS) -I .
+-endif
++CC := ${CC} -std=c99 -U__STRICT_ANSI__ -lm -lrt $(OS_CCDEFS) -I .
+ ifeq ($(USE_NETWORK),)
+ else
+-NETWORK_OPT = -DUSE_NETWORK -isystem /usr/local/include /usr/local/lib/libpcap.a
++NETWORK_OPT = -DUSE_NETWORK -DNEED_PCAP_SENDPACKET -lpcap
+ endif
+ else
+ #Win32 Environments
+ LDFLAGS = -lm -lwsock32 -lwinmm
+-CC = gcc -std=c99 -U__STRICT_ANSI__ -O0 -I.
++CC := ${CC} -std=c99 -U__STRICT_ANSI__ -O0 -I.
+ EXE = .exe
+ ifeq ($(USE_NETWORK),)
+ else
+@@ -30,6 +26,8 @@ NETWORK_OPT = -DUSE_NETWORK -lwpcap -lpacket
+ endif
+ endif
+
++CC := ${CC} ${CPPFLAGS} ${CFLAGS}
++
+ #
+ # Common Libraries
+ #
diff --git a/recipes/simh/simh_3.7-1.bb b/recipes/simh/simh_3.7-1.bb
new file mode 100644
index 0000000000..6240fed4f9
--- /dev/null
+++ b/recipes/simh/simh_3.7-1.bb
@@ -0,0 +1,47 @@
+DESCRIPTION = "The Computer History Simulation Project"
+HOMEPAGE = "http://simh.trailing-edge.com/"
+SECTION = "console/misc"
+LICENSE = "as-is"
+DEPENDS = "libpcap"
+PR = "r0"
+
+URIPV = "${@bb.data.getVar('PV',d,1).replace('.','')}"
+SRC_URI = "http://simh.trailing-edge.com/sources/simhv${URIPV}.zip \
+ file://makefile.patch;patch=1"
+S = "${WORKDIR}/${PN}-${PV}"
+
+python do_unpack() {
+ import os
+ os.mkdir(bb.data.getVar('S',d,1))
+ tmp = bb.data.createCopy(d)
+ bb.data.setVar('WORKDIR',bb.data.getVar('S',d,1),tmp)
+ bb.build.exec_func('base_do_unpack', tmp)
+}
+
+do_compile() {
+ mkdir BIN || true
+ make USE_NETWORK=1 || die "make failed"
+}
+
+do_install() {
+ install -d "${D}${bindir}"
+ cd "${S}/BIN"
+ for bin in * ; do
+ install -m 0755 "$bin" "${D}${bindir}/${PN}-${bin}"
+ done
+ install -d "${D}${datadir}/${PN}"
+ install -m 0644 ${S}/VAX/*.bin "${D}${datadir}/${PN}/"
+}
+
+PACKAGES_DYNAMIC = "simh-*"
+
+populate_packages_prepend() {
+ do_split_packages( d, bb.data.getVar('bindir',d,1), '^simh-(.*)$',
+ output_pattern='simh-%s',
+ description='SIMH for %s',
+ prepend=True, extra_depends='')
+}
+
+PACKAGES += "${PN}-vaxbin"
+
+FILES_${PN}-vaxbin = "${datadir}/${PN}"