aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/sip
diff options
context:
space:
mode:
authorNoor Ahsan <noor_ahsan@mentor.com>2010-09-05 21:12:06 +0000
committerKhem Raj <raj.khem@gmail.com>2010-09-27 17:03:50 -0700
commit6e15655f69d34cdb727f8b37d707a2b5e818670e (patch)
tree022bc9612bcb95ec019e3de3593573c9b10944d0 /recipes/sip
parentca59f2509b6eeac4879710ea9253b0f7ef35ef02 (diff)
downloadopenembedded-6e15655f69d34cdb727f8b37d707a2b5e818670e.tar.gz
sip-native: Run oe-stylize.py script on the recipe and modified the the recipe accordingly
* Run the oe-stylize.py script on the recipe and modified the recipe according to the output of the script. Signed-off-by: Noor Ahsan <noor_ahsan@mentor.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes/sip')
-rw-r--r--recipes/sip/sip-native_4.7.9.bb28
1 files changed, 14 insertions, 14 deletions
diff --git a/recipes/sip/sip-native_4.7.9.bb b/recipes/sip/sip-native_4.7.9.bb
index 0b025df602..106c81e39e 100644
--- a/recipes/sip/sip-native_4.7.9.bb
+++ b/recipes/sip/sip-native_4.7.9.bb
@@ -1,35 +1,35 @@
DESCRIPTION = "SIP is a C++/Python Wrapper Generator"
-SECTION = "devel"
-HOMEPAGE = "http://www.riverbankcomputing.co.uk/sip"
AUTHOR = "Phil Thompson"
+HOMEPAGE = "http://www.riverbankcomputing.co.uk/sip"
+SECTION = "devel"
PRIORITY = "optional"
LICENSE = "GPL"
PR = "ml0"
-DEFAULT_PREFERENCE = "-1"
-
SRC_URI = "http://www.riverbankcomputing.co.uk/static/Downloads/sip4/sip-${PV}.tar.gz"
+SRC_URI[md5sum] = "597d7ff7edb42a18421c806ffd18a136"
+SRC_URI[sha256sum] = "7faaccb6f17296399051bd076a7f41e0f6d95a28eda3e30468f1bd7cf45898e1"
+
S = "${WORKDIR}/sip-${PV}/sipgen"
inherit qt4x11 native
+EXTRA_QMAKEVARS_POST += "DESTDIR=${S} CONFIG=console"
+
export BUILD_SYS
export HOST_SYS
export STAGING_LIBDIR
export STAGING_INCDIR
-EXTRA_QMAKEVARS_POST += "DESTDIR=${S} CONFIG=console"
-
do_configure_prepend() {
- cat sipgen.sbf | sed s,target,TARGET, | sed s,sources,SOURCES, | sed s,headers,HEADERS, > sipgen.pro
+ cat sipgen.sbf | sed s,target,TARGET, | sed s,sources,SOURCES, | sed s,headers,HEADERS, > sipgen.pro
}
-
do_stage() {
- install -m 0755 sip ${STAGING_BINDIR_NATIVE}/sip
- cd ${WORKDIR}/sip-${PV} && python configure.py
- install -d ${STAGING_PYDIR}/site-packages
- install -m 0755 sip*.py ${STAGING_PYDIR}/site-packages
+ install -m 0755 sip ${STAGING_BINDIR_NATIVE}/sip
+ cd ${WORKDIR}/sip-${PV} && python configure.py
+ install -d ${STAGING_PYDIR}/site-packages
+ install -m 0755 sip*.py ${STAGING_PYDIR}/site-packages
}
-SRC_URI[md5sum] = "597d7ff7edb42a18421c806ffd18a136"
-SRC_URI[sha256sum] = "7faaccb6f17296399051bd076a7f41e0f6d95a28eda3e30468f1bd7cf45898e1"
+DEFAULT_PREFERENCE = "-1"
+