aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/skippy
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/skippy
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/skippy')
-rw-r--r--recipes/skippy/files/event_base.patch11
-rw-r--r--recipes/skippy/files/fix-makefile.patch37
-rw-r--r--recipes/skippy/skippy-xd_0.5.0.bb18
3 files changed, 66 insertions, 0 deletions
diff --git a/recipes/skippy/files/event_base.patch b/recipes/skippy/files/event_base.patch
new file mode 100644
index 0000000000..20632edf15
--- /dev/null
+++ b/recipes/skippy/files/event_base.patch
@@ -0,0 +1,11 @@
+--- skippy-xd-0.5.0/mainwin.c.old 2005-04-29 03:54:32 +01:00
++++ skippy-xd-0.5.0/mainwin.c 2005-04-29 03:55:06 +01:00
+@@ -67,7 +67,7 @@
+ XRenderPictureAttributes pa;
+ XRenderColor clear;
+ int error_base;
+-#ifdef XINERAMA
++#if 1
+ int event_base;
+ #endif /* XINERAMA */
+
diff --git a/recipes/skippy/files/fix-makefile.patch b/recipes/skippy/files/fix-makefile.patch
new file mode 100644
index 0000000000..843be52467
--- /dev/null
+++ b/recipes/skippy/files/fix-makefile.patch
@@ -0,0 +1,37 @@
+--- skippy-xd-0.5.0/Makefile.old 2005-04-29 03:42:33 +01:00
++++ skippy-xd-0.5.0/Makefile 2005-04-29 03:45:21 +01:00
+@@ -1,17 +1,17 @@
+-PREFIX = /usr/local
+-BINDIR = ${PREFIX}/bin
++#PREFIX = /usr
++#BINDIR = ${PREFIX}/bin
+
+-X11PREFIX = /usr/X11R6
++#X11PREFIX = /usr/X11R6
+
+-CFLAGS += -I${X11PREFIX}/include `pkg-config xft xrender xcomposite xdamage xfixes --cflags` -g -pedantic -Wall
+-LDFLAGS += -L${X11PREFIX}/lib -lX11 -lm `pkg-config xft xrender xcomposite xdamage xfixes --libs`
++CFLAGS += `${PKG_CONFIG} xft xrender xcomposite xdamage xfixes --cflags` -Wall
++LDFLAGS += -lX11 -lm `${PKG_CONFIG} xft xrender xcomposite xdamage xfixes --libs`
+
+ # Disable post-processing effects
+-# CFLAGS += -DNOEFFECTS
++CFLAGS += -DNOEFFECTS
+
+ # Comment these out to disable Xinerama support
+-CFLAGS += -DXINERAMA
+-LDFLAGS += -lXext -lXinerama
++#CFLAGS += -DXINERAMA
++#LDFLAGS += -lXext -lXinerama
+
+ # Uncomment this for Xinerama debugging
+ #CFLAGS += -DDEBUG
+@@ -24,7 +24,7 @@
+ all: skippy-xd${EXESUFFIX}
+
+ skippy-xd${EXESUFFIX}: Makefile ${SOURCES} ${HEADERS}
+- gcc ${CFLAGS} -o skippy-xd${EXESUFFIX} ${SOURCES} ${LDFLAGS}
++ ${CC} ${CFLAGS} -o skippy-xd${EXESUFFIX} ${SOURCES} ${LDFLAGS}
+
+ clean:
+ rm -f skippy-xd${EXESUFFIX}
diff --git a/recipes/skippy/skippy-xd_0.5.0.bb b/recipes/skippy/skippy-xd_0.5.0.bb
new file mode 100644
index 0000000000..c5ed177aa6
--- /dev/null
+++ b/recipes/skippy/skippy-xd_0.5.0.bb
@@ -0,0 +1,18 @@
+LICENSE = "GPLV2"
+DESCRIPTION = "Skippy is a full-screen task-switcher for X11."
+SECTION = "x11"
+DEPENDS = "virtual/xserver libxdamage libxcomposite"
+
+inherit pkgconfig
+
+SRC_URI = "http://thegraveyard.org/files/${PN}-${PV}.tar.bz2 \
+ file://fix-makefile.patch;patch=1 \
+ file://event_base.patch;patch=1"
+
+EXTRA_OEMAKE = "X11PREFIX='${STAGING_DIR_TARGET}${layout_prefix}' PKG_CONFIG='${STAGING_BINDIR_NATIVE}/pkg-config'"
+CFLAGS_append = " -I${STAGING_INCDIR}/X11"
+LDFLAGS_append = " -L${STAGING_LIBDIR}/X11"
+
+do_install() {
+ oe_runmake 'BINDIR=${D}${bindir}' install
+}