aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/slang/slang_1.4.9.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/slang/slang_1.4.9.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/slang/slang_1.4.9.bb')
-rw-r--r--recipes/slang/slang_1.4.9.bb37
1 files changed, 37 insertions, 0 deletions
diff --git a/recipes/slang/slang_1.4.9.bb b/recipes/slang/slang_1.4.9.bb
new file mode 100644
index 0000000000..492bd7d9a0
--- /dev/null
+++ b/recipes/slang/slang_1.4.9.bb
@@ -0,0 +1,37 @@
+DESCRIPTION = "slang is a library of text functions used in editors like slrn etc."
+SECTION = "libs"
+PRIORITY = "optional"
+PR = "r1"
+LICENSE = "GPL Artistic"
+SRC_URI = "ftp://space.mit.edu/pub/davis/slang/v1.4/slang-${PV}.tar.bz2 \
+ file://configure.patch;patch=1 \
+ file://Makefile.patch;patch=1"
+inherit autotools
+
+acpaths = "-I ${S}/autoconf"
+EXTRA_OECONF="--enable-warnings"
+CFLAGS_append=" -fno-strength-reduce -D_REENTRANT"
+LDFLAGS_prepend="-L${S}/src/elfobjs "
+EXTRA_OEMAKE="'ELF_CFLAGS=${CFLAGS} -fPIC' 'ELF_CC=${CC}' \
+ 'ELF_LINK=${CC} -shared -Wl,-soname'"
+
+do_configure_prepend () {
+ mv ${S}/autoconf/aclocal.m4 ${S}/autoconf/acinclude.m4
+}
+
+do_compile () {
+ oe_runmake all
+ oe_runmake elf
+# oe_runmake demos
+}
+
+do_stage () {
+ oe_libinstall -so -C src/elfobjs libslang ${STAGING_LIBDIR}
+ oe_libinstall -a -C src/objs libslang ${STAGING_LIBDIR}
+ install -m 0644 src/slang.h ${STAGING_INCDIR}
+ install -m 0644 src/slcurses.h ${STAGING_INCDIR}
+}
+
+do_install () {
+ oe_runmake 'DESTDIR=${D}' install install-elf
+}