summaryrefslogtreecommitdiffstats
path: root/recipes/slang
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/slang
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/slang')
-rw-r--r--recipes/slang/slang/Makefile.patch26
-rw-r--r--recipes/slang/slang/configure.patch157
-rw-r--r--recipes/slang/slang_1.4.9.bb37
3 files changed, 220 insertions, 0 deletions
diff --git a/recipes/slang/slang/Makefile.patch b/recipes/slang/slang/Makefile.patch
new file mode 100644
index 0000000000..a79b2b9ae3
--- /dev/null
+++ b/recipes/slang/slang/Makefile.patch
@@ -0,0 +1,26 @@
+--- slang-1.4.9/autoconf/Makefile.in.orig 2004-09-24 15:51:57.054180737 +0100
++++ slang-1.4.9/autoconf/Makefile.in 2004-09-24 15:52:47.065068195 +0100
+@@ -13,12 +13,12 @@
+ @echo Use make install-elf to install it.
+ runtests:
+ cd src; $(MAKE) runtests
+-demos:
+- cd demo; $(MAKE)
++#demos:
++# cd demo; $(MAKE)
+ clean:
+ /bin/rm -f *~
+ cd src; $(MAKE) clean
+- cd demo; $(MAKE) clean
++# cd demo; $(MAKE) clean
+ install:
+ cd src; $(MAKE) install
+ install-elf:
+@@ -32,6 +32,6 @@
+ distclean:
+ /bin/rm -f *~ Makefile config.status config.log config.cache files.pck
+ cd src; $(MAKE) distclean
+- cd demo; $(MAKE) distclean
++# cd demo; $(MAKE) distclean
+ #
+
diff --git a/recipes/slang/slang/configure.patch b/recipes/slang/slang/configure.patch
new file mode 100644
index 0000000000..e2d78acb72
--- /dev/null
+++ b/recipes/slang/slang/configure.patch
@@ -0,0 +1,157 @@
+--- slang-1.4.9/configure.orig 2004-09-24 14:12:25.619997396 +0100
++++ slang-1.4.9/configure 2004-09-24 14:15:25.579414174 +0100
+@@ -2457,7 +2457,7 @@
+
+
+
+-subdirs="demo"
++#subdirs="demo"
+
+
+ trap '' 1 2 15
+@@ -2876,76 +2876,76 @@
+ esac
+ done
+
+- for ac_config_dir in demo; do
+-
+- # Do not complain, so a configure script can configure whichever
+- # parts of a large source tree are present.
+- if test ! -d $srcdir/$ac_config_dir; then
+- continue
+- fi
+-
+- echo configuring in $ac_config_dir
+-
+- case "$srcdir" in
+- .) ;;
+- *)
+- if test -d ./$ac_config_dir || mkdir ./$ac_config_dir; then :;
+- else
+- { echo "configure: error: can not create `pwd`/$ac_config_dir" 1>&2; exit 1; }
+- fi
+- ;;
+- esac
+-
+- ac_popdir=`pwd`
+- cd $ac_config_dir
+-
+- # A "../" for each directory in /$ac_config_dir.
+- ac_dots=`echo $ac_config_dir|sed -e 's%^\./%%' -e 's%[^/]$%&/%' -e 's%[^/]*/%../%g'`
+-
+- case "$srcdir" in
+- .) # No --srcdir option. We are building in place.
+- ac_sub_srcdir=$srcdir ;;
+- /*) # Absolute path.
+- ac_sub_srcdir=$srcdir/$ac_config_dir ;;
+- *) # Relative path.
+- ac_sub_srcdir=$ac_dots$srcdir/$ac_config_dir ;;
+- esac
+-
+- # Check for guested configure; otherwise get Cygnus style configure.
+- if test -f $ac_sub_srcdir/configure; then
+- ac_sub_configure=$ac_sub_srcdir/configure
+- elif test -f $ac_sub_srcdir/configure.in; then
+- ac_sub_configure=$ac_configure
+- else
+- echo "configure: warning: no configuration information is in $ac_config_dir" 1>&2
+- ac_sub_configure=
+- fi
+-
+- # The recursion is here.
+- if test -n "$ac_sub_configure"; then
+-
+- # Make the cache file name correct relative to the subdirectory.
+- case "$cache_file" in
+- /*) ac_sub_cache_file=$cache_file ;;
+- *) # Relative path.
+- ac_sub_cache_file="$ac_dots$cache_file" ;;
+- esac
+- case "$ac_given_INSTALL" in
+- [/$]*) INSTALL="$ac_given_INSTALL" ;;
+- *) INSTALL="$ac_dots$ac_given_INSTALL" ;;
+- esac
+-
+- echo "running ${CONFIG_SHELL-/bin/sh} $ac_sub_configure $ac_sub_configure_args --cache-file=$ac_sub_cache_file --srcdir=$ac_sub_srcdir"
++# for ac_config_dir in demo; do
++#
++# # Do not complain, so a configure script can configure whichever
++# # parts of a large source tree are present.
++# if test ! -d $srcdir/$ac_config_dir; then
++# continue
++# fi
++#
++# echo configuring in $ac_config_dir
++#
++# case "$srcdir" in
++# .) ;;
++# *)
++# if test -d ./$ac_config_dir || mkdir ./$ac_config_dir; then :;
++# else
++# { echo "configure: error: can not create `pwd`/$ac_config_dir" 1>&2; exit 1; }
++# fi
++# ;;
++# esac
++#
++# ac_popdir=`pwd`
++# cd $ac_config_dir
++#
++# # A "../" for each directory in /$ac_config_dir.
++# ac_dots=`echo $ac_config_dir|sed -e 's%^\./%%' -e 's%[^/]$%&/%' -e 's%[^/]*/%../%g'`
++#
++# case "$srcdir" in
++# .) # No --srcdir option. We are building in place.
++# ac_sub_srcdir=$srcdir ;;
++# /*) # Absolute path.
++# ac_sub_srcdir=$srcdir/$ac_config_dir ;;
++# *) # Relative path.
++# ac_sub_srcdir=$ac_dots$srcdir/$ac_config_dir ;;
++# esac
++#
++# # Check for guested configure; otherwise get Cygnus style configure.
++# if test -f $ac_sub_srcdir/configure; then
++# ac_sub_configure=$ac_sub_srcdir/configure
++# elif test -f $ac_sub_srcdir/configure.in; then
++# ac_sub_configure=$ac_configure
++# else
++# echo "configure: warning: no configuration information is in $ac_config_dir" 1>&2
++# ac_sub_configure=
++# fi
++#
++# # The recursion is here.
++# if test -n "$ac_sub_configure"; then
++#
++# # Make the cache file name correct relative to the subdirectory.
++# case "$cache_file" in
++# /*) ac_sub_cache_file=$cache_file ;;
++# *) # Relative path.
++# ac_sub_cache_file="$ac_dots$cache_file" ;;
++# esac
++# case "$ac_given_INSTALL" in
++# [/$]*) INSTALL="$ac_given_INSTALL" ;;
++# *) INSTALL="$ac_dots$ac_given_INSTALL" ;;
++# esac
++#
++# echo "running ${CONFIG_SHELL-/bin/sh} $ac_sub_configure $ac_sub_configure_args --cache-file=$ac_sub_cache_file --srcdir=$ac_sub_srcdir"
+ # The eval makes quoting arguments work.
+- if eval ${CONFIG_SHELL-/bin/sh} $ac_sub_configure $ac_sub_configure_args --cache-file=$ac_sub_cache_file --srcdir=$ac_sub_srcdir
+- then :
+- else
+- { echo "configure: error: $ac_sub_configure failed for $ac_config_dir" 1>&2; exit 1; }
+- fi
+- fi
+-
+- cd $ac_popdir
+- done
++# if eval ${CONFIG_SHELL-/bin/sh} $ac_sub_configure $ac_sub_configure_args --cache-file=$ac_sub_cache_file --srcdir=$ac_sub_srcdir
++# then :
++# else
++# { echo "configure: error: $ac_sub_configure failed for $ac_config_dir" 1>&2; exit 1; }
++# fi
++# fi
++#
++# cd $ac_popdir
++# done
+ fi
+
+
diff --git a/recipes/slang/slang_1.4.9.bb b/recipes/slang/slang_1.4.9.bb
new file mode 100644
index 0000000000..492bd7d9a0
--- /dev/null
+++ b/recipes/slang/slang_1.4.9.bb
@@ -0,0 +1,37 @@
+DESCRIPTION = "slang is a library of text functions used in editors like slrn etc."
+SECTION = "libs"
+PRIORITY = "optional"
+PR = "r1"
+LICENSE = "GPL Artistic"
+SRC_URI = "ftp://space.mit.edu/pub/davis/slang/v1.4/slang-${PV}.tar.bz2 \
+ file://configure.patch;patch=1 \
+ file://Makefile.patch;patch=1"
+inherit autotools
+
+acpaths = "-I ${S}/autoconf"
+EXTRA_OECONF="--enable-warnings"
+CFLAGS_append=" -fno-strength-reduce -D_REENTRANT"
+LDFLAGS_prepend="-L${S}/src/elfobjs "
+EXTRA_OEMAKE="'ELF_CFLAGS=${CFLAGS} -fPIC' 'ELF_CC=${CC}' \
+ 'ELF_LINK=${CC} -shared -Wl,-soname'"
+
+do_configure_prepend () {
+ mv ${S}/autoconf/aclocal.m4 ${S}/autoconf/acinclude.m4
+}
+
+do_compile () {
+ oe_runmake all
+ oe_runmake elf
+# oe_runmake demos
+}
+
+do_stage () {
+ oe_libinstall -so -C src/elfobjs libslang ${STAGING_LIBDIR}
+ oe_libinstall -a -C src/objs libslang ${STAGING_LIBDIR}
+ install -m 0644 src/slang.h ${STAGING_INCDIR}
+ install -m 0644 src/slcurses.h ${STAGING_INCDIR}
+}
+
+do_install () {
+ oe_runmake 'DESTDIR=${D}' install install-elf
+}