aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/socketcan
diff options
context:
space:
mode:
authorVitus Jensen <vjensen@gmx.de>2010-05-21 04:38:04 +0000
committerEric Bénard <eric@eukrea.com>2010-06-03 21:46:24 +0200
commitd76f5695523ccf8755db393fbd41815c1fa011de (patch)
tree1dd0c73c7964bdc3c09410be1ad4024598b46c51 /recipes/socketcan
parent92d5f445955dbf49ba509863b27657f4d5757c39 (diff)
downloadopenembedded-d76f5695523ccf8755db393fbd41815c1fa011de.tar.gz
libsocketcan: new recipes
Build pengutronix' libsocketcan (netlink interface), used by newer versions of canutils. can_netlink.h is really linux/can/netlink.h from linux-libc-headers but installed here to be independ of staged linux-libc-headers versions. libsocketcan 0.0.8 automatically installs can_netlink.h, version 0.0.7 is patched to do so. Signed-off-by: Vitus Jensen <vjensen@gmx.de> Signed-off-by: Eric Bénard <eric@eukrea.com>
Diffstat (limited to 'recipes/socketcan')
-rw-r--r--recipes/socketcan/files/install-can_netlink.h.patch21
-rw-r--r--recipes/socketcan/libsocketcan.inc16
-rw-r--r--recipes/socketcan/libsocketcan_0.0.7.bb7
-rw-r--r--recipes/socketcan/libsocketcan_0.0.8.bb4
4 files changed, 48 insertions, 0 deletions
diff --git a/recipes/socketcan/files/install-can_netlink.h.patch b/recipes/socketcan/files/install-can_netlink.h.patch
new file mode 100644
index 0000000000..36f5e10f7b
--- /dev/null
+++ b/recipes/socketcan/files/install-can_netlink.h.patch
@@ -0,0 +1,21 @@
+commit 2470d91a6254b062aae8ab6120795a0f28344687
+Author: Vitus Jensen <vitus@vitus.devnet.local>
+Date: Tue May 18 16:59:01 2010 +0200
+
+ install can_netlink.h
+
+diff --git a/include/GNUmakefile.am b/include/GNUmakefile.am
+index 4ba2798..eb35a3a 100644
+--- a/include/GNUmakefile.am
++++ b/include/GNUmakefile.am
+@@ -1,8 +1,6 @@
+-noinst_HEADERS = \
+- can_netlink.h
+-
+ nobase_include_HEADERS = \
+- libsocketcan.h
++ libsocketcan.h \
++ can_netlink.h
+
+ MAINTAINERCLEANFILES = \
+ libsocketcan_config.h.in \
diff --git a/recipes/socketcan/libsocketcan.inc b/recipes/socketcan/libsocketcan.inc
new file mode 100644
index 0000000000..367766c54a
--- /dev/null
+++ b/recipes/socketcan/libsocketcan.inc
@@ -0,0 +1,16 @@
+DESCRIPTION = "Control basic functions in socketcan from userspace"
+AUTHOR = "Luotao Fu"
+HOMEPAGE = "http://www.pengutronix.de"
+SECTION = "libs/network"
+PRIORITY = "optional"
+LICENSE = "LGPL"
+
+TAG = "v${PV}"
+INC_PR = "r0"
+
+SRC_URI = "git://git.pengutronix.de/git/tools/libsocketcan.git;protocol=git;tag=${TAG} \
+ "
+
+S = "${WORKDIR}/git"
+
+inherit autotools_stage pkgconfig
diff --git a/recipes/socketcan/libsocketcan_0.0.7.bb b/recipes/socketcan/libsocketcan_0.0.7.bb
new file mode 100644
index 0000000000..18f607e9ae
--- /dev/null
+++ b/recipes/socketcan/libsocketcan_0.0.7.bb
@@ -0,0 +1,7 @@
+TAG = "v${PV}"
+require libsocketcan.inc
+
+PR = "${INC_PR}.0"
+
+SRC_URI += "file://install-can_netlink.h.patch;apply=yes \
+ "
diff --git a/recipes/socketcan/libsocketcan_0.0.8.bb b/recipes/socketcan/libsocketcan_0.0.8.bb
new file mode 100644
index 0000000000..5598a0f582
--- /dev/null
+++ b/recipes/socketcan/libsocketcan_0.0.8.bb
@@ -0,0 +1,4 @@
+TAG = "v${PV}"
+require libsocketcan.inc
+
+PR = "${INC_PR}.0"