aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/spca5xx
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/spca5xx
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/spca5xx')
-rw-r--r--recipes/spca5xx/spca5xx-20060501/Makefile.patch19
-rw-r--r--recipes/spca5xx/spca5xx_20060501.bb24
2 files changed, 43 insertions, 0 deletions
diff --git a/recipes/spca5xx/spca5xx-20060501/Makefile.patch b/recipes/spca5xx/spca5xx-20060501/Makefile.patch
new file mode 100644
index 0000000000..8053858ee1
--- /dev/null
+++ b/recipes/spca5xx/spca5xx-20060501/Makefile.patch
@@ -0,0 +1,19 @@
+*** spca5xx-20060202/Makefile.orig Thu Feb 2 21:33:18 2006
+--- spca5xx-20060202/Makefile Sun Feb 19 12:39:35 2006
+***************
+*** 51,57 ****
+ default:
+ @echo ' Building SPCA5XX driver for 2.5/2.6 kernel.'
+ @echo ' Remember: you must have read/write access to your kernel source tree.'
+! $(MAKE) -C $(KERNELDIR) SUBDIRS=$(PWD) CC=$(CC) modules
+
+ install:
+ mkdir -p $(MODULE_INSTALLDIR)
+--- 51,57 ----
+ default:
+ @echo ' Building SPCA5XX driver for 2.5/2.6 kernel.'
+ @echo ' Remember: you must have read/write access to your kernel source tree.'
+! $(MAKE) -C $(KERNELDIR) SUBDIRS=$(PWD) CC="$(CC)" modules
+
+ install:
+ mkdir -p $(MODULE_INSTALLDIR)
diff --git a/recipes/spca5xx/spca5xx_20060501.bb b/recipes/spca5xx/spca5xx_20060501.bb
new file mode 100644
index 0000000000..3e523c83a8
--- /dev/null
+++ b/recipes/spca5xx/spca5xx_20060501.bb
@@ -0,0 +1,24 @@
+DESCRIPTION = "USB Webcam driver for spca5xx chipset family supporting \
+over 100 models of camera"
+PRIORITY = "optional"
+SECTION = "kernel/modules"
+LICENSE = "GPL"
+
+SRC_URI = "http://mxhaard.free.fr/spca50x/Download/spca5xx-${PV}.tar.gz \
+ file://Makefile.patch;patch=1"
+
+S = "${WORKDIR}/spca5xx-${PV}"
+
+inherit module
+
+do_compile () {
+ unset CFLAGS CPPFLAGS CXXFLAGS LDFLAGS
+ oe_runmake 'KERNELDIR=${STAGING_KERNEL_DIR}' \
+ 'CC=${KERNEL_CC}' \
+ 'LD=${KERNEL_LD}'
+}
+
+do_install() {
+ install -d ${D}${base_libdir}/modules/${KERNEL_VERSION}/kernel/drivers/usb/media
+ install -m 0644 *${KERNEL_OBJECT_SUFFIX} ${D}${base_libdir}/modules/${KERNEL_VERSION}/kernel/drivers/usb/media
+}