aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/splashutils
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/splashutils
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/splashutils')
-rw-r--r--recipes/splashutils/splashutils_1.5.4.2.bb42
1 files changed, 42 insertions, 0 deletions
diff --git a/recipes/splashutils/splashutils_1.5.4.2.bb b/recipes/splashutils/splashutils_1.5.4.2.bb
new file mode 100644
index 0000000000..36c11ab2de
--- /dev/null
+++ b/recipes/splashutils/splashutils_1.5.4.2.bb
@@ -0,0 +1,42 @@
+DESCRIPTION = "Framebuffer splash utilities."
+SECTION = "media-gfx"
+LICENSE = "GPL"
+PR = "r0"
+
+SRC_URI = "http://dev.gentoo.org/~spock/projects/gensplash/archive/splashutils-${PV}.tar.bz2"
+
+DEPENDS = "jpeg klibc"
+
+inherit autotools
+
+PARALLEL_MAKE = ""
+
+# klcc doesn't work with -isystem
+export TARGET_CPPFLAGS = "-I${STAGING_DIR_TARGET}/${layout_includedir}"
+export BUILD_CPPFLAGS = "-I${STAGING_DIR_NATIVE}${layout_includedir}"
+
+do_configure_prepend() {
+ if [ -f "${S}"/src/Makefile.am ] ; then
+ sed -i "s#^INCLUDES = \(.*\)#INCLUDES = \1 $CPPFLAGS#" "${S}"/src/Makefile.am
+ fi
+}
+
+EXTRA_OECONF = "--without-gpm --without-png --without-mng --without-ttf --without-ttf-kernel"
+
+# fbcondecor_helper is also useful outside of the main package.
+RDEPENDS_${PN} = "${PN}-helper"
+
+PACKAGES =+ "${PN}-helper"
+FILES_${PN}-helper = "${base_sbindir}/fbcondecor_helper ${base_sbindir}/splash_helper"
+FILES_${PN} += "/lib"
+
+do_install_append () {
+ if [ -f "${S}"/debian/splashutils.dirs ] ; then
+ for dir in $(cat debian/splashutils.dirs) ; do
+ mkdir -p ${D}/$dir
+ done
+ fi
+
+ ln -s fbcondecor_helper ${D}${base_sbindir}/splash_helper
+
+}