summaryrefslogtreecommitdiffstats
path: root/recipes/squashfs-tools/files/Makefile-3.1.patch
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/squashfs-tools/files/Makefile-3.1.patch
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/squashfs-tools/files/Makefile-3.1.patch')
-rw-r--r--recipes/squashfs-tools/files/Makefile-3.1.patch34
1 files changed, 34 insertions, 0 deletions
diff --git a/recipes/squashfs-tools/files/Makefile-3.1.patch b/recipes/squashfs-tools/files/Makefile-3.1.patch
new file mode 100644
index 0000000000..1b7c49878f
--- /dev/null
+++ b/recipes/squashfs-tools/files/Makefile-3.1.patch
@@ -0,0 +1,34 @@
+Modifies the Makefile to work with OpenEmbedded.
+
+I copied the CFLAGS_R approach from the existing 2.0 squashfs-tools,
+without actually knowing why this approach was taken. It works though.
+
+Leon Woestenberg <leonw@mailcan.com>
+
+--- squashfs-tools/Makefile 2006-10-10 13:59:05.000000000 +0200
++++ squashfs-tools/Makefile.oe 2006-10-10 14:06:01.000000000 +0200
+@@ -1,17 +1,22 @@
+ INCLUDEDIR = .
++CFLAGS_R = -I$(INCLUDEDIR) -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE
++LIBS = -lz -lpthread
+
+ CFLAGS := -I$(INCLUDEDIR) -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -O2
+
+ all: mksquashfs unsquashfs
+
+ mksquashfs: mksquashfs.o read_fs.o sort.o
+- $(CC) mksquashfs.o read_fs.o sort.o -lz -lpthread -o $@
++ $(CC) $(LDFLAGS) mksquashfs.o read_fs.o sort.o $(LIBS) -o $@
+
+ mksquashfs.o: mksquashfs.c squashfs_fs.h mksquashfs.h global.h sort.h
++ $(CC) $(CFLAGS_R) $(CFLAGS) -c -o mksquashfs.o mksquashfs.c
+
+ read_fs.o: read_fs.c squashfs_fs.h read_fs.h global.h
+-
++ $(CC) $(CFLAGS_R) $(CFLAGS) -c -o read_fs.o read_fs.c
++
+ sort.o: sort.c squashfs_fs.h global.h sort.h
++ $(CC) $(CFLAGS_R) $(CFLAGS) -c -o sort.o sort.c
+
+ unsquashfs: unsquashfs.o
+ $(CC) unsquashfs.o -lz -o $@