aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/squashfs-tools/squashfs-tools_4.0.bb
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2009-09-27 21:36:29 -0300
committerOtavio Salvador <otavio@ossystems.com.br>2009-10-29 20:43:50 -0200
commit0456b5ee381e55383249782a2e7ac6e4de60e746 (patch)
tree196d4868a2f89f944618176ddee75398fb98754d /recipes/squashfs-tools/squashfs-tools_4.0.bb
parentc99bb48707c79be34d897f33e67f2f87397096c8 (diff)
downloadopenembedded-0456b5ee381e55383249782a2e7ac6e4de60e746.tar.gz
squashfs-tools: add lzma support in 4.0 version
This added lzma by default since squashfs-tools is not common to be installed into a image and it doesn't increase the compilation time a lot. Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes/squashfs-tools/squashfs-tools_4.0.bb')
-rw-r--r--recipes/squashfs-tools/squashfs-tools_4.0.bb9
1 files changed, 8 insertions, 1 deletions
diff --git a/recipes/squashfs-tools/squashfs-tools_4.0.bb b/recipes/squashfs-tools/squashfs-tools_4.0.bb
index 0de5794b95..a4503fcf0f 100644
--- a/recipes/squashfs-tools/squashfs-tools_4.0.bb
+++ b/recipes/squashfs-tools/squashfs-tools_4.0.bb
@@ -1,5 +1,12 @@
require squashfs-tools.inc
+DEPENDS += "lzma"
PR = "${INC_PR}.1"
+EXTRA_OEMAKE = "USE_LZMA=1 \
+ LZMA_CFLAGS='-I${STAGING_INCDIR}/lzma -DUSE_LZMA' \
+ LZMA_LIB='${STAGING_LIBDIR}/liblzma.a'"
+
DEFAULT_PREFERENCE = "-1"
-SRC_URI += " file://Makefile.patch;patch=1"
+SRC_URI += " file://portability.patch;patch=1;pnum=2 \
+ file://lzma-support.patch;patch=1;pnum=2"
+