aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/squeezeclient/squeezeslave_svn.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/squeezeclient/squeezeslave_svn.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/squeezeclient/squeezeslave_svn.bb')
-rw-r--r--recipes/squeezeclient/squeezeslave_svn.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/recipes/squeezeclient/squeezeslave_svn.bb b/recipes/squeezeclient/squeezeslave_svn.bb
new file mode 100644
index 0000000000..acdbc656da
--- /dev/null
+++ b/recipes/squeezeclient/squeezeslave_svn.bb
@@ -0,0 +1,32 @@
+SECTION = "console/multimedia"
+DESCRIPTION = "command line audio playback client for SlimServer"
+LICENSE = "GPL"
+DEPENDS += "flac libvorbis \
+ ${@base_conditional('ENTERPRISE_DISTRO', '1', '', 'libmad', d)}"
+PV = "3.0+svn-${SRCDATE}"
+PR = "r1"
+
+SRC_URI = "svn://svn.slimdevices.com/repos/slim/trunk/;module=softsqueeze;proto=http \
+ file://varinit.patch;patch=1 \
+ file://runfix.patch;patch=1 \
+ file://makefile.patch;patch=1"
+
+
+S = "${WORKDIR}/softsqueeze/SlimProtoLib"
+
+CFLAGS += "-D_GNU_SOURCE"
+
+inherit autotools
+
+do_compile() {
+ oe_runmake LDFLAGS=${TARGET_LDFLAGS} -f makefile.linux
+}
+
+do_install() {
+ install -d ${D}/${bindir}
+ install -m 0755 bin/squeezeslave ${D}/${bindir}
+ oe_libinstall -C lib -so libslimproto ${D}${libdir}
+ oe_libinstall -C lib -so libportaudio ${D}${libdir}
+ oe_libinstall -C lib -so libportmixer ${D}${libdir}
+}
+