aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/squid/squid-3.1.9
diff options
context:
space:
mode:
authorCliff Brake <cbrake@bec-systems.com>2010-11-12 00:00:20 -0500
committerCliff Brake <cbrake@bec-systems.com>2010-11-12 00:00:20 -0500
commit3c6efe8f8abc16668ca5e9cdf7a46665dac87172 (patch)
tree642c13416b99e80f0871cdc6668e832e635dfb48 /recipes/squid/squid-3.1.9
parentc400c874f2ac9233b8a43a73309b6e7907289c54 (diff)
parent13fbe7253c95881ede787004a4c3a1c31502e5c6 (diff)
downloadopenembedded-3c6efe8f8abc16668ca5e9cdf7a46665dac87172.tar.gz
Merge branch 'master' into testing-nexttested_2010-11-12testing
Diffstat (limited to 'recipes/squid/squid-3.1.9')
-rw-r--r--recipes/squid/squid-3.1.9/fix-runs-in-configure.patch80
-rw-r--r--recipes/squid/squid-3.1.9/squidv3-build-cf_gen.patch33
2 files changed, 113 insertions, 0 deletions
diff --git a/recipes/squid/squid-3.1.9/fix-runs-in-configure.patch b/recipes/squid/squid-3.1.9/fix-runs-in-configure.patch
new file mode 100644
index 0000000000..35744a3f68
--- /dev/null
+++ b/recipes/squid/squid-3.1.9/fix-runs-in-configure.patch
@@ -0,0 +1,80 @@
+Index: squid-3.1.8/configure.in
+===================================================================
+--- squid-3.1.8.orig/configure.in 2010-09-13 17:51:04.000000000 +0400
++++ squid-3.1.8/configure.in 2010-09-13 17:53:04.000000000 +0400
+@@ -364,10 +364,6 @@
+ fi
+ ])
+
+-dnl Nasty hack to get autoconf 2.64 on Linux to run.
+-dnl all other uses of RUN_IFELSE are wrapped inside CACHE_CHECK which breaks on 2.64
+-AC_RUN_IFELSE([AC_LANG_SOURCE([[ int main(int argc, char **argv) { return 0; } ]])],[],[],[:])
+-
+ dnl This is a developer only option.. developers know how to set defines
+ dnl
+ dnl AC_ARG_ENABLE(xmalloc-debug,
+@@ -1318,7 +1314,7 @@
+ dnl Verify that epoll really works
+ if test $ac_cv_func_epoll_ctl = yes; then
+ AC_CACHE_CHECK(if epoll works, ac_cv_epoll_works,
+- AC_RUN_IFELSE([AC_LANG_SOURCE([[
++ AC_COMPILE_IFELSE([AC_LANG_SOURCE([[
+ #include <sys/epoll.h>
+ #include <stdlib.h>
+ #include <stdio.h>
+@@ -3072,7 +3068,7 @@
+ dnl setresuid() but doesn't implement it.
+ dnl
+ AC_CACHE_CHECK(if setresuid is implemented, ac_cv_func_setresuid,
+- AC_RUN_IFELSE([AC_LANG_SOURCE([[
++ AC_COMPILE_IFELSE([AC_LANG_SOURCE([[
+ #include <stdlib.h>
+ int main(int argc, char **argv) {
+ if(setresuid(-1,-1,-1)) {
+@@ -3092,7 +3088,7 @@
+ dnl copy that crashes with a buffer over-run!
+ dnl
+ AC_CACHE_CHECK(if strnstr is well implemented, ac_cv_func_strnstr,
+- AC_RUN_IFELSE([AC_LANG_SOURCE([[
++ AC_COMPILE_IFELSE([AC_LANG_SOURCE([[
+ #include <stdlib.h>
+ #include <stdio.h>
+ #include <string.h>
+@@ -3118,7 +3114,7 @@
+ dnl Test for va_copy
+ dnl
+ AC_CACHE_CHECK(if va_copy is implemented, ac_cv_func_va_copy,
+- AC_RUN_IFELSE([AC_LANG_SOURCE([[
++ AC_COMPILE_IFELSE([AC_LANG_SOURCE([[
+ #include <stdarg.h>
+ #include <stdlib.h>
+ int f (int i, ...) {
+@@ -3141,7 +3137,7 @@
+ dnl Some systems support __va_copy
+ dnl
+ AC_CACHE_CHECK(if __va_copy is implemented, ac_cv_func___va_copy,
+- AC_RUN_IFELSE([AC_LANG_SOURCE([[
++ AC_COMPILE_IFELSE([AC_LANG_SOURCE([[
+ #include <stdarg.h>
+ #include <stdlib.h>
+ int f (int i, ...) {
+Index: squid-3.1.8/helpers/negotiate_auth/squid_kerb_auth/configure.in
+===================================================================
+--- squid-3.1.8.orig/helpers/negotiate_auth/squid_kerb_auth/configure.in 2010-09-04 07:25:58.000000000 +0400
++++ squid-3.1.8/helpers/negotiate_auth/squid_kerb_auth/configure.in 2010-09-13 17:52:15.000000000 +0400
+@@ -367,13 +367,13 @@
+
+ CPPFLAGS="$CPPFLAGS -I../../../ -I../../../include/ -I$squid_dir/include -I$squid_dir/src -I$squid_dir"
+ AC_CACHE_CHECK([for SQUID at '$squid_dir' ],ac_cv_have_squid,[
+-AC_TRY_RUN([
++AC_TRY_COMPILE([
+ #include <config.h>
+ int main(int argc, char *argv[]) {
+ #ifdef SQUID_CONFIG_H
+ return 0;
+ #else
+-return 1;
++boom!
+ #endif
+ }],
+ ac_cv_have_squid=yes,
diff --git a/recipes/squid/squid-3.1.9/squidv3-build-cf_gen.patch b/recipes/squid/squid-3.1.9/squidv3-build-cf_gen.patch
new file mode 100644
index 0000000000..955acf8007
--- /dev/null
+++ b/recipes/squid/squid-3.1.9/squidv3-build-cf_gen.patch
@@ -0,0 +1,33 @@
+Index: squid-3.1.4/configure.in
+===================================================================
+--- squid-3.1.4.orig/configure.in 2010-05-30 17:21:49.000000000 +0400
++++ squid-3.1.4/configure.in 2010-07-06 15:41:52.000000000 +0400
+@@ -2116,6 +2116,10 @@
+ ;;
+ esac
+
++dnl Define BUILD_CXX
++BUILD_CXX="$BUILD_CXX"
++AC_SUBST(BUILD_CXX)
++
+ dnl Check for programs
+ AC_PROG_CPP
+ AC_PROG_INSTALL
+Index: squid-3.1.4/src/Makefile.am
+===================================================================
+--- squid-3.1.4.orig/src/Makefile.am 2010-05-30 17:21:11.000000000 +0400
++++ squid-3.1.4/src/Makefile.am 2010-07-06 15:42:29.000000000 +0400
+@@ -751,6 +751,13 @@
+ squid.conf.default squid.conf.documented: cf_parser.cci
+ true
+
++BUILD_CXX ?= @BUILD_CXX@
++
++cf_gen$(EXEEXT): $(cf_gen_SOURCES) $(cf_gen_DEPENDENCIES)
++ $(BUILD_CXX) -o $@ $(srcdir)/cf_gen.cc \
++ $(top_srcdir)/lib/util.c $(top_srcdir)/compat/assert.cc \
++ -DNDEBUG -DBUILD_HOST_TOOL ${INCLUDES}
++
+ cf_parser.cci: cf.data cf_gen$(EXEEXT)
+ ./cf_gen cf.data $(srcdir)/cf.data.depend
+