aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/squid/squid.inc
diff options
context:
space:
mode:
authorRoman I Khimov <khimov@altell.ru>2010-03-18 19:09:02 +0300
committerRoman I Khimov <khimov@altell.ru>2010-03-20 18:01:48 +0300
commitbe21d678d19609728d7087fddfc03ce17c8b38d5 (patch)
treefe82eaab45298138adb881d5a0c03b86de6717fe /recipes/squid/squid.inc
parentd7d1558dca1deb46c21acc852cdb09cf90a8bce7 (diff)
downloadopenembedded-be21d678d19609728d7087fddfc03ce17c8b38d5.tar.gz
squid: move potentially reusable in other versions parts to .inc files
Signed-off-by: Roman I Khimov <khimov@altell.ru>
Diffstat (limited to 'recipes/squid/squid.inc')
-rw-r--r--recipes/squid/squid.inc41
1 files changed, 41 insertions, 0 deletions
diff --git a/recipes/squid/squid.inc b/recipes/squid/squid.inc
new file mode 100644
index 0000000000..7fb3543ca2
--- /dev/null
+++ b/recipes/squid/squid.inc
@@ -0,0 +1,41 @@
+DESCRIPTION = "Squid is a caching proxy for the Web supporting HTTP, HTTPS, FTP, and more"
+LICENSE = "GPLv2"
+INC_PR = "r1"
+DEPENDS = "squid-native-${PV}"
+
+SRC_URI = "http://www.squid-cache.org/Versions/v2/${SQUID_MAJOR}/squid-${PV}.tar.bz2 \
+ file://fix_epoll_check.patch;patch=1 \
+ file://squid.init"
+
+inherit autotools update-rc.d
+
+EXTRA_OECONF = "--disable-epoll --disable-nls"
+
+logdir = ${localstatedir}/log/squid
+EXTRA_OEMAKE = "\
+ DEFAULT_CACHE_LOG=${logdir}/cache.log \
+ DEFAULT_ACCESS_LOG=${logdir}/access.log \
+ DEFAULT_STORE_LOG=${logdir}/store.log \
+ DEFAULT_PID_FILE=${localstatedir}/run/squid.pid \
+ DEFAULT_SWAP_DIR=${localstatedir}/spool/squid \
+ "
+
+INITSCRIPT_NAME = "squid"
+
+do_configure_append() {
+ sed -i -e 's|./cf_gen |${STAGING_BINDIR_NATIVE}/cf_gen |g' src/Makefile
+}
+
+do_install_append() {
+ install -d ${D}${sysconfdir}/init.d
+ install -m 755 ${WORKDIR}/squid.init ${D}${sysconfdir}/init.d/squid
+}
+
+# this packages the languages better and saves some space, installs
+# English as errors default and the others in locale package
+
+FILES_${PN} += " ${datadir}/errors/English/* \
+ ${datadir}/icons/* \
+ ${datadir}/mib.txt"
+
+FILES_${PN}-locale += " ${datadir}/errors/* "