aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/ssmtp
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/ssmtp
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/ssmtp')
-rw-r--r--recipes/ssmtp/ssmtp-2.61/configure.patch32
-rw-r--r--recipes/ssmtp/ssmtp-2.61/dont-strip.patch14
-rw-r--r--recipes/ssmtp/ssmtp-2.61/ldflags.patch24
-rw-r--r--recipes/ssmtp/ssmtp-2.61/libs-lcrypto.patch13
-rw-r--r--recipes/ssmtp/ssmtp-2.61/ssmtp.conf13
-rw-r--r--recipes/ssmtp/ssmtp_2.61.bb39
6 files changed, 135 insertions, 0 deletions
diff --git a/recipes/ssmtp/ssmtp-2.61/configure.patch b/recipes/ssmtp/ssmtp-2.61/configure.patch
new file mode 100644
index 0000000000..2feaa8a80c
--- /dev/null
+++ b/recipes/ssmtp/ssmtp-2.61/configure.patch
@@ -0,0 +1,32 @@
+
+#
+# Patch managed by http://www.mn-logistik.de/unsupported/pxa250/patcher
+#
+
+--- ssmtp-2.60/./configure.in~configure
++++ ssmtp-2.60/./configure.in
+@@ -1,5 +1,6 @@
+ dnl Process this file with autoconf to produce a configure script.
+-AC_INIT(ssmtp.c)
++AC_INIT
++AC_CONFIG_SRCDIR([ssmtp.c])
+
+ dnl Checks for programs.
+ AC_PROG_INSTALL
+@@ -13,8 +14,7 @@
+
+
+ AC_CACHE_CHECK([for obsolete openlog],ssmtp_cv_obsolete_openlog,
+- [ AC_TRY_COMPILE([#include <syslog.h> ] , [ openlog("xx",1); ] ,
+- ssmtp_cv_obsolete_openlog=yes, ssmtp_cv_obsolete_openlog=no)]
++ [ AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[#include <syslog.h> ]], [[ openlog("xx",1); ]])],[ssmtp_cv_obsolete_openlog=yes],[ssmtp_cv_obsolete_openlog=no])]
+ )
+
+
+@@ -70,4 +70,5 @@
+ fi
+ enableval=""
+
+-AC_OUTPUT(Makefile)
++AC_CONFIG_FILES([Makefile])
++AC_OUTPUT
diff --git a/recipes/ssmtp/ssmtp-2.61/dont-strip.patch b/recipes/ssmtp/ssmtp-2.61/dont-strip.patch
new file mode 100644
index 0000000000..5071633ad8
--- /dev/null
+++ b/recipes/ssmtp/ssmtp-2.61/dont-strip.patch
@@ -0,0 +1,14 @@
+Don't try and strip ssmtp during install as this tries to run the native
+strip rather than strip for the target platform.
+
+--- ssmtp-2.61/Makefile.in 2006/07/04 04:43:06 1.1
++++ ssmtp-2.61/Makefile.in 2006/07/04 04:43:17
+@@ -48,7 +48,7 @@
+ .PHONY: install
+ install: ssmtp $(GEN_CONFIG)
+ $(INSTALL) -d -m 755 $(bindir)
+- $(INSTALL) -s -m 755 ssmtp $(bindir)/ssmtp
++ $(INSTALL) -m 755 ssmtp $(bindir)/ssmtp
+ $(INSTALL) -d -m 755 $(mandir)
+ $(INSTALL) -m 644 $(srcdir)/ssmtp.8 $(mandir)/ssmtp.8
+ $(INSTALL) -d -m 755 $(SSMTPCONFDIR)
diff --git a/recipes/ssmtp/ssmtp-2.61/ldflags.patch b/recipes/ssmtp/ssmtp-2.61/ldflags.patch
new file mode 100644
index 0000000000..0cbda2c85d
--- /dev/null
+++ b/recipes/ssmtp/ssmtp-2.61/ldflags.patch
@@ -0,0 +1,24 @@
+
+#
+# Patch managed by http://www.mn-logistik.de/unsupported/pxa250/patcher
+#
+
+--- ssmtp-2.60/Makefile.in~ldflags
++++ ssmtp-2.60/Makefile.in
+@@ -36,6 +36,7 @@
+
+
+ CFLAGS=-Wall @DEFS@ $(EXTRADEFS) @CFLAGS@
++LDFLAGS=@LDFLAGS@
+
+ .PHONY: all
+ all: ssmtp
+@@ -78,7 +79,7 @@
+
+ # Binaries:
+ ssmtp: $(OBJS)
+- $(CC) -o ssmtp $(OBJS) @LIBS@
++ $(CC) -o ssmtp $(OBJS) $(LDFLAGS) @LIBS@
+
+ .PHONY: clean
+ clean:
diff --git a/recipes/ssmtp/ssmtp-2.61/libs-lcrypto.patch b/recipes/ssmtp/ssmtp-2.61/libs-lcrypto.patch
new file mode 100644
index 0000000000..8f2cf84df4
--- /dev/null
+++ b/recipes/ssmtp/ssmtp-2.61/libs-lcrypto.patch
@@ -0,0 +1,13 @@
+Index: ssmtp-2.61/configure.in
+===================================================================
+--- ssmtp-2.61.orig/configure.in 2005-03-31 18:53:48.046049000 +1000
++++ ssmtp-2.61/configure.in 2005-03-31 19:10:49.919318000 +1000
+@@ -52,7 +52,7 @@
+ [ --enable-ssl support for secure connection to mail server])
+ if test x$enableval = xyes ; then
+ AC_DEFINE(HAVE_SSL)
+- LIBS="$LIBS -lssl"
++ LIBS="$LIBS -lssl -lcrypto"
+ fi
+ enableval=""
+
diff --git a/recipes/ssmtp/ssmtp-2.61/ssmtp.conf b/recipes/ssmtp/ssmtp-2.61/ssmtp.conf
new file mode 100644
index 0000000000..201292f8b9
--- /dev/null
+++ b/recipes/ssmtp/ssmtp-2.61/ssmtp.conf
@@ -0,0 +1,13 @@
+#
+# /etc/ssmtp.conf -- a config file for sSMTP sendmail.
+#
+# The person who gets all mail for userids < 1000
+root=postmaster
+# The place where the mail goes. The actual machine name is required
+# no MX records are consulted. Commonly mailhosts are named mail.domain.com
+# The example will fit if you are in domain.com and you mailhub is so named.
+mailhub=mail
+# Where will the mail seem to come from?
+#rewriteDomain=localhost.localdomain
+# The full hostname
+hostname=localhost.localdomain
diff --git a/recipes/ssmtp/ssmtp_2.61.bb b/recipes/ssmtp/ssmtp_2.61.bb
new file mode 100644
index 0000000000..c8461ab29c
--- /dev/null
+++ b/recipes/ssmtp/ssmtp_2.61.bb
@@ -0,0 +1,39 @@
+SECTION = "console/network"
+DEPENDS = "openssl"
+DESCRIPTION = "Extremely simple MTA to get mail off the system to a mail hub."
+LICENSE = "GPL"
+PR = "r6"
+
+SRC_URI = "${DEBIAN_MIRROR}/main/s/ssmtp/ssmtp_${PV}.orig.tar.gz \
+ file://ldflags.patch;patch=1 \
+ file://configure.patch;patch=1 \
+ file://libs-lcrypto.patch;patch=1 \
+ file://dont-strip.patch;patch=1 \
+ file://ssmtp.conf"
+S = "${WORKDIR}/${PN}-${PV}"
+
+inherit autotools
+
+CONFFILES_${PN} = "${sysconfdir}/ssmtp/ssmtp.conf ${sysconfdir}/ssmtp/revaliases"
+EXTRA_OECONF = "--enable-ssl"
+INHIBIT_AUTO_STAGE = "1"
+
+do_compile () {
+ oe_runmake 'LDFLAGS=${LDFLAGS}'
+}
+
+do_install () {
+ oe_runmake 'prefix=${D}${prefix}' 'exec_prefix=${D}${exec_prefix}' \
+ 'bindir=${D}${bindir}' 'mandir=${D}${mandir}' \
+ 'etcdir=${D}${sysconfdir}' GEN_CONFIG="`which echo`" install
+ install -d ${D}${sysconfdir}/ssmtp
+ install -m 0644 ${WORKDIR}/ssmtp.conf ${D}${sysconfdir}/ssmtp/ssmtp.conf
+}
+
+pkg_postinst () {
+ update-alternatives --install ${sbindir}/sendmail sendmail ${bindir}/ssmtp 30
+}
+
+pkg_postrm () {
+ update-alternatives --remove ${sbindir}/sendmail sendmail
+}