aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/stat
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/stat
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/stat')
-rw-r--r--recipes/stat/stat-native_3.3.bb13
-rw-r--r--recipes/stat/stat_3.3.bb15
2 files changed, 28 insertions, 0 deletions
diff --git a/recipes/stat/stat-native_3.3.bb b/recipes/stat/stat-native_3.3.bb
new file mode 100644
index 0000000000..cb97119fb3
--- /dev/null
+++ b/recipes/stat/stat-native_3.3.bb
@@ -0,0 +1,13 @@
+SECTION = "console/utils"
+require stat_${PV}.bb
+inherit native
+S = "${WORKDIR}/stat-${PV}"
+
+do_stage() {
+ install -m 755 stat ${STAGING_BINDIR}
+
+}
+
+do_install() {
+ true
+}
diff --git a/recipes/stat/stat_3.3.bb b/recipes/stat/stat_3.3.bb
new file mode 100644
index 0000000000..7094ab3258
--- /dev/null
+++ b/recipes/stat/stat_3.3.bb
@@ -0,0 +1,15 @@
+SECTION = "console/utils"
+DESCRIPTION = "Display all information about a file that the stat() call provides and all information a filesystem that statfs() provides."
+LICENSE = "GPL"
+
+SRC_URI = "ftp://metalab.unc.edu/pub/Linux/utils/file/stat-3.3.tar.gz"
+
+do_stage() {
+ true
+}
+
+do_install() {
+ install -d ${D}${bindir} ${D}${mandir}/man1
+ install -m 755 stat ${D}${bindir}
+ install -m 644 stat.1 ${D}${mandir}/man1
+}