aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/subversion
diff options
context:
space:
mode:
authorStanislav Brabec <utx@penguin.cz>2009-04-30 21:33:36 +0000
committerutx@penguin.cz <utx@penguin.cz>2009-04-30 21:33:36 +0000
commit87fbf88f7e448eb9381f7fc0551dd386616c6f9b (patch)
tree369b37b4e47c9117fbbc716b7c26a8218caa3ec9 /recipes/subversion
parent74efae1b1ab7b6cf37b08de1c0eb1e2c564d2b3c (diff)
downloadopenembedded-87fbf88f7e448eb9381f7fc0551dd386616c6f9b.tar.gz
subversion: Build with the latest libtool.
Diffstat (limited to 'recipes/subversion')
-rw-r--r--recipes/subversion/files/libtool.patch12
-rw-r--r--recipes/subversion/subversion_1.4.5.bb11
2 files changed, 22 insertions, 1 deletions
diff --git a/recipes/subversion/files/libtool.patch b/recipes/subversion/files/libtool.patch
new file mode 100644
index 0000000000..d296806b12
--- /dev/null
+++ b/recipes/subversion/files/libtool.patch
@@ -0,0 +1,12 @@
+Index: subversion-1.4.5/configure.in
+===================================================================
+--- subversion-1.4.5.orig/configure.in 2007-01-01 14:41:51.000000000 +0000
++++ subversion-1.4.5/configure.in 2009-04-30 21:19:12.000000000 +0000
+@@ -11,6 +11,7 @@
+
+ AC_CONFIG_SRCDIR(subversion/include/svn_types.h)
+ AC_CONFIG_AUX_DIR([build])
++AC_CONFIG_MACRO_DIR([build/ac-macros])
+
+ AC_MSG_NOTICE([Configuring Subversion ]AC_PACKAGE_VERSION)
+
diff --git a/recipes/subversion/subversion_1.4.5.bb b/recipes/subversion/subversion_1.4.5.bb
index d4f290590f..1029e70c5c 100644
--- a/recipes/subversion/subversion_1.4.5.bb
+++ b/recipes/subversion/subversion_1.4.5.bb
@@ -9,7 +9,8 @@ PR = "r0"
SRC_URI = "http://subversion.tigris.org/downloads/${P}.tar.bz2 \
file://disable-revision-install.patch;patch=1 \
- file://neon-detection.patch;patch=1"
+ file://neon-detection.patch;patch=1 \
+ file://libtool.patch;patch=1"
EXTRA_OECONF = "--with-neon=${STAGING_EXECPREFIXDIR} \
--without-berkeley-db --without-apxs --without-apache \
@@ -23,6 +24,14 @@ export LDFLAGS += " -L${STAGING_LIBDIR} "
acpaths = "-I build/ -I build/ac-macros/"
+# FIXME: Ugly hack! Instead of fully porting to the new libtool, apply libtool.patch and do the rest here.
+do_configure_prepend() {
+ rm -f build/libtool.m4
+}
+do_configure_append() {
+ if ! test -f libtool ; then cp -a *-libtool libtool ; fi
+}
+
do_stage() {
autotools_stage_all
}