aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/sugar
diff options
context:
space:
mode:
authorElena Grandi <elena.valhalla@gmail.com>2009-07-01 10:47:38 +0200
committerElena Grandi <elena.valhalla@gmail.com>2009-07-01 10:47:38 +0200
commitef127ce31b24b990bef2174b372697e945f56df0 (patch)
treec489a30bbc759e5a5f940015ce3caf4d361d3e4c /recipes/sugar
parentb1cd10046779238c3878b32d800f9cb9ee2e9ff7 (diff)
downloadopenembedded-ef127ce31b24b990bef2174b372697e945f56df0.tar.gz
sugar-toolkit: updated recipe for version 0.84.4
Diffstat (limited to 'recipes/sugar')
-rw-r--r--recipes/sugar/sugar-toolkit_0.84.4.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/recipes/sugar/sugar-toolkit_0.84.4.bb b/recipes/sugar/sugar-toolkit_0.84.4.bb
new file mode 100644
index 0000000000..864582d7e5
--- /dev/null
+++ b/recipes/sugar/sugar-toolkit_0.84.4.bb
@@ -0,0 +1,22 @@
+DESCRIPTION = "Sugar toolkit"
+LICENSE = "LGPLv2"
+DEPENDS = "python-pygtk libxml-parser-perl-native libxml2 gtk+ alsa-lib"
+
+SRC_URI = "http://download.sugarlabs.org/sources/sucrose/glucose/sugar-toolkit/sugar-toolkit-${PV}.tar.bz2"
+
+inherit autotools distutils-base
+
+SRC_URI += "file://acinclude.m4"
+
+EXTRA_OECONF += "--with-python-includes=${STAGING_INCDIR}/../"
+
+do_configure_prepend() {
+ install -m 0644 ${WORKDIR}/acinclude.m4 ${S}/
+}
+
+AUTOTOOLS_STAGE_PKGCONFIG = "1"
+
+do_stage() {
+ autotools_stage_all
+}
+