aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/suspend-desktop
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/suspend-desktop
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/suspend-desktop')
-rw-r--r--recipes/suspend-desktop/suspend-desktop_1.0.bb27
-rw-r--r--recipes/suspend-desktop/suspend.desktop9
-rw-r--r--recipes/suspend-desktop/suspend.sh10
3 files changed, 46 insertions, 0 deletions
diff --git a/recipes/suspend-desktop/suspend-desktop_1.0.bb b/recipes/suspend-desktop/suspend-desktop_1.0.bb
new file mode 100644
index 0000000000..fa9efba84b
--- /dev/null
+++ b/recipes/suspend-desktop/suspend-desktop_1.0.bb
@@ -0,0 +1,27 @@
+SECTION = "gpe"
+PRIORITY = "optional"
+DESCRIPTION = "Suspend feature for the application launcher menu."
+LICENSE = "GPL"
+
+PR = "r1"
+
+RDEPENDS = "gpe-conf"
+RRECOMMENDS = "apm"
+
+PACKAGES = "${PN}"
+PACKAGE_ARCH = "all"
+
+SRC_URI = "file://suspend.desktop \
+ file://suspend.sh"
+
+FILES_${PN} = "${bindir} ${datadir}"
+
+do_compile() {
+}
+
+do_install() {
+ install -d ${D}/${bindir}
+ install -d ${D}/${datadir}/applications
+ install -m 644 ${WORKDIR}/suspend.desktop ${D}/${datadir}/applications/suspend.desktop
+ install -m 755 ${WORKDIR}/suspend.sh ${D}/${bindir}/suspend.sh
+}
diff --git a/recipes/suspend-desktop/suspend.desktop b/recipes/suspend-desktop/suspend.desktop
new file mode 100644
index 0000000000..21da51a66c
--- /dev/null
+++ b/recipes/suspend-desktop/suspend.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Name=Suspend
+Comment=Suspend device
+Exec=/usr/bin/suspend.sh
+Terminal=0
+Type=Application
+Icon=gpe-config-sleep.png
+Categories=Utility;GPE;Action
+StartupNotify=False
diff --git a/recipes/suspend-desktop/suspend.sh b/recipes/suspend-desktop/suspend.sh
new file mode 100644
index 0000000000..990bc09949
--- /dev/null
+++ b/recipes/suspend-desktop/suspend.sh
@@ -0,0 +1,10 @@
+#!/bin/sh
+if [ -x /usr/bin/apm ]
+then
+ /usr/bin/apm --suspend
+else
+ if [ -x /usr/bin/pm ]
+ then
+ /usr/bin/pm -pp
+ fi
+fi