aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/synergy
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/synergy
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/synergy')
-rw-r--r--recipes/synergy/files/synergy-1.3.1+gcc-4.3.patch161
-rw-r--r--recipes/synergy/synergy_1.2.7.bb15
-rw-r--r--recipes/synergy/synergy_1.3.1.bb16
3 files changed, 192 insertions, 0 deletions
diff --git a/recipes/synergy/files/synergy-1.3.1+gcc-4.3.patch b/recipes/synergy/files/synergy-1.3.1+gcc-4.3.patch
new file mode 100644
index 0000000000..c13a179cf7
--- /dev/null
+++ b/recipes/synergy/files/synergy-1.3.1+gcc-4.3.patch
@@ -0,0 +1,161 @@
+Index: synergy-1.3.1/lib/arch/CArchDaemonUnix.cpp
+===================================================================
+--- synergy-1.3.1.orig/lib/arch/CArchDaemonUnix.cpp
++++ synergy-1.3.1/lib/arch/CArchDaemonUnix.cpp
+@@ -20,6 +20,8 @@
+ #include <fcntl.h>
+ #include <errno.h>
+
++#include <cstdlib>
++
+ //
+ // CArchDaemonUnix
+ //
+Index: synergy-1.3.1/lib/arch/CMultibyte.cpp
+===================================================================
+--- synergy-1.3.1.orig/lib/arch/CMultibyte.cpp
++++ synergy-1.3.1/lib/arch/CMultibyte.cpp
+@@ -19,14 +19,12 @@
+ #include "CArch.h"
+ #include <limits.h>
+ #include <string.h>
++#include <cstdlib>
+ #if HAVE_LOCALE_H
+ # include <locale.h>
+ #endif
+ #if HAVE_WCHAR_H || defined(_MSC_VER)
+ # include <wchar.h>
+-#elif __APPLE__
+- // wtf? Darwin puts mbtowc() et al. in stdlib
+-# include <stdlib.h>
+ #else
+ // platform apparently has no wchar_t support. provide dummy
+ // implementations. hopefully at least the C++ compiler has
+Index: synergy-1.3.1/lib/base/CStringUtil.cpp
+===================================================================
+--- synergy-1.3.1.orig/lib/base/CStringUtil.cpp
++++ synergy-1.3.1/lib/base/CStringUtil.cpp
+@@ -19,6 +19,7 @@
+ #include <cctype>
+ #include <cstdio>
+ #include <cstdlib>
++#include <cstring>
+ #include <algorithm>
+
+ //
+Index: synergy-1.3.1/lib/client/CClient.cpp
+===================================================================
+--- synergy-1.3.1.orig/lib/client/CClient.cpp
++++ synergy-1.3.1/lib/client/CClient.cpp
+@@ -27,6 +27,9 @@
+ #include "IEventQueue.h"
+ #include "TMethodEventJob.h"
+
++#include <cstring>
++#include <cstdlib>
++
+ //
+ // CClient
+ //
+Index: synergy-1.3.1/lib/client/CServerProxy.cpp
+===================================================================
+--- synergy-1.3.1.orig/lib/client/CServerProxy.cpp
++++ synergy-1.3.1/lib/client/CServerProxy.cpp
+@@ -24,6 +24,7 @@
+ #include "TMethodEventJob.h"
+ #include "XBase.h"
+ #include <memory>
++#include <cstring>
+
+ //
+ // CServerProxy
+Index: synergy-1.3.1/lib/net/CTCPSocket.cpp
+===================================================================
+--- synergy-1.3.1.orig/lib/net/CTCPSocket.cpp
++++ synergy-1.3.1/lib/net/CTCPSocket.cpp
+@@ -24,6 +24,7 @@
+ #include "CArch.h"
+ #include "XArch.h"
+ #include <string.h>
++#include <cstdlib>
+
+ //
+ // CTCPSocket
+Index: synergy-1.3.1/lib/platform/CXWindowsScreen.cpp
+===================================================================
+--- synergy-1.3.1.orig/lib/platform/CXWindowsScreen.cpp
++++ synergy-1.3.1/lib/platform/CXWindowsScreen.cpp
+@@ -27,6 +27,7 @@
+ #include "IEventQueue.h"
+ #include "TMethodEventJob.h"
+ #include <cstring>
++#include <cstdlib>
+ #if X_DISPLAY_MISSING
+ # error X11 is required to build synergy
+ #else
+Index: synergy-1.3.1/lib/server/CClientProxy1_3.cpp
+===================================================================
+--- synergy-1.3.1.orig/lib/server/CClientProxy1_3.cpp
++++ synergy-1.3.1/lib/server/CClientProxy1_3.cpp
+@@ -18,6 +18,8 @@
+ #include "IEventQueue.h"
+ #include "TMethodEventJob.h"
+
++#include <cstring>
++
+ //
+ // CClientProxy1_3
+ //
+Index: synergy-1.3.1/lib/server/CServer.cpp
+===================================================================
+--- synergy-1.3.1.orig/lib/server/CServer.cpp
++++ synergy-1.3.1/lib/server/CServer.cpp
+@@ -28,7 +28,8 @@
+ #include "CLog.h"
+ #include "TMethodEventJob.h"
+ #include "CArch.h"
+-#include <string.h>
++#include <cstring>
++#include <cstdlib>
+
+ //
+ // CServer
+Index: synergy-1.3.1/lib/synergy/CPacketStreamFilter.cpp
+===================================================================
+--- synergy-1.3.1.orig/lib/synergy/CPacketStreamFilter.cpp
++++ synergy-1.3.1/lib/synergy/CPacketStreamFilter.cpp
+@@ -16,6 +16,7 @@
+ #include "IEventQueue.h"
+ #include "CLock.h"
+ #include "TMethodEventJob.h"
++#include <cstring>
+
+ //
+ // CPacketStreamFilter
+Index: synergy-1.3.1/lib/synergy/IKeyState.cpp
+===================================================================
+--- synergy-1.3.1.orig/lib/synergy/IKeyState.cpp
++++ synergy-1.3.1/lib/synergy/IKeyState.cpp
+@@ -13,7 +13,8 @@
+ */
+
+ #include "IKeyState.h"
+-#include <string.h>
++#include <cstring>
++#include <cstdlib>
+
+ //
+ // IKeyState
+Index: synergy-1.3.1/lib/synergy/IPrimaryScreen.cpp
+===================================================================
+--- synergy-1.3.1.orig/lib/synergy/IPrimaryScreen.cpp
++++ synergy-1.3.1/lib/synergy/IPrimaryScreen.cpp
+@@ -14,6 +14,8 @@
+
+ #include "IPrimaryScreen.h"
+
++#include <cstdlib>
++
+ //
+ // IPrimaryScreen
+ //
diff --git a/recipes/synergy/synergy_1.2.7.bb b/recipes/synergy/synergy_1.2.7.bb
new file mode 100644
index 0000000000..2aa7152425
--- /dev/null
+++ b/recipes/synergy/synergy_1.2.7.bb
@@ -0,0 +1,15 @@
+DESCRIPTION = "Synergy - control multiple computers with one keyboard and mouse"
+HOMEPAGE = "http://synergy2.sourceforge.net/"
+LICENSE = "GPLv2"
+SECTION = "x11/utils"
+# NOTE: This depends on full x11, not diet-x11
+DEPENDS = "libx11 libxtst"
+PR = "r2"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/synergy2/synergy-${PV}.tar.gz"
+
+do_configure_prepend() {
+ grep -l -- -Werror "${S}/"* | xargs sed -i 's:-Werror::'
+}
+
+inherit autotools
diff --git a/recipes/synergy/synergy_1.3.1.bb b/recipes/synergy/synergy_1.3.1.bb
new file mode 100644
index 0000000000..d46cb47203
--- /dev/null
+++ b/recipes/synergy/synergy_1.3.1.bb
@@ -0,0 +1,16 @@
+DESCRIPTION = "Synergy - control multiple computers with one keyboard and mouse"
+HOMEPAGE = "http://synergy2.sourceforge.net/"
+LICENSE = "GPLv2"
+SECTION = "x11/utils"
+# NOTE: This depends on full x11, not diet-x11
+DEPENDS = "libx11 libxtst"
+PR = "r0"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/synergy2/synergy-${PV}.tar.gz \
+ file://synergy-1.3.1+gcc-4.3.patch;patch=1"
+
+do_configure_prepend() {
+ grep -l -- -Werror "${S}/"* | xargs sed -i 's:-Werror::'
+}
+
+inherit autotools