aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/sysvinit
diff options
context:
space:
mode:
authorCarsten Haitzler (Rasterman <raster@rasterman.com>2009-04-17 15:44:58 +1000
committerCarsten Haitzler (Rasterman) <raster@rasterman.com>2009-04-17 15:48:45 +1000
commit212e36417ae27e1be11147168b6f5cdfd1c5eda9 (patch)
tree00892cc3bca94534140f1e44ab98b4e58587410c /recipes/sysvinit
parentd92391844e4454ba9ea3af5b4273721496511ebb (diff)
downloadopenembedded-212e36417ae27e1be11147168b6f5cdfd1c5eda9.tar.gz
angstrom, exquisite, psplash, opkg, angsrtom-images, sysvinit: abstract splash
this abstracts psplash to be generic. now as long as something provides a splashfuncs file that sysvinit (and other scripts) can source, and all the approproate init hooks to start the splash etc. you can use psplash, exquisitie, usplash or anything that tickles your fancy. this moves splash toa ${SPLASH} variable to include in your image (or override). the default in angstrom is psplash - unless you override it. opkg also runs a configure script that cna take forever - and so this speically sends off some splash commands (if there) to let you know the systme is alive and working (but just busy). this is one commit as if this breaks things you either want to fix the minor break or totally revert the whole patch. i hope it didn't break anything.
Diffstat (limited to 'recipes/sysvinit')
-rwxr-xr-xrecipes/sysvinit/sysvinit/angstrom/rc13
-rw-r--r--recipes/sysvinit/sysvinit_2.86.bb2
2 files changed, 8 insertions, 7 deletions
diff --git a/recipes/sysvinit/sysvinit/angstrom/rc b/recipes/sysvinit/sysvinit/angstrom/rc
index 30b69ad516..6c5f4ca2ec 100755
--- a/recipes/sysvinit/sysvinit/angstrom/rc
+++ b/recipes/sysvinit/sysvinit/angstrom/rc
@@ -16,6 +16,9 @@
#
. /etc/default/rcS
+if [ -f /etc/default/splashfuncs ]; then
+ . /etc/default/splashfuncs
+fi
export VERBOSE
startup_progress() {
@@ -26,9 +29,7 @@ startup_progress() {
progress=$progress_size
fi
#echo "PROGRESS is $progress $runlevel $first_step + ($step of $num_steps) $step_change $progress_size"
- if type psplash-write >/dev/null 2>&1; then
- TMPDIR=/mnt/.psplash psplash-write "PROGRESS $progress" || true
- fi
+ status_position $progress || true
}
@@ -169,8 +170,8 @@ startup() {
#Uncomment to cause psplash to exit manually, otherwise it exits when it sees a VC switch
#if [ "x$runlevel" != "xS" ]; then
-# if type psplash-write >/dev/null 2>&1; then
-# TMPDIR=/mnt/.psplash psplash-write "QUIT" || true
-# umount /mnt/.psplash
+# if type splash-write >/dev/null 2>&1; then
+# TMPDIR=/mnt/.splash splash-write "QUIT" || true
+# umount /mnt/.splash
# fi
#fi
diff --git a/recipes/sysvinit/sysvinit_2.86.bb b/recipes/sysvinit/sysvinit_2.86.bb
index 6e6f98c6ed..d3a151703f 100644
--- a/recipes/sysvinit/sysvinit_2.86.bb
+++ b/recipes/sysvinit/sysvinit_2.86.bb
@@ -2,7 +2,7 @@ DESCRIPTION = "System-V like init."
SECTION = "base"
LICENSE = "GPL"
HOMEPAGE = "http://freshmeat.net/projects/sysvinit/"
-PR = "r46"
+PR = "r52"
# USE_VT and SERIAL_CONSOLE are generally defined by the MACHINE .conf.
# Set PACKAGE_ARCH appropriately.