aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/t1lib/t1lib_5.0.2.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/t1lib/t1lib_5.0.2.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/t1lib/t1lib_5.0.2.bb')
-rw-r--r--recipes/t1lib/t1lib_5.0.2.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/recipes/t1lib/t1lib_5.0.2.bb b/recipes/t1lib/t1lib_5.0.2.bb
new file mode 100644
index 0000000000..5da31f7d09
--- /dev/null
+++ b/recipes/t1lib/t1lib_5.0.2.bb
@@ -0,0 +1,27 @@
+DESCRIPTION = "A Type1 Font Rastering Library"
+SECTION = "libs"
+PRIORITY = "optional"
+DEPENDS = "virtual/libx11"
+PR = "r4"
+LICENSE = "LGPL GPL"
+SRC_URI = "${DEBIAN_MIRROR}/main/t/t1lib/t1lib_${PV}.orig.tar.gz \
+ file://configure.patch;patch=1 \
+ file://install.patch;patch=1 \
+ file://libtool.patch;patch=1"
+
+inherit autotools
+
+EXTRA_OECONF = "--with-x --without-athena"
+EXTRA_OEMAKE = "without_doc"
+
+do_configure() {
+ rm -f ${S}/ac-tools/aclocal.m4
+ autotools_do_configure
+}
+
+do_stage() {
+ autotools_stage_all
+}
+
+FILES_${PN} = "${bindir}/* ${libdir}/*.so* ${datadir}/t1lib/t1lib.config"
+FILES_${PN}-doc = "${datadir}/t1lib/doc/t1lib_doc.pdf"