aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/t1lib
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/t1lib
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/t1lib')
-rw-r--r--recipes/t1lib/t1lib-5.0.2/configure.patch122
-rw-r--r--recipes/t1lib/t1lib-5.0.2/install.patch163
-rw-r--r--recipes/t1lib/t1lib-5.0.2/libtool.patch116
-rw-r--r--recipes/t1lib/t1lib_5.0.2.bb27
4 files changed, 428 insertions, 0 deletions
diff --git a/recipes/t1lib/t1lib-5.0.2/configure.patch b/recipes/t1lib/t1lib-5.0.2/configure.patch
new file mode 100644
index 0000000000..f2405c6bc7
--- /dev/null
+++ b/recipes/t1lib/t1lib-5.0.2/configure.patch
@@ -0,0 +1,122 @@
+
+#
+# Patch managed by http://www.holgerschurig.de/patcher.html
+#
+
+--- t1lib-5.0.2/configure.in~configure.patch
++++ t1lib-5.0.2/configure.in
+@@ -75,9 +75,9 @@
+ T1LIB_VERSIONSTRING=\"MACRO_T1LIB_IDENTIFIER\"
+
+
+-dnl We use this file by Andreas Zeller to check for libXaw
+-builtin(include, ac-tools/ice_find_athena.m4)
+-builtin(include, ac-tools/aclocal.m4)
++#dnl We use this file by Andreas Zeller to check for libXaw
++#builtin(include, ac-tools/ice_find_athena.m4)
++#builtin(include, ac-tools/aclocal.m4)
+
+ dnl We want these before the checks, so the checks can modify their values.
+ test -z "$LDLIBS" && LDLIBS=-lm AC_SUBST(LDLIBS)
+@@ -161,6 +161,7 @@
+
+ dnl **** Check for underscore on external symbols ****
+
++AH_TEMPLATE([NEED_UNDERSCORE_PREFIX], [Define if external symbols need an underscore prefix])
+ AC_CACHE_CHECK("whether external symbols need an underscore prefix",
+ ac_cv_c_extern_prefix,
+ [saved_libs=$LIBS
+@@ -178,64 +179,46 @@
+ AC_DEFINE(NEED_UNDERSCORE_PREFIX)
+ fi
+
+-dnl **** Check which ANSI integer type is 16 bit
++dnl **** Check which ANSI integer type is 16 bit
++T1_AA_TYPE16=""
++for type in short int; do
++ if test x"`eval echo \\$ac_cv_sizeof_$type`" = "x2"; then
++ T1_AA_TYPE16="-DT1_AA_TYPE16=$type"
++ break
++ fi
++done
+
+-AC_CACHE_CHECK( "which ANSI integer type is 16 bit", ac_16bit_type,
+- AC_TRY_RUN([
+-int main(void) {
+- if (sizeof(short)==2)
+- return(0);
+- else if (sizeof(int)==2)
+- return(1);
+- else
+- return(2);
+-}], ac_16bit_type="short", ac_16bit_type="int", ac_16bit_type=))
+-if test "$ac_16bit_type" = "short"
+-then
+- T1_AA_TYPE16="-DT1_AA_TYPE16=short"
+-else
+- T1_AA_TYPE16="-DT1_AA_TYPE16=int"
++if test x"$T1_AA_TYPE16" = "x"; then
++ AC_MSG_ERROR("Unable to determine which integer type is 16 bit.")
+ fi
+
+-
+ dnl **** Check which ANSI integer type is 32 bit
++T1_AA_TYPE32=""
++for type in int long; do
++ if test x"`eval echo \\$ac_cv_sizeof_$type`" = "x4"; then
++ T1_AA_TYPE32="-DT1_AA_TYPE32=$type"
++ break
++ fi
++done
+
+-AC_CACHE_CHECK( "which ANSI integer type is 32 bit", ac_32bit_type,
+- AC_TRY_RUN([
+-int main(void) {
+- if (sizeof(int)==4)
+- return(0);
+- else if (sizeof(long)==4)
+- return(1);
+- else
+- return(2);
+-}], ac_32bit_type="int", ac_32bit_type="long", ac_32bit_type=))
+-if test "$ac_32bit_type" = "int"
+-then
+- T1_AA_TYPE32="-DT1_AA_TYPE32=int"
+-else
+- T1_AA_TYPE32="-DT1_AA_TYPE32=long"
++if test x"$T1_AA_TYPE32" = "x"; then
++ AC_MSG_ERROR("Unable to determine which integer type is 32 bit.")
+ fi
+
+-
+ dnl **** Check which ANSI integer type is 64 bit
++T1_AA_TYPE64=""
++for type in long long_long; do
++ if test x"`eval echo \\$ac_cv_sizeof_$type`" = "x8"; then
++ AC_MSG_WARN("$type is 64 bit")
++ T1_AA_TYPE64="-DT1_AA_TYPE64=\"`echo $type|tr '_' ' '`\""
++ break
++ fi
++done
+
+-AC_CACHE_CHECK( "which ANSI integer type is 64 bit", ac_64bit_type,
+- AC_TRY_RUN([
+-int main(void) {
+- if (sizeof(long)==8)
+- return(0);
+- else
+- return(1);
+-}], ac_64bit_type="long", ac_64bit_type="<none>"))
+-if test "$ac_64bit_type" = "long"
+-then
+- T1_AA_TYPE64="-DT1_AA_TYPE64=long"
+-else
+- T1_AA_TYPE64=
++if test x"$T1_AA_TYPE64" = "x"; then
++ AC_MSG_ERROR("Unable to determine which integer type is 64 bit.")
+ fi
+
+-
+ CFLAGS="${CFLAGS} -DT1LIB_IDENT=\"\\\"${T1LIB_IDENTIFIER}\\\"\" -DGLOBAL_CONFIG_DIR=\"\\\"${T1LIB_DATA_DIR}\\\"\""
+
+ dnl **** Check for functions and header files ****
diff --git a/recipes/t1lib/t1lib-5.0.2/install.patch b/recipes/t1lib/t1lib-5.0.2/install.patch
new file mode 100644
index 0000000000..3d8843861c
--- /dev/null
+++ b/recipes/t1lib/t1lib-5.0.2/install.patch
@@ -0,0 +1,163 @@
+
+#
+# Patch managed by http://www.mn-logistik.de/unsupported/pxa250/patcher
+#
+
+--- t1lib-5.0.1/Makefile.in~install 2001-01-15 17:37:11.000000000 -0500
++++ t1lib-5.0.1/Makefile.in 2004-02-13 12:29:21.000000000 -0500
+@@ -44,6 +44,7 @@
+ INSTALL_PROGRAM = @INSTALL_PROGRAM@
+ INSTALL_DATA = @INSTALL_DATA@
+ MKINSTALLDIRS = @top_srcdir@/ac-tools/mkinstalldirs
++DESTDIR = @DESTDIR@
+ prefix = @prefix@
+ exec_prefix = @exec_prefix@
+ includedir = @includedir@
+--- t1lib-5.0.1/doc/Makefile.in~install 2001-12-15 14:10:46.000000000 -0500
++++ t1lib-5.0.1/doc/Makefile.in 2004-02-13 12:29:28.000000000 -0500
+@@ -43,6 +43,7 @@
+ INSTALL_PROGRAM = @INSTALL_PROGRAM@
+ INSTALL_DATA = @INSTALL_DATA@
+ MKINSTALLDIRS = @top_srcdir@/ac-tools/mkinstalldirs
++DESTDIR = @DESTDIR@
+ prefix = @prefix@
+ exec_prefix = @exec_prefix@
+ includedir = @includedir@
+@@ -91,18 +92,18 @@
+ install: dummy
+ if (test -f t1lib_doc.ps) \
+ then \
+- $(MKINSTALLDIRS) @T1LIB_DATA_DIR@/doc; \
+- $(INSTALL_DATA) t1lib_doc.ps @T1LIB_DATA_DIR@/doc; \
++ $(MKINSTALLDIRS) $(DESTDIR)@T1LIB_DATA_DIR@/doc; \
++ $(INSTALL_DATA) t1lib_doc.ps $(DESTDIR)@T1LIB_DATA_DIR@/doc; \
+ fi;
+ if (test -f t1lib_doc.pdf) \
+ then \
+- $(MKINSTALLDIRS) @T1LIB_DATA_DIR@/doc; \
+- $(INSTALL_DATA) t1lib_doc.pdf @T1LIB_DATA_DIR@/doc; \
++ $(MKINSTALLDIRS) $(DESTDIR)@T1LIB_DATA_DIR@/doc; \
++ $(INSTALL_DATA) t1lib_doc.pdf $(DESTDIR)@T1LIB_DATA_DIR@/doc; \
+ fi;
+
+
+ uninstall: dummy
+- $(RM) -R @T1LIB_DATA_DIR@/doc
++ $(RM) -R $(DESTDIR)@T1LIB_DATA_DIR@/doc
+
+
+ dummy:
+--- t1lib-5.0.1/examples/Makefile.in~install 2001-01-15 17:11:47.000000000 -0500
++++ t1lib-5.0.1/examples/Makefile.in 2004-02-13 12:29:33.000000000 -0500
+@@ -40,6 +40,7 @@
+ INSTALL_PROGRAM = @INSTALL_PROGRAM@
+ INSTALL_DATA = @INSTALL_DATA@
+ MKINSTALLDIRS = @top_srcdir@/ac-tools/mkinstalldirs
++DESTDIR = @DESTDIR@
+ prefix = @prefix@
+ exec_prefix = @exec_prefix@
+ includedir = @includedir@
+--- t1lib-5.0.1/lib/Makefile.in~install 2002-06-24 22:15:30.000000000 -0400
++++ t1lib-5.0.1/lib/Makefile.in 2004-02-13 12:29:35.000000000 -0500
+@@ -40,6 +40,7 @@
+ INSTALL_PROGRAM = @INSTALL_PROGRAM@
+ INSTALL_DATA = @INSTALL_DATA@
+ MKINSTALLDIRS = @top_srcdir@/ac-tools/mkinstalldirs
++DESTDIR = @DESTDIR@
+ prefix = @prefix@
+ exec_prefix = @exec_prefix@
+ includedir = @includedir@
+@@ -160,27 +161,27 @@
+
+
+ install: dummy
+- $(MKINSTALLDIRS) $(libdir)
+- $(MKINSTALLDIRS) $(includedir)
+- $(MKINSTALLDIRS) @T1LIB_DATA_DIR@
++ $(MKINSTALLDIRS) $(DESTDIR)$(libdir)
++ $(MKINSTALLDIRS) $(DESTDIR)$(includedir)
++ $(MKINSTALLDIRS) $(DESTDIR)@T1LIB_DATA_DIR@
+ $(LIBTOOL) --mode=install \
+- $(INSTALL_DATA) $(MAIN_TARGET) $(libdir)
++ $(INSTALL_DATA) $(MAIN_TARGET) $(DESTDIR)$(libdir)
+ $(LIBTOOL) --mode=install \
+- $(INSTALL_DATA) $(MAIN_HEADER) $(includedir)
+- if (test -f @T1LIB_DATA_DIR@/t1lib.config) \
++ $(INSTALL_DATA) $(MAIN_HEADER) $(DESTDIR)$(includedir)
++ if (test -f $(DESTDIR)@T1LIB_DATA_DIR@/t1lib.config) \
+ then \
+ echo "Alert: Global configuration file exists, installation skipped!"; \
+ else \
+- $(LIBTOOL) --mode=install $(INSTALL_DATA) t1lib.config @T1LIB_DATA_DIR@; \
++ $(LIBTOOL) --mode=install $(INSTALL_DATA) t1lib.config $(DESTDIR)@T1LIB_DATA_DIR@; \
+ fi;
+
+
+ uninstall: dummy
+- -$(LIBTOOL) --mode=uninstall $(RM) $(libdir)/libt1.la
+- -$(LIBTOOL) --mode=uninstall $(RM) $(libdir)/libt1x.la
+- -$(LIBTOOL) --mode=uninstall $(RM) $(includedir)/t1lib.h
+- -$(LIBTOOL) --mode=uninstall $(RM) $(includedir)/t1libx.h
+- -$(LIBTOOL) --mode=uninstall $(RM) @T1LIB_DATA_DIR@/t1lib.config
++ -$(LIBTOOL) --mode=uninstall $(RM) $(DESTDIR)$(libdir)/libt1.la
++ -$(LIBTOOL) --mode=uninstall $(RM) $(DESTDIR)$(libdir)/libt1x.la
++ -$(LIBTOOL) --mode=uninstall $(RM) $(DESTDIR)$(includedir)/t1lib.h
++ -$(LIBTOOL) --mode=uninstall $(RM) $(DESTDIR)$(includedir)/t1libx.h
++ -$(LIBTOOL) --mode=uninstall $(RM) $(DESTDIR)@T1LIB_DATA_DIR@/t1lib.config
+
+
+ dummy:
+--- t1lib-5.0.1/type1afm/Makefile.in~install 2001-01-15 17:08:23.000000000 -0500
++++ t1lib-5.0.1/type1afm/Makefile.in 2004-02-13 12:29:40.000000000 -0500
+@@ -42,6 +42,7 @@
+ INSTALL_PROGRAM = @INSTALL_PROGRAM@
+ INSTALL_DATA = @INSTALL_DATA@
+ MKINSTALLDIRS = @top_srcdir@/ac-tools/mkinstalldirs
++DESTDIR = @DESTDIR@
+ prefix = @prefix@
+ exec_prefix = @exec_prefix@
+ includedir = @includedir@
+@@ -87,14 +88,14 @@
+ -rmdir .libs
+
+ install: dummy
+- $(MKINSTALLDIRS) $(bindir)
++ $(MKINSTALLDIRS) $(DESTDIR)$(bindir)
+ $(LIBTOOL) --mode=install \
+- $(INSTALL_PROGRAM) type1afm $(bindir)/type1afm
++ $(INSTALL_PROGRAM) type1afm $(DESTDIR)$(bindir)/type1afm
+
+
+ uninstall: dummy
+ $(LIBTOOL) --mode=uninstall \
+- $(RM) $(bindir)/type1afm
++ $(RM) $(DESTDIR)$(bindir)/type1afm
+
+
+ dummy:
+--- t1lib-5.0.1/xglyph/Makefile.in~install 2001-01-15 17:06:53.000000000 -0500
++++ t1lib-5.0.1/xglyph/Makefile.in 2004-02-13 12:29:44.000000000 -0500
+@@ -42,6 +42,7 @@
+ INSTALL_PROGRAM = @INSTALL_PROGRAM@
+ INSTALL_DATA = @INSTALL_DATA@
+ MKINSTALLDIRS = @top_srcdir@/ac-tools/mkinstalldirs
++DESTDIR = @DESTDIR@
+ prefix = @prefix@
+ exec_prefix = @exec_prefix@
+ includedir = @includedir@
+@@ -94,12 +95,12 @@
+
+
+ install: dummy
+- $(MKINSTALLDIRS) $(bindir)
+- $(LIBTOOL) --mode=install $(INSTALL_PROGRAM) xglyph $(bindir)/xglyph
++ $(MKINSTALLDIRS) $(DESTDIR)$(bindir)
++ $(LIBTOOL) --mode=install $(INSTALL_PROGRAM) xglyph $(DESTDIR)$(bindir)/xglyph
+
+
+ uninstall: dummy
+- $(LIBTOOL) --mode=uninstall $(RM) -f $(bindir)/xglyph
++ $(LIBTOOL) --mode=uninstall $(RM) -f $(DESTDIR)$(bindir)/xglyph
+
+
+ dummy:
diff --git a/recipes/t1lib/t1lib-5.0.2/libtool.patch b/recipes/t1lib/t1lib-5.0.2/libtool.patch
new file mode 100644
index 0000000000..e050025739
--- /dev/null
+++ b/recipes/t1lib/t1lib-5.0.2/libtool.patch
@@ -0,0 +1,116 @@
+
+#
+# Patch managed by http://www.holgerschurig.de/patcher.html
+#
+
+--- t1lib-5.0.2/Makefile.in~libtool
++++ t1lib-5.0.2/Makefile.in
+@@ -18,7 +18,8 @@
+ # Last modified: 2001-04-01
+ #
+
+-SHELL = /bin/sh
++SHELL = @SHELL@
++LIBTOOL = @LIBTOOL@
+ CC = @CC@
+ CPP = @CPP@
+ CFLAGS = @CFLAGS@
+@@ -150,7 +151,7 @@
+ $(RM) examples/Makefile
+ $(RM) xglyph/Makefile
+ $(RM) doc/Makefile
+- $(RM) libtool
++ $(RM) $(LIBTOOL)
+
+
+ # The following two targets are for building and cleaning the python-
+--- t1lib-5.0.2/examples/Makefile.in~libtool
++++ t1lib-5.0.2/examples/Makefile.in
+@@ -14,9 +14,10 @@
+ # Last modified: 2001-04-01
+ #
+
++top_builddir = @top_builddir@
+
+-LIBTOOL = ../libtool
+-SHELL = /bin/sh
++LIBTOOL = @LIBTOOL@
++SHELL = @SHELL@
+ CC = @CC@
+ CPP = @CPP@
+ CFLAGS = @CFLAGS@
+--- t1lib-5.0.2/lib/Makefile.in~libtool
++++ t1lib-5.0.2/lib/Makefile.in
+@@ -15,8 +15,10 @@
+ #
+ # Contributions by H.Kakugawa to use libtool!
+
+-LIBTOOL = ../libtool
+-SHELL = /bin/sh
++top_builddir = @top_builddir@
++
++LIBTOOL = @LIBTOOL@
++SHELL = @SHELL@
+ CC = @CC@
+ CPP = @CPP@
+ CFLAGS = @CFLAGS@
+--- t1lib-5.0.2/lib/t1lib/Makefile.in~libtool
++++ t1lib-5.0.2/lib/t1lib/Makefile.in
+@@ -14,8 +14,10 @@
+ #
+ # Modified by H.Kakugawa to use libtool
+
+-LIBTOOL = ../../libtool
+-SHELL = /bin/sh
++top_builddir = @top_builddir@
++
++LIBTOOL = @LIBTOOL@
++SHELL = @SHELL@
+ CC = @CC@
+ CPP = @CPP@
+ CFLAGS = @CFLAGS@
+--- t1lib-5.0.2/lib/type1/Makefile.in~libtool
++++ t1lib-5.0.2/lib/type1/Makefile.in
+@@ -14,8 +14,10 @@
+ #
+ # Modified by H.Kakugawa to use libtool
+
+-LIBTOOL = ../../libtool
+-SHELL = /bin/sh
++top_builddir = @top_builddir@
++
++LIBTOOL = @LIBTOOL@
++SHELL = @SHELL@
+ CC = @CC@
+ CPP = @CPP@
+ CFLAGS = @CFLAGS@
+--- t1lib-5.0.2/type1afm/Makefile.in~libtool
++++ t1lib-5.0.2/type1afm/Makefile.in
+@@ -15,8 +15,10 @@
+ #
+ # Modified by H.Kakugawa to use libtool
+
+-LIBTOOL = ../libtool
+-SHELL = /bin/sh
++top_builddir = @top_builddir@
++
++LIBTOOL = @LIBTOOL@
++SHELL = @SHELL@
+ CC = @CC@
+ CPP = @CPP@
+ CFLAGS = @CFLAGS@
+--- t1lib-5.0.2/xglyph/Makefile.in~libtool
++++ t1lib-5.0.2/xglyph/Makefile.in
+@@ -15,8 +15,10 @@
+ #
+ # Modified by H.Kakugawa to use libtool
+
+-LIBTOOL = ../libtool
+-SHELL = /bin/sh
++top_builddir = @top_builddir@
++
++LIBTOOL = @LIBTOOL@
++SHELL = @SHELL@
+ CC = @CC@
+ CPP = @CPP@
+ CFLAGS = @CFLAGS@
diff --git a/recipes/t1lib/t1lib_5.0.2.bb b/recipes/t1lib/t1lib_5.0.2.bb
new file mode 100644
index 0000000000..5da31f7d09
--- /dev/null
+++ b/recipes/t1lib/t1lib_5.0.2.bb
@@ -0,0 +1,27 @@
+DESCRIPTION = "A Type1 Font Rastering Library"
+SECTION = "libs"
+PRIORITY = "optional"
+DEPENDS = "virtual/libx11"
+PR = "r4"
+LICENSE = "LGPL GPL"
+SRC_URI = "${DEBIAN_MIRROR}/main/t/t1lib/t1lib_${PV}.orig.tar.gz \
+ file://configure.patch;patch=1 \
+ file://install.patch;patch=1 \
+ file://libtool.patch;patch=1"
+
+inherit autotools
+
+EXTRA_OECONF = "--with-x --without-athena"
+EXTRA_OEMAKE = "without_doc"
+
+do_configure() {
+ rm -f ${S}/ac-tools/aclocal.m4
+ autotools_do_configure
+}
+
+do_stage() {
+ autotools_stage_all
+}
+
+FILES_${PN} = "${bindir}/* ${libdir}/*.so* ${datadir}/t1lib/t1lib.config"
+FILES_${PN}-doc = "${datadir}/t1lib/doc/t1lib_doc.pdf"