aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/tar/tar_1.13.93.bb
diff options
context:
space:
mode:
authorChris Larson <clarson@mvista.com>2009-08-11 11:16:09 -0700
committerChris Larson <clarson@mvista.com>2009-08-20 12:25:01 -0700
commitf2442f18ecdb310750195753f8c122f2cd81e364 (patch)
tree68f6be24c195c3065727f3201ac722933447db5f /recipes/tar/tar_1.13.93.bb
parentdf0c1f671b493f6300e51b5b4c7d41956f486d62 (diff)
downloadopenembedded-f2442f18ecdb310750195753f8c122f2cd81e364.tar.gz
tar: inherit gettext & use a .inc to avoid duplicated metadata.
Signed-off-by: Chris Larson <clarson@mvista.com>
Diffstat (limited to 'recipes/tar/tar_1.13.93.bb')
-rw-r--r--recipes/tar/tar_1.13.93.bb30
1 files changed, 5 insertions, 25 deletions
diff --git a/recipes/tar/tar_1.13.93.bb b/recipes/tar/tar_1.13.93.bb
index 6c7139595f..ea56c0d372 100644
--- a/recipes/tar/tar_1.13.93.bb
+++ b/recipes/tar/tar_1.13.93.bb
@@ -1,28 +1,8 @@
-SECTION = "base"
-DESCRIPTION = "GNU tar saves many files together into a single tape \
-or disk archive, and can restore individual files from the archive."
-LICENSE = "GPL"
+require tar.inc
+
+LICENSE = "GPLv2"
PR = "r1"
SRC_URI = "ftp://alpha.gnu.org/gnu/tar/tar-${PV}.tar.gz \
- file://configure.patch;patch=1 \
- file://m4.patch;patch=1"
-
-inherit autotools
-
-do_install () {
- autotools_do_install
- install -d ${D}${base_bindir}
- mv ${D}${bindir}/tar ${D}${base_bindir}/tar.${PN}
- mv ${D}${libexecdir}/rmt ${D}${libexecdir}/rmt.${PN}
-}
-
-pkg_postinst_${PN} () {
- update-alternatives --install ${base_bindir}/tar tar tar.${PN} 100
- update-alternatives --install ${libexecdir}/rmt rmt rmt.${PN} 100
-}
-
-pkg_prerm_${PN} () {
- update-alternatives --remove tar tar.${PN}
- update-alternatives --remove rmt rmt.${PN}
-}
+ file://configure.patch;patch=1 \
+ file://m4.patch;patch=1"