aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/tasks/task-base.bb
diff options
context:
space:
mode:
authorSebastian Spaeth <Sebastian@SSpaeth.de>2009-12-04 09:07:33 +0100
committerSebastian Spaeth <Sebastian@SSpaeth.de>2009-12-04 11:59:02 +0100
commit3943c0dac3e134e55a478cc575a005d57ed4e860 (patch)
tree9c7d43a6def5dff400a35493d5a7cd1831999cbb /recipes/tasks/task-base.bb
parent3512b7de2daae13ecad6dbe4475bd58ab053cb29 (diff)
downloadopenembedded-3943c0dac3e134e55a478cc575a005d57ed4e860.tar.gz
task-base: Introduce DISTRO_APM and convert recipes to use that
Signed-off-by: Sebastian Spaeth <Sebastian@SSpaeth.de>
Diffstat (limited to 'recipes/tasks/task-base.bb')
-rw-r--r--recipes/tasks/task-base.bb7
1 files changed, 5 insertions, 2 deletions
diff --git a/recipes/tasks/task-base.bb b/recipes/tasks/task-base.bb
index ed561b802e..b540c80bda 100644
--- a/recipes/tasks/task-base.bb
+++ b/recipes/tasks/task-base.bb
@@ -1,5 +1,5 @@
DESCRIPTION = "Merge machine and distro options to create a basic machine task/package"
-PR = "r86"
+PR = "r87"
inherit task
@@ -60,6 +60,9 @@ HOTPLUG ?= "${@base_contains("MACHINE_FEATURES", "kernel24", "linux-hotplug",""
#
DISTRO_SSH_DAEMON ?= "dropbear"
+# Distro can override apm provider
+DISTRO_APM ?= "apm"
+
#
# bluetooth manager
#
@@ -190,7 +193,7 @@ RDEPENDS_task-base-acpi = "\
acpid"
RDEPENDS_task-base-apm = "\
- apm \
+ "${DISTRO_APM}" \
apmd \
${@base_contains('MACHINE_FEATURES', 'kernel24', 'network-suspend-scripts', '',d)}"