aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/tasks/task-slugos.bb
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2010-06-02 15:04:25 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2010-06-03 07:33:27 +0200
commitd4276bed389b7db06db58c7acebb83f92bff86a5 (patch)
tree2386574b6ab0c36a58a314a24d31f6b5c9291a65 /recipes/tasks/task-slugos.bb
parent823aa270059259ca619e21a5d9b22e86afb12f3b (diff)
downloadopenembedded-d4276bed389b7db06db58c7acebb83f92bff86a5.tar.gz
recipes: conform to OE packaging guidelines with RDEPENDS/RRECOMMENDS
* there is probably very few cases when it's needed without _${PN}, if you find one in attached patch, please enlighten me * usually we want those only for ${PN} not for all ${PACKAGES} ie ${PN}-dev, ${PN)-doc etc * there is a check for this in recipe-sanity.bclass * there is maybe few possible fixes also in bbclasses cpan-base.bbclass:RDEPENDS += "${@["perl", ""][(bb.data.inherits_class('native', d))]}" distutils-base.bbclass:RDEPENDS += "python-core" gtk-icon-cache.bbclass:RDEPENDS += "hicolor-icon-theme" image.bbclass:RDEPENDS += "${IMAGE_INSTALL} ${IMAGE_BOOT}" module.bbclass:RDEPENDS += "kernel (${KERNEL_VERSION}) update-modules" ?opie_i18n.bbclass: rdepends = bb.data.getVar("RDEPENDS", d, 1) ?opie_i18n.bbclass: bb.data.setVar('RDEPENDS_%s' % x[0].lower(), pn, d) ?opie_i18n.bbclass: bb.data.setVar('RDEPENDS', rdepends, d) rubyextension.bbclass:RDEPENDS += "ruby" Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Acked-by: Koen Kooi <k-kooi@ti.com>
Diffstat (limited to 'recipes/tasks/task-slugos.bb')
-rw-r--r--recipes/tasks/task-slugos.bb12
1 files changed, 6 insertions, 6 deletions
diff --git a/recipes/tasks/task-slugos.bb b/recipes/tasks/task-slugos.bb
index 0ebf149480..69bf6caf11 100644
--- a/recipes/tasks/task-slugos.bb
+++ b/recipes/tasks/task-slugos.bb
@@ -81,7 +81,7 @@ kernel-module-md-mod \
kernel-module-raid1 \
"
-# Add the machine-specific RRECOMMENDS stuff -- kernel modules required for
+# Add the machine-specific RRECOMMENDS_${PN} stuff -- kernel modules required for
# network support.
SLUGOS_MACHINE_RRECOMMENDS_nslu2 = "\
kernel-module-mii \
@@ -89,7 +89,7 @@ kernel-module-ixp4xx-mac \
kernel-module-ixp4xx-qmgr \
"
-# Add machine-specific RDEPENDS stuff - packages such as the NPE firmware
+# Add machine-specific RDEPENDS_${PN} stuff - packages such as the NPE firmware
SLUGOS_MACHINE_RDEPENDS_nslu2 = "\
ixp4xx-npe \
"
@@ -100,7 +100,7 @@ DEPENDS += "${DISTRO_EXTRA_DEPENDS}"
DISTRO_EXTRA_RDEPENDS ?= ""
## This comment block is temporary, to be removed once SlugOS 5.0 stabilizes
-##RDEPENDS += "\
+##RDEPENDS_${PN} += "\
## kernel ixp4xx-npe \
## base-files base-passwd netbase \
## busybox initscripts-slugos slugos-init \
@@ -115,7 +115,7 @@ DISTRO_EXTRA_RDEPENDS ?= ""
## util-linux-losetup \
## ${SLUGOS_STANDARD_RDEPENDS} \
## ${DISTRO_EXTRA_RDEPENDS}"
-## SlugOS 5.0 - original RDEPENDS above for reference; tinylogin and the
+## SlugOS 5.0 - original RDEPENDS_${PN} above for reference; tinylogin and the
## util-linux-* utilities are now replaced by busybox tools. Also, ipkg
## is replaced by a trimmed-down version of opkg (no package signatures,
## and it uses the busybox wget command instead of libcurl - MJW
@@ -123,7 +123,7 @@ DISTRO_EXTRA_RDEPENDS ?= ""
## SlugOS 5.2 - module-init-tools reinstated due to busybox bugs - MJW
## SlugOS 5.4 - util-linux-mount reinstated due to busybox bugs - MJW
-RDEPENDS += "\
+RDEPENDS_${PN} += "\
kernel \
base-files base-passwd netbase \
busybox initscripts-slugos slugos-init \
@@ -138,7 +138,7 @@ RDEPENDS += "\
${DISTRO_EXTRA_RDEPENDS}"
DISTRO_EXTRA_RRECOMMENDS ?= ""
-RRECOMMENDS += "\
+RRECOMMENDS_${PN} += "\
openssh \
${SLUGOS_STANDARD_RRECOMMENDS} \
${SLUGOS_MACHINE_RRECOMMENDS} \