aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/tasks
diff options
context:
space:
mode:
authorSimon Busch <morphis@gravedo.de>2011-04-04 18:53:39 +0200
committerSimon Busch <morphis@gravedo.de>2011-04-05 18:11:50 +0200
commitb6fc3c342c028639afed7382aa766b1fa91f5029 (patch)
treec4b63d53107f3ed8672c6b5e4b5761f868710452 /recipes/tasks
parentc3265b14b23e1aec54f7794e753b28f0d0622d86 (diff)
downloadopenembedded-b6fc3c342c028639afed7382aa766b1fa91f5029.tar.gz
meta-toolchain-shr: add initial recipe
This is the start of a own toolchain for the SHR distribution. Later it will include several utilities to develop applications for SHR. Signed-off-by: Simon Busch <morphis@gravedo.de>
Diffstat (limited to 'recipes/tasks')
-rw-r--r--recipes/tasks/task-shr-toolchain-host.bb10
-rw-r--r--recipes/tasks/task-shr-toolchain-target.bb20
2 files changed, 30 insertions, 0 deletions
diff --git a/recipes/tasks/task-shr-toolchain-host.bb b/recipes/tasks/task-shr-toolchain-host.bb
new file mode 100644
index 0000000000..6419e09054
--- /dev/null
+++ b/recipes/tasks/task-shr-toolchain-host.bb
@@ -0,0 +1,10 @@
+require task-sdk-host.bb
+PR = "r1"
+DESCRIPTION = "Packages for a standalone SHR external toolchain"
+ALLOW_EMPTY = "1"
+
+PACKAGES = "${PN}"
+
+#RDEPENDS_${PN} += "\
+# devio-sdk \
+#"
diff --git a/recipes/tasks/task-shr-toolchain-target.bb b/recipes/tasks/task-shr-toolchain-target.bb
new file mode 100644
index 0000000000..35c01df22f
--- /dev/null
+++ b/recipes/tasks/task-shr-toolchain-target.bb
@@ -0,0 +1,20 @@
+DESCRIPTION = "Packages for a standalone SHR or external toolchain"
+LICENSE = "MIT"
+ALLOW_EMPTY = "1"
+
+PR = "r3.2"
+
+PACKAGES = "${PN}"
+
+# This is a starting point, and nothing more at present -- please fill
+# this out with a reasonable set of development tools for a SHR image.
+# Also feel free to remove stuff that's silly.
+
+RDEPENDS_${PN} = "\
+ eglibc eglibc-dbg eglibc-utils eglibc-dev eglibc-thread-db libsegfault \
+ libgcc libstdc++ libstdc++-dev \
+ libssl \
+ libcrypto \
+ openssl-dev \
+ zlib-dev \
+ "