aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/telepathy
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/telepathy
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/telepathy')
-rw-r--r--recipes/telepathy/empathy-0.1/no-gnome.diff39
-rw-r--r--recipes/telepathy/empathy-0.5/no-gnome.diff146
-rw-r--r--recipes/telepathy/empathy_0.1.bb17
-rw-r--r--recipes/telepathy/empathy_0.14.bb17
-rw-r--r--recipes/telepathy/empathy_0.4.bb18
-rw-r--r--recipes/telepathy/empathy_0.5.bb18
-rw-r--r--recipes/telepathy/empathy_2.23.90.bb23
-rw-r--r--recipes/telepathy/empathy_2.24.0.bb22
-rw-r--r--recipes/telepathy/libtelepathy_0.0.53.bb15
-rw-r--r--recipes/telepathy/libtelepathy_0.2.0.bb15
-rw-r--r--recipes/telepathy/libtelepathy_0.3.3.bb15
-rw-r--r--recipes/telepathy/telepathy-gabble-0.5.10/gabble.manager33
-rw-r--r--recipes/telepathy/telepathy-gabble-0.7.8/gabble.manager32
-rw-r--r--recipes/telepathy/telepathy-gabble_0.5.10.bb17
-rw-r--r--recipes/telepathy/telepathy-gabble_0.7.8.bb17
-rw-r--r--recipes/telepathy/telepathy-glib_0.5.10.bb40
-rw-r--r--recipes/telepathy/telepathy-glib_0.6.0.bb40
-rw-r--r--recipes/telepathy/telepathy-glib_0.7.14.bb40
-rw-r--r--recipes/telepathy/telepathy-idle_0.1.2.bb11
-rw-r--r--recipes/telepathy/telepathy-inspector/scons-workaround.patch12
-rw-r--r--recipes/telepathy/telepathy-inspector_0.5.0.bb11
-rw-r--r--recipes/telepathy/telepathy-mission-control_4.21.bb42
-rw-r--r--recipes/telepathy/telepathy-mission-control_4.22.bb42
-rw-r--r--recipes/telepathy/telepathy-mission-control_4.45.bb42
-rw-r--r--recipes/telepathy/telepathy-mission-control_4.67.bb52
-rw-r--r--recipes/telepathy/telepathy-python_0.14.0.bb8
-rw-r--r--recipes/telepathy/telepathy-python_0.15.1.bb8
-rw-r--r--recipes/telepathy/telepathy-salut-0.3.4/keep-manager-file.diff11
-rw-r--r--recipes/telepathy/telepathy-salut-0.3.4/salut.manager13
-rw-r--r--recipes/telepathy/telepathy-salut_0.3.4.bb18
30 files changed, 834 insertions, 0 deletions
diff --git a/recipes/telepathy/empathy-0.1/no-gnome.diff b/recipes/telepathy/empathy-0.1/no-gnome.diff
new file mode 100644
index 0000000000..4dd4a96354
--- /dev/null
+++ b/recipes/telepathy/empathy-0.1/no-gnome.diff
@@ -0,0 +1,39 @@
+diff -ur empathy-0.1.orig/configure.ac empathy-0.1/configure.ac
+--- empathy-0.1.orig/configure.ac 2007-04-25 23:05:40.000000000 +0100
++++ empathy-0.1/configure.ac 2007-04-27 17:10:29.000000000 +0100
+@@ -39,12 +39,12 @@
+
+ PKG_CHECK_MODULES(EMPATHY,
+ [
++ libxml-2.0
+ glib-2.0 >= $GLIB_REQUIRED
+ gobject-2.0
+ gtk+-2.0 >= $GTK_REQUIRED
+ gconf-2.0 >= $GCONF_REQUIRED
+ libglade-2.0 >= $LIBGLADE_REQUIRED
+- libgnomeui-2.0
+ libtelepathy >= $TELEPATHY_REQUIRED
+ libmissioncontrol >= $MISSION_CONTROL_REQUIRED
+ ])
+Only in empathy-0.1: configure.ac~
+diff -ur empathy-0.1.orig/libempathy-gtk/gossip-ui-utils.c empathy-0.1/libempathy-gtk/gossip-ui-utils.c
+--- empathy-0.1.orig/libempathy-gtk/gossip-ui-utils.c 2007-04-25 23:05:40.000000000 +0100
++++ empathy-0.1/libempathy-gtk/gossip-ui-utils.c 2007-04-27 17:06:48.000000000 +0100
+@@ -31,7 +31,6 @@
+ #include <glib/gi18n.h>
+ #include <gtk/gtk.h>
+ #include <glade/glade.h>
+-#include <libgnome/libgnome.h>
+
+ #include <libmissioncontrol/mc-profile.h>
+
+@@ -1307,7 +1306,7 @@
+ GError *error = NULL;
+
+ real_url = fixup_url (url);
+- gnome_url_show (real_url, &error);
++ g_warning ("TODO: gnome_url_show (real_url, &error);");
+ if (error) {
+ g_warning ("Couldn't show URL:'%s'", real_url);
+ g_error_free (error);
+Only in empathy-0.1/libempathy-gtk: gossip-ui-utils.c~
diff --git a/recipes/telepathy/empathy-0.5/no-gnome.diff b/recipes/telepathy/empathy-0.5/no-gnome.diff
new file mode 100644
index 0000000000..29d6276f51
--- /dev/null
+++ b/recipes/telepathy/empathy-0.5/no-gnome.diff
@@ -0,0 +1,146 @@
+Index: libempathy-gtk/gossip-ui-utils.c
+===================================================================
+--- libempathy-gtk/gossip-ui-utils.c (revision 99)
++++ libempathy-gtk/gossip-ui-utils.c (working copy)
+@@ -33,7 +33,7 @@
+ #include <glib/gi18n.h>
+ #include <gtk/gtk.h>
+ #include <glade/glade.h>
+-#include <libgnome/libgnome.h>
++#include <libgnomevfs/gnome-vfs-utils.h>
+
+ #include <libmissioncontrol/mc-profile.h>
+
+@@ -1280,13 +1280,14 @@
+ gossip_url_show (const char *url)
+ {
+ gchar *real_url;
+- GError *error = NULL;
++ GnomeVFSResult res;
+
+ real_url = fixup_url (url);
+- gnome_url_show (real_url, &error);
+- if (error) {
+- g_warning ("Couldn't show URL:'%s'", real_url);
+- g_error_free (error);
++ res = gnome_vfs_url_show (real_url);
++ if (res != GNOME_VFS_OK) {
++ g_warning ("Couldn't show URL %s: %s",
++ real_url,
++ gnome_vfs_result_to_string (res));
+ }
+
+ g_free (real_url);
+Index: src/empathy-chat-main.c
+===================================================================
+--- src/empathy-chat-main.c (revision 99)
++++ src/empathy-chat-main.c (working copy)
+@@ -28,9 +28,6 @@
+ #include <glib/gi18n.h>
+ #include <gtk/gtk.h>
+
+-#include <libgnome/gnome-program.h>
+-#include <libgnomeui/gnome-ui-init.h>
+-
+ #include <libtelepathy/tp-conn.h>
+ #include <libtelepathy/tp-chan.h>
+ #include <libmissioncontrol/mc-account.h>
+@@ -162,7 +159,6 @@
+ main (int argc, char *argv[])
+ {
+ EmpathyChandler *chandler;
+- GnomeProgram *program;
+ gchar *localedir;
+
+ localedir = gossip_paths_get_locale_path ();
+@@ -171,14 +167,8 @@
+ textdomain (GETTEXT_PACKAGE);
+ g_free (localedir);
+
+- program = gnome_program_init ("empathy-chat",
+- PACKAGE_VERSION,
+- LIBGNOMEUI_MODULE,
+- argc, argv,
+- GNOME_PROGRAM_STANDARD_PROPERTIES,
+- GNOME_PARAM_HUMAN_READABLE_NAME, PACKAGE_NAME,
+- NULL);
+-
++ gtk_init (&argc, &argv);
++
+ gtk_window_set_default_icon_name ("empathy");
+
+ if (g_getenv ("EMPATHY_DEBUG")) {
+@@ -194,7 +184,6 @@
+
+ gtk_main ();
+
+- g_object_unref (program);
+ g_object_unref (chandler);
+
+ return EXIT_SUCCESS;
+Index: src/empathy-main.c
+===================================================================
+--- src/empathy-main.c (revision 99)
++++ src/empathy-main.c (working copy)
+@@ -28,9 +28,6 @@
+ #include <glib/gi18n.h>
+ #include <gtk/gtk.h>
+
+-#include <libgnome/gnome-program.h>
+-#include <libgnomeui/gnome-ui-init.h>
+-
+ #include <libmissioncontrol/mc-account.h>
+ #include <libmissioncontrol/mc-account-monitor.h>
+ #include <libmissioncontrol/mission-control.h>
+@@ -136,7 +133,6 @@
+ McAccountMonitor *monitor;
+ EmpathyFilter *filter;
+ gchar *localedir;
+- GnomeProgram *program;
+ gboolean no_connect = FALSE;
+ GOptionContext *context;
+ GOptionEntry options[] = {
+@@ -157,14 +153,8 @@
+
+ g_set_application_name (PACKAGE_NAME);
+
+- program = gnome_program_init ("empathy",
+- PACKAGE_VERSION,
+- LIBGNOMEUI_MODULE,
+- argc, argv,
+- GNOME_PROGRAM_STANDARD_PROPERTIES,
+- "goption-context", context,
+- GNOME_PARAM_HUMAN_READABLE_NAME, PACKAGE_NAME,
+- NULL);
++ gtk_init (&argc, &argv);
++ /* TODO: option parsing */
+
+ gtk_window_set_default_icon_name ("empathy");
+
+@@ -204,7 +194,6 @@
+ g_object_unref (monitor);
+ g_object_unref (mc);
+ g_object_unref (icon);
+- g_object_unref (program);
+
+ return EXIT_SUCCESS;
+ }
+Index: configure.ac
+===================================================================
+--- configure.ac (revision 99)
++++ configure.ac (working copy)
+@@ -62,12 +62,13 @@
+
+ PKG_CHECK_MODULES(EMPATHY,
+ [
++ libxml-2.0
+ glib-2.0 >= $GLIB_REQUIRED
+ gobject-2.0
+ gtk+-2.0 >= $GTK_REQUIRED
+ gconf-2.0 >= $GCONF_REQUIRED
+ libglade-2.0 >= $LIBGLADE_REQUIRED
+- libgnomeui-2.0
++ gnome-vfs-2.0
+ libtelepathy >= $TELEPATHY_REQUIRED
+ libmissioncontrol >= $MISSION_CONTROL_REQUIRED
+ ])
diff --git a/recipes/telepathy/empathy_0.1.bb b/recipes/telepathy/empathy_0.1.bb
new file mode 100644
index 0000000000..d76f17051c
--- /dev/null
+++ b/recipes/telepathy/empathy_0.1.bb
@@ -0,0 +1,17 @@
+DESCRIPTION = "Empathy: a Telepathy based IM client"
+HOMEPAGE = "http://blogs.gnome.org/view/xclaesse/2007/04/26/0"
+LICENSE = "GPL"
+DEPENDS = "telepathy-mission-control libtelepathy gtk+ gconf libglade"
+RDEPENDS = "telepathy-mission-control"
+RRECOMMENDS = "telepathy-gabble"
+
+PR ="r1"
+
+SRC_URI = "http://projects.collabora.co.uk/~xclaesse/empathy-0.1.tar.gz \
+ file://no-gnome.diff;patch=1"
+
+inherit autotools pkgconfig
+
+FILES_${PN} += "/usr/share/mission-control/profiles/*.profile \
+ /usr/share/dbus-1/services/*.service \
+ /usr/share/telepathy/managers/*.chandler"
diff --git a/recipes/telepathy/empathy_0.14.bb b/recipes/telepathy/empathy_0.14.bb
new file mode 100644
index 0000000000..6c3c15ef2c
--- /dev/null
+++ b/recipes/telepathy/empathy_0.14.bb
@@ -0,0 +1,17 @@
+DESCRIPTION = "Empathy: a Telepathy based IM client"
+HOMEPAGE = "http://blogs.gnome.org/view/xclaesse/2007/04/26/0"
+LICENSE = "GPL"
+DEPENDS = "telepathy-mission-control libtelepathy gtk+ gconf libglade gnome-vfs"
+RDEPENDS = "telepathy-mission-control"
+RRECOMMENDS = "telepathy-gabble"
+
+PR ="r0"
+
+inherit gnome
+
+SRC_URI = "http://ftp.gnome.org/pub/GNOME/sources/empathy/${PV}/empathy-${PV}.tar.bz2"
+
+FILES_${PN} += "${datadir}/mission-control/profiles/*.profile \
+ ${datadir}/dbus-1/services/*.service \
+ ${datadir}/telepathy/managers/*.chandler \
+ ${datadir}/icons"
diff --git a/recipes/telepathy/empathy_0.4.bb b/recipes/telepathy/empathy_0.4.bb
new file mode 100644
index 0000000000..97df361d3d
--- /dev/null
+++ b/recipes/telepathy/empathy_0.4.bb
@@ -0,0 +1,18 @@
+DESCRIPTION = "Empathy: a Telepathy based IM client"
+HOMEPAGE = "http://blogs.gnome.org/view/xclaesse/2007/04/26/0"
+LICENSE = "GPL"
+DEPENDS = "libgnomeui telepathy-mission-control libtelepathy gtk+ gconf libglade"
+RDEPENDS = "telepathy-mission-control"
+RRECOMMENDS = "telepathy-gabble"
+
+PR ="r0"
+
+inherit gnome
+
+SRC_URI = "http://ftp.gnome.org/pub/GNOME/sources/empathy/0.4/empathy-${PV}.tar.bz2 \
+ "
+
+FILES_${PN} += "${datadir}/mission-control/profiles/*.profile \
+ ${datadir}/dbus-1/services/*.service \
+ ${datadir}/telepathy/managers/*.chandler \
+ ${datadir}/icons"
diff --git a/recipes/telepathy/empathy_0.5.bb b/recipes/telepathy/empathy_0.5.bb
new file mode 100644
index 0000000000..6774b6b027
--- /dev/null
+++ b/recipes/telepathy/empathy_0.5.bb
@@ -0,0 +1,18 @@
+DESCRIPTION = "Empathy: a Telepathy based IM client"
+HOMEPAGE = "http://blogs.gnome.org/view/xclaesse/2007/04/26/0"
+LICENSE = "GPL"
+DEPENDS = "telepathy-mission-control libtelepathy gtk+ gconf libglade gnome-vfs"
+RDEPENDS = "telepathy-mission-control"
+RRECOMMENDS = "telepathy-gabble"
+
+PR ="r1"
+
+inherit gnome
+
+SRC_URI = "http://ftp.gnome.org/pub/GNOME/sources/empathy/0.5/empathy-${PV}.tar.bz2 \
+ file://no-gnome.diff;patch=1;pnum=0"
+
+FILES_${PN} += "${datadir}/mission-control/profiles/*.profile \
+ ${datadir}/dbus-1/services/*.service \
+ ${datadir}/telepathy/managers/*.chandler \
+ ${datadir}/icons"
diff --git a/recipes/telepathy/empathy_2.23.90.bb b/recipes/telepathy/empathy_2.23.90.bb
new file mode 100644
index 0000000000..ff304f918e
--- /dev/null
+++ b/recipes/telepathy/empathy_2.23.90.bb
@@ -0,0 +1,23 @@
+DESCRIPTION = "Empathy: a Telepathy based IM client"
+HOMEPAGE = "http://blogs.gnome.org/view/xclaesse/2007/04/26/0"
+LICENSE = "GPL"
+DEPENDS = "python-native telepathy-python telepathy-mission-control libtelepathy telepathy-glib gtk+ gconf libglade eds-dbus"
+RDEPENDS = "telepathy-mission-control"
+RRECOMMENDS = "telepathy-gabble"
+
+inherit gnome
+
+PARALLEL_MAKE = ""
+PR = "r1"
+
+PACKAGES =+ "empathy-scrollkeeper-junk"
+FILES_empathy-scrollkeeper-junk = "/var/lib/scrollkeeper"
+
+FILES_${PN} += "${datadir}/mission-control/profiles/*.profile \
+ ${datadir}/dbus-1/services/*.service \
+ ${datadir}/telepathy/managers/*.chandler \
+ ${datadir}/icons \
+ ${libdir}/python*"
+
+FILES_${PN}-dbg += "${libdir}/python*/*/.debug"
+
diff --git a/recipes/telepathy/empathy_2.24.0.bb b/recipes/telepathy/empathy_2.24.0.bb
new file mode 100644
index 0000000000..b9cf1d5ac9
--- /dev/null
+++ b/recipes/telepathy/empathy_2.24.0.bb
@@ -0,0 +1,22 @@
+DESCRIPTION = "Empathy: a Telepathy based IM client"
+HOMEPAGE = "http://blogs.gnome.org/view/xclaesse/2007/04/26/0"
+LICENSE = "GPL"
+DEPENDS = "gnome-doc-utils python-native telepathy-python telepathy-mission-control libtelepathy telepathy-glib gtk+ gconf libglade eds-dbus"
+RDEPENDS = "telepathy-mission-control"
+RRECOMMENDS = "telepathy-gabble"
+
+inherit gnome
+
+PARALLEL_MAKE = ""
+
+PACKAGES =+ "empathy-scrollkeeper-junk"
+FILES_empathy-scrollkeeper-junk = "/var/lib/scrollkeeper"
+
+FILES_${PN} += "${datadir}/mission-control/profiles/*.profile \
+ ${datadir}/dbus-1/services/*.service \
+ ${datadir}/telepathy/managers/*.chandler \
+ ${datadir}/icons \
+ ${libdir}/python*"
+
+FILES_${PN}-dbg += "${libdir}/python*/*/.debug"
+
diff --git a/recipes/telepathy/libtelepathy_0.0.53.bb b/recipes/telepathy/libtelepathy_0.0.53.bb
new file mode 100644
index 0000000000..f3e4f37521
--- /dev/null
+++ b/recipes/telepathy/libtelepathy_0.0.53.bb
@@ -0,0 +1,15 @@
+HOMEPAGE = "http://telepathy.freedesktop.org/wiki/"
+DEPENDS = "glib-2.0 dbus"
+LICENSE = "LGPL"
+PR = "r1"
+
+SRC_URI = "http://telepathy.freedesktop.org/releases/libtelepathy/libtelepathy-${PV}.tar.gz"
+
+inherit autotools pkgconfig
+
+FILES_${PN} += "${datadir}/telepathy \
+ ${datadir}/dbus-1"
+
+do_stage() {
+ autotools_stage_all
+}
diff --git a/recipes/telepathy/libtelepathy_0.2.0.bb b/recipes/telepathy/libtelepathy_0.2.0.bb
new file mode 100644
index 0000000000..d30b301d38
--- /dev/null
+++ b/recipes/telepathy/libtelepathy_0.2.0.bb
@@ -0,0 +1,15 @@
+HOMEPAGE = "http://telepathy.freedesktop.org/wiki/"
+DEPENDS = "glib-2.0 dbus"
+LICENSE = "LGPL"
+PR = "r0"
+
+SRC_URI = "http://telepathy.freedesktop.org/releases/libtelepathy/libtelepathy-${PV}.tar.gz"
+
+inherit autotools pkgconfig
+
+FILES_${PN} += "${datadir}/telepathy \
+ ${datadir}/dbus-1"
+
+do_stage() {
+ autotools_stage_all
+}
diff --git a/recipes/telepathy/libtelepathy_0.3.3.bb b/recipes/telepathy/libtelepathy_0.3.3.bb
new file mode 100644
index 0000000000..3f34081379
--- /dev/null
+++ b/recipes/telepathy/libtelepathy_0.3.3.bb
@@ -0,0 +1,15 @@
+HOMEPAGE = "http://telepathy.freedesktop.org/wiki/"
+DEPENDS = "telepathy-glib glib-2.0 dbus"
+LICENSE = "LGPL"
+PR = "r0"
+
+SRC_URI = "http://telepathy.freedesktop.org/releases/libtelepathy/libtelepathy-${PV}.tar.gz"
+
+inherit autotools pkgconfig
+
+FILES_${PN} += "${datadir}/telepathy \
+ ${datadir}/dbus-1"
+
+do_stage() {
+ autotools_stage_all
+}
diff --git a/recipes/telepathy/telepathy-gabble-0.5.10/gabble.manager b/recipes/telepathy/telepathy-gabble-0.5.10/gabble.manager
new file mode 100644
index 0000000000..9000cd41cc
--- /dev/null
+++ b/recipes/telepathy/telepathy-gabble-0.5.10/gabble.manager
@@ -0,0 +1,33 @@
+
+[ConnectionManager]
+BusName=org.freedesktop.Telepathy.ConnectionManager.gabble
+ObjectPath=/org/freedesktop/Telepathy/ConnectionManager/gabble
+
+[Protocol jabber]
+param-account=s required register
+param-password=s required register
+param-server=s
+param-resource=s
+param-priority=n
+param-port=q
+param-old-ssl=b
+param-register=b
+param-low-bandwidth=b
+param-https-proxy-server=s
+param-https-proxy-port=q
+param-fallback-conference-server=s
+param-stun-server=s
+param-stun-port=q
+param-ignore-ssl-errors=b
+param-alias=s
+param-mac=s
+param-btid=s
+default-resource=Telepathy
+default-priority=0
+default-port=5222
+default-old-ssl=false
+default-register=false
+default-low-bandwidth=false
+default-https-proxy-port=443
+default-stun-port=3478
+default-ignore-ssl-errors=false
diff --git a/recipes/telepathy/telepathy-gabble-0.7.8/gabble.manager b/recipes/telepathy/telepathy-gabble-0.7.8/gabble.manager
new file mode 100644
index 0000000000..d09b838090
--- /dev/null
+++ b/recipes/telepathy/telepathy-gabble-0.7.8/gabble.manager
@@ -0,0 +1,32 @@
+
+[ConnectionManager]
+BusName=org.freedesktop.Telepathy.ConnectionManager.gabble
+ObjectPath=/org/freedesktop/Telepathy/ConnectionManager/gabble
+
+[Protocol jabber]
+param-account=s required register
+param-password=s required register
+param-server=s
+param-resource=s
+param-priority=n
+param-port=q
+param-old-ssl=b
+param-require-encryption=b
+param-register=b
+param-low-bandwidth=b
+param-https-proxy-server=s
+param-https-proxy-port=q
+param-fallback-conference-server=s
+param-stun-server=s
+param-stun-port=q
+param-ignore-ssl-errors=b
+param-alias=s
+default-resource=Telepathy
+default-priority=0
+default-old-ssl=false
+default-require-encryption=false
+default-register=false
+default-low-bandwidth=false
+default-https-proxy-port=443
+default-stun-port=3478
+default-ignore-ssl-errors=false
diff --git a/recipes/telepathy/telepathy-gabble_0.5.10.bb b/recipes/telepathy/telepathy-gabble_0.5.10.bb
new file mode 100644
index 0000000000..fbc209eeb5
--- /dev/null
+++ b/recipes/telepathy/telepathy-gabble_0.5.10.bb
@@ -0,0 +1,17 @@
+DESCRIPTION = "Gabble: a Jabber/XMPP connection manager"
+HOMEPAGE = "http://telepathy.freedesktop.org/wiki/"
+DEPENDS = "glib-2.0 dbus loudmouth telepathy-glib"
+LICENSE = "LGPL"
+
+# gabble.manager needs to get regenerated every release, so please don't copy it over blindly
+SRC_URI = "http://telepathy.freedesktop.org/releases/telepathy-gabble/${P}.tar.gz \
+ file://gabble.manager"
+
+inherit autotools pkgconfig
+
+do_compile_prepend() {
+ cp ${WORKDIR}/gabble.manager ${S}/data/
+}
+
+FILES_${PN} += "${datadir}/telepathy \
+ ${datadir}/dbus-1"
diff --git a/recipes/telepathy/telepathy-gabble_0.7.8.bb b/recipes/telepathy/telepathy-gabble_0.7.8.bb
new file mode 100644
index 0000000000..fbc209eeb5
--- /dev/null
+++ b/recipes/telepathy/telepathy-gabble_0.7.8.bb
@@ -0,0 +1,17 @@
+DESCRIPTION = "Gabble: a Jabber/XMPP connection manager"
+HOMEPAGE = "http://telepathy.freedesktop.org/wiki/"
+DEPENDS = "glib-2.0 dbus loudmouth telepathy-glib"
+LICENSE = "LGPL"
+
+# gabble.manager needs to get regenerated every release, so please don't copy it over blindly
+SRC_URI = "http://telepathy.freedesktop.org/releases/telepathy-gabble/${P}.tar.gz \
+ file://gabble.manager"
+
+inherit autotools pkgconfig
+
+do_compile_prepend() {
+ cp ${WORKDIR}/gabble.manager ${S}/data/
+}
+
+FILES_${PN} += "${datadir}/telepathy \
+ ${datadir}/dbus-1"
diff --git a/recipes/telepathy/telepathy-glib_0.5.10.bb b/recipes/telepathy/telepathy-glib_0.5.10.bb
new file mode 100644
index 0000000000..f6b6a6c6b3
--- /dev/null
+++ b/recipes/telepathy/telepathy-glib_0.5.10.bb
@@ -0,0 +1,40 @@
+DESCRIPTION = "Telepathy framework - GLib library"
+HOMEPAGE = "http://telepathy.freedesktop.org/wiki/"
+DEPENDS = "glib-2.0 dbus python-native dbus-native"
+LICENSE = "LGPL"
+
+SRC_URI = "http://telepathy.freedesktop.org/releases/telepathy-glib/${P}.tar.gz "
+
+inherit autotools pkgconfig
+
+FILES_${PN} += "${datadir}/telepathy \
+ ${datadir}/dbus-1"
+
+do_stage() {
+ #
+ # copied autotools_stage_all because telepathy-glib has one lib only built as static
+ # so it can not be oe_libinstalled
+ #
+ rm -rf ${STAGE_TEMP}
+ mkdir -p ${STAGE_TEMP}
+ oe_runmake DESTDIR="${STAGE_TEMP}" install
+ if [ -d ${STAGE_TEMP}/${includedir} ]; then
+ cp -fpPR ${STAGE_TEMP}/${includedir}/* ${STAGING_INCDIR}
+ fi
+ if [ -d ${STAGE_TEMP}/${libdir} ]
+ then
+ for i in ${STAGE_TEMP}/${libdir}/*.la
+ do
+ if [ ! -f "$i" ]; then
+ cp -fpPR ${STAGE_TEMP}/${libdir}/* ${STAGING_LIBDIR}
+ break
+ fi
+ done
+ oe_libinstall -so -C telepathy-glib/.libs libtelepathy-glib ${STAGING_LIBDIR}
+ fi
+ if [ -d ${STAGE_TEMP}/${datadir}/aclocal ]; then
+ install -d ${STAGING_DATADIR}/aclocal
+ cp -fpPR ${STAGE_TEMP}/${datadir}/aclocal/* ${STAGING_DATADIR}/aclocal
+ fi
+ rm -rf ${STAGE_TEMP}
+}
diff --git a/recipes/telepathy/telepathy-glib_0.6.0.bb b/recipes/telepathy/telepathy-glib_0.6.0.bb
new file mode 100644
index 0000000000..f6b6a6c6b3
--- /dev/null
+++ b/recipes/telepathy/telepathy-glib_0.6.0.bb
@@ -0,0 +1,40 @@
+DESCRIPTION = "Telepathy framework - GLib library"
+HOMEPAGE = "http://telepathy.freedesktop.org/wiki/"
+DEPENDS = "glib-2.0 dbus python-native dbus-native"
+LICENSE = "LGPL"
+
+SRC_URI = "http://telepathy.freedesktop.org/releases/telepathy-glib/${P}.tar.gz "
+
+inherit autotools pkgconfig
+
+FILES_${PN} += "${datadir}/telepathy \
+ ${datadir}/dbus-1"
+
+do_stage() {
+ #
+ # copied autotools_stage_all because telepathy-glib has one lib only built as static
+ # so it can not be oe_libinstalled
+ #
+ rm -rf ${STAGE_TEMP}
+ mkdir -p ${STAGE_TEMP}
+ oe_runmake DESTDIR="${STAGE_TEMP}" install
+ if [ -d ${STAGE_TEMP}/${includedir} ]; then
+ cp -fpPR ${STAGE_TEMP}/${includedir}/* ${STAGING_INCDIR}
+ fi
+ if [ -d ${STAGE_TEMP}/${libdir} ]
+ then
+ for i in ${STAGE_TEMP}/${libdir}/*.la
+ do
+ if [ ! -f "$i" ]; then
+ cp -fpPR ${STAGE_TEMP}/${libdir}/* ${STAGING_LIBDIR}
+ break
+ fi
+ done
+ oe_libinstall -so -C telepathy-glib/.libs libtelepathy-glib ${STAGING_LIBDIR}
+ fi
+ if [ -d ${STAGE_TEMP}/${datadir}/aclocal ]; then
+ install -d ${STAGING_DATADIR}/aclocal
+ cp -fpPR ${STAGE_TEMP}/${datadir}/aclocal/* ${STAGING_DATADIR}/aclocal
+ fi
+ rm -rf ${STAGE_TEMP}
+}
diff --git a/recipes/telepathy/telepathy-glib_0.7.14.bb b/recipes/telepathy/telepathy-glib_0.7.14.bb
new file mode 100644
index 0000000000..77970fa3ab
--- /dev/null
+++ b/recipes/telepathy/telepathy-glib_0.7.14.bb
@@ -0,0 +1,40 @@
+DESCRIPTION = "Telepathy framework - GLib library"
+HOMEPAGE = "http://telepathy.freedesktop.org/wiki/"
+DEPENDS = "glib-2.0 dbus libxslt-native python-native dbus-native"
+LICENSE = "LGPL"
+
+SRC_URI = "http://telepathy.freedesktop.org/releases/telepathy-glib/${P}.tar.gz "
+
+inherit autotools pkgconfig
+
+FILES_${PN} += "${datadir}/telepathy \
+ ${datadir}/dbus-1"
+
+do_stage() {
+ #
+ # copied autotools_stage_all because telepathy-glib has one lib only built as static
+ # so it can not be oe_libinstalled
+ #
+ rm -rf ${STAGE_TEMP}
+ mkdir -p ${STAGE_TEMP}
+ oe_runmake DESTDIR="${STAGE_TEMP}" install
+ if [ -d ${STAGE_TEMP}/${includedir} ]; then
+ cp -fpPR ${STAGE_TEMP}/${includedir}/* ${STAGING_INCDIR}
+ fi
+ if [ -d ${STAGE_TEMP}/${libdir} ]
+ then
+ for i in ${STAGE_TEMP}/${libdir}/*.la
+ do
+ if [ ! -f "$i" ]; then
+ cp -fpPR ${STAGE_TEMP}/${libdir}/* ${STAGING_LIBDIR}
+ break
+ fi
+ done
+ oe_libinstall -so -C telepathy-glib/.libs libtelepathy-glib ${STAGING_LIBDIR}
+ fi
+ if [ -d ${STAGE_TEMP}/${datadir}/aclocal ]; then
+ install -d ${STAGING_DATADIR}/aclocal
+ cp -fpPR ${STAGE_TEMP}/${datadir}/aclocal/* ${STAGING_DATADIR}/aclocal
+ fi
+ rm -rf ${STAGE_TEMP}
+}
diff --git a/recipes/telepathy/telepathy-idle_0.1.2.bb b/recipes/telepathy/telepathy-idle_0.1.2.bb
new file mode 100644
index 0000000000..d152e31a21
--- /dev/null
+++ b/recipes/telepathy/telepathy-idle_0.1.2.bb
@@ -0,0 +1,11 @@
+DESCRIPTION = "IRC connection manager for Telepathy"
+HOMEPAGE = "http://telepathy.freedesktop.org/wiki/"
+DEPENDS = "glib-2.0 dbus telepathy-glib openssl"
+LICENSE = "LGPL"
+
+SRC_URI = "http://telepathy.freedesktop.org/releases/${PN}/${P}.tar.gz"
+
+inherit autotools pkgconfig
+
+FILES_${PN} += "${datadir}/telepathy \
+ ${datadir}/dbus-1"
diff --git a/recipes/telepathy/telepathy-inspector/scons-workaround.patch b/recipes/telepathy/telepathy-inspector/scons-workaround.patch
new file mode 100644
index 0000000000..ac3c37cb9c
--- /dev/null
+++ b/recipes/telepathy/telepathy-inspector/scons-workaround.patch
@@ -0,0 +1,12 @@
+Index: telepathy-inspector-0.5.0/SConstruct
+===================================================================
+--- telepathy-inspector-0.5.0.orig/SConstruct 2007-10-31 10:49:00.000000000 +0100
++++ telepathy-inspector-0.5.0/SConstruct 2007-10-31 10:49:10.000000000 +0100
+@@ -4,6 +4,7 @@
+ SConsignFile()
+
+ env = Environment(ENV = os.environ)
++env['CC'] = os.environ['CC']
+
+ # Variables
+
diff --git a/recipes/telepathy/telepathy-inspector_0.5.0.bb b/recipes/telepathy/telepathy-inspector_0.5.0.bb
new file mode 100644
index 0000000000..069430775a
--- /dev/null
+++ b/recipes/telepathy/telepathy-inspector_0.5.0.bb
@@ -0,0 +1,11 @@
+DESCRIPTION = "debugging tool for Telepathy developers"
+DEPENDS = "glib-2.0 gtk+ libglade dbus-glib"
+LICENSE = "LGPL"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/tapioca-voip/telepathy-inspector-0.5.0.tar.gz \
+ file://scons-workaround.patch;patch=1"
+
+inherit scons
+
+FILES_${PN} += "${datadir}/telepathy \
+ ${datadir}/dbus-1"
diff --git a/recipes/telepathy/telepathy-mission-control_4.21.bb b/recipes/telepathy/telepathy-mission-control_4.21.bb
new file mode 100644
index 0000000000..6d43b805bd
--- /dev/null
+++ b/recipes/telepathy/telepathy-mission-control_4.21.bb
@@ -0,0 +1,42 @@
+DESCRIPTION = "Telepathy Mission Control"
+HOMEPAGE = "http://mission-control.sourceforge.net/"
+LICENSE = "LGPL"
+SECTION = "libs"
+DEPENDS = "libtelepathy dbus-glib gconf"
+PR = "r1"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/mission-control/telepathy-mission-control-${PV}.tar.gz"
+
+inherit autotools pkgconfig
+
+PACKAGES =+ " \
+ libmissioncontrol \
+ libmissioncontrol-config \
+ libmissioncontrol-server \
+ libmissioncontrol-dev \
+ libmissioncontrol-config-dev \
+ libmissioncontrol-server-dev \
+ libmissioncontrol-dbg \
+ libmissioncontrol-config-dbg \
+ libmissioncontrol-server-dbg \
+"
+
+FILES_${PN} += "${datadir}/dbus*"
+
+FILES_libmissioncontrol = "${libdir}/libmissioncontrol.so.*"
+FILES_libmissioncontrol-config = "${libdir}/libmissioncontrol-config.so.*"
+FILES_libmissioncontrol-server = "${libdir}/libmissioncontrol-server.so.*"
+
+FILES_libmissioncontrol-dev = "${libdir}/libmissioncontrol.* \
+ ${includedir}/libmissioncontrol/ \
+ ${libdir}/pkgconfig/libmissioncontrol.pc"
+FILES_libmissioncontrol-config-dev = "${libdir}/libmissioncontrol-config.*"
+FILES_libmissioncontrol-server-dev = "${libdir}/libmissioncontrol-server.*"
+
+FILES_libmissioncontrol-dbg += "${libdir}/.debug/libmissioncontrol.so.*"
+FILES_libmissioncontrol-config-dbg += "${libdir}/.debug/libmissioncontrol-config.so.*"
+FILES_libmissioncontrol-server-dbg += "${libdir}/.debug/libmissioncontrol-server.so.*"
+
+do_stage() {
+ autotools_stage_all
+}
diff --git a/recipes/telepathy/telepathy-mission-control_4.22.bb b/recipes/telepathy/telepathy-mission-control_4.22.bb
new file mode 100644
index 0000000000..a0afbb068f
--- /dev/null
+++ b/recipes/telepathy/telepathy-mission-control_4.22.bb
@@ -0,0 +1,42 @@
+DESCRIPTION = "Telepathy Mission Control"
+HOMEPAGE = "http://mission-control.sourceforge.net/"
+LICENSE = "LGPL"
+SECTION = "libs"
+DEPENDS = "libtelepathy dbus-glib gconf"
+PR = "r0"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/mission-control/telepathy-mission-control-${PV}.tar.gz"
+
+inherit autotools pkgconfig
+
+PACKAGES =+ " \
+ libmissioncontrol \
+ libmissioncontrol-config \
+ libmissioncontrol-server \
+ libmissioncontrol-dev \
+ libmissioncontrol-config-dev \
+ libmissioncontrol-server-dev \
+ libmissioncontrol-dbg \
+ libmissioncontrol-config-dbg \
+ libmissioncontrol-server-dbg \
+"
+
+FILES_${PN} += "${datadir}/dbus*"
+
+FILES_libmissioncontrol = "${libdir}/libmissioncontrol.so.*"
+FILES_libmissioncontrol-config = "${libdir}/libmissioncontrol-config.so.*"
+FILES_libmissioncontrol-server = "${libdir}/libmissioncontrol-server.so.*"
+
+FILES_libmissioncontrol-dev = "${libdir}/libmissioncontrol.* \
+ ${includedir}/libmissioncontrol/ \
+ ${libdir}/pkgconfig/libmissioncontrol.pc"
+FILES_libmissioncontrol-config-dev = "${libdir}/libmissioncontrol-config.*"
+FILES_libmissioncontrol-server-dev = "${libdir}/libmissioncontrol-server.*"
+
+FILES_libmissioncontrol-dbg += "${libdir}/.debug/libmissioncontrol.so.*"
+FILES_libmissioncontrol-config-dbg += "${libdir}/.debug/libmissioncontrol-config.so.*"
+FILES_libmissioncontrol-server-dbg += "${libdir}/.debug/libmissioncontrol-server.so.*"
+
+do_stage() {
+ autotools_stage_all
+}
diff --git a/recipes/telepathy/telepathy-mission-control_4.45.bb b/recipes/telepathy/telepathy-mission-control_4.45.bb
new file mode 100644
index 0000000000..a0afbb068f
--- /dev/null
+++ b/recipes/telepathy/telepathy-mission-control_4.45.bb
@@ -0,0 +1,42 @@
+DESCRIPTION = "Telepathy Mission Control"
+HOMEPAGE = "http://mission-control.sourceforge.net/"
+LICENSE = "LGPL"
+SECTION = "libs"
+DEPENDS = "libtelepathy dbus-glib gconf"
+PR = "r0"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/mission-control/telepathy-mission-control-${PV}.tar.gz"
+
+inherit autotools pkgconfig
+
+PACKAGES =+ " \
+ libmissioncontrol \
+ libmissioncontrol-config \
+ libmissioncontrol-server \
+ libmissioncontrol-dev \
+ libmissioncontrol-config-dev \
+ libmissioncontrol-server-dev \
+ libmissioncontrol-dbg \
+ libmissioncontrol-config-dbg \
+ libmissioncontrol-server-dbg \
+"
+
+FILES_${PN} += "${datadir}/dbus*"
+
+FILES_libmissioncontrol = "${libdir}/libmissioncontrol.so.*"
+FILES_libmissioncontrol-config = "${libdir}/libmissioncontrol-config.so.*"
+FILES_libmissioncontrol-server = "${libdir}/libmissioncontrol-server.so.*"
+
+FILES_libmissioncontrol-dev = "${libdir}/libmissioncontrol.* \
+ ${includedir}/libmissioncontrol/ \
+ ${libdir}/pkgconfig/libmissioncontrol.pc"
+FILES_libmissioncontrol-config-dev = "${libdir}/libmissioncontrol-config.*"
+FILES_libmissioncontrol-server-dev = "${libdir}/libmissioncontrol-server.*"
+
+FILES_libmissioncontrol-dbg += "${libdir}/.debug/libmissioncontrol.so.*"
+FILES_libmissioncontrol-config-dbg += "${libdir}/.debug/libmissioncontrol-config.so.*"
+FILES_libmissioncontrol-server-dbg += "${libdir}/.debug/libmissioncontrol-server.so.*"
+
+do_stage() {
+ autotools_stage_all
+}
diff --git a/recipes/telepathy/telepathy-mission-control_4.67.bb b/recipes/telepathy/telepathy-mission-control_4.67.bb
new file mode 100644
index 0000000000..418a265512
--- /dev/null
+++ b/recipes/telepathy/telepathy-mission-control_4.67.bb
@@ -0,0 +1,52 @@
+DESCRIPTION = "Telepathy Mission Control"
+HOMEPAGE = "http://mission-control.sourceforge.net/"
+LICENSE = "LGPL"
+SECTION = "libs"
+DEPENDS = "libtelepathy dbus-glib gconf"
+PR = "r0"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/mission-control/telepathy-mission-control-${PV}.tar.gz"
+
+inherit autotools
+
+PACKAGES =+ " \
+ libmissioncontrol \
+ libmissioncontrol-config \
+ libmissioncontrol-server \
+ libmissioncontrol-dev \
+ libmissioncontrol-config-dev \
+ libmissioncontrol-server-dev \
+ libmissioncontrol-dbg \
+ libmissioncontrol-config-dbg \
+ libmissioncontrol-server-dbg \
+"
+
+FILES_${PN} += "${datadir}/dbus*"
+
+FILES_libmissioncontrol = "${libdir}/libmissioncontrol.so.*"
+FILES_libmissioncontrol-config = "${libdir}/libmissioncontrol-config.so.*"
+FILES_libmissioncontrol-server = "${libdir}/libmissioncontrol-server.so.*"
+
+FILES_libmissioncontrol-dev = "${libdir}/libmissioncontrol.* \
+ ${includedir}/libmissioncontrol/ \
+ ${libdir}/pkgconfig/libmissioncontrol.pc"
+FILES_libmissioncontrol-config-dev = "${libdir}/libmissioncontrol-config.*"
+FILES_libmissioncontrol-server-dev = "${libdir}/libmissioncontrol-server.*"
+
+FILES_libmissioncontrol-dbg += "${libdir}/.debug/libmissioncontrol.so.*"
+FILES_libmissioncontrol-config-dbg += "${libdir}/.debug/libmissioncontrol-config.so.*"
+FILES_libmissioncontrol-server-dbg += "${libdir}/.debug/libmissioncontrol-server.so.*"
+
+AUTOTOOLS_STAGE_PKGCONFIG = "1"
+
+do_compile_append() {
+ for i in ${S}/*.pc ; do
+ sed -i -e s:${STAGING_DIR_TARGET}::g \
+ -e s:/${TARGET_SYS}::g \
+ $i
+ done
+}
+
+do_stage() {
+ autotools_stage_all
+}
diff --git a/recipes/telepathy/telepathy-python_0.14.0.bb b/recipes/telepathy/telepathy-python_0.14.0.bb
new file mode 100644
index 0000000000..0898b321eb
--- /dev/null
+++ b/recipes/telepathy/telepathy-python_0.14.0.bb
@@ -0,0 +1,8 @@
+DESCRIPTION = "Telepathy framework - Python package"
+HOMEPAGE = "http://telepathy.freedesktop.org/wiki/"
+LICENSE = "LGPL"
+RDEPENDS_${PN} += "python-dbus"
+
+SRC_URI = "http://telepathy.freedesktop.org/releases/${PN}/${P}.tar.gz "
+
+inherit distutils
diff --git a/recipes/telepathy/telepathy-python_0.15.1.bb b/recipes/telepathy/telepathy-python_0.15.1.bb
new file mode 100644
index 0000000000..0898b321eb
--- /dev/null
+++ b/recipes/telepathy/telepathy-python_0.15.1.bb
@@ -0,0 +1,8 @@
+DESCRIPTION = "Telepathy framework - Python package"
+HOMEPAGE = "http://telepathy.freedesktop.org/wiki/"
+LICENSE = "LGPL"
+RDEPENDS_${PN} += "python-dbus"
+
+SRC_URI = "http://telepathy.freedesktop.org/releases/${PN}/${P}.tar.gz "
+
+inherit distutils
diff --git a/recipes/telepathy/telepathy-salut-0.3.4/keep-manager-file.diff b/recipes/telepathy/telepathy-salut-0.3.4/keep-manager-file.diff
new file mode 100644
index 0000000000..4c335e0c8b
--- /dev/null
+++ b/recipes/telepathy/telepathy-salut-0.3.4/keep-manager-file.diff
@@ -0,0 +1,11 @@
+--- /tmp/Makefile.am 2008-08-31 15:37:45.000000000 +0200
++++ telepathy-salut-0.3.4/data/Makefile.am 2008-08-31 15:38:09.163198000 +0200
+@@ -15,8 +15,4 @@
+
+ CLEANFILES = $(service_DATA) $(manager_DATA)
+
+-$(manager_DATA): always-build
+- $(MAKE) -C ../src write-mgr-file
+- ../src/write-mgr-file > $@
+-
+ .PHONY: always-build
diff --git a/recipes/telepathy/telepathy-salut-0.3.4/salut.manager b/recipes/telepathy/telepathy-salut-0.3.4/salut.manager
new file mode 100644
index 0000000000..8fd84d5877
--- /dev/null
+++ b/recipes/telepathy/telepathy-salut-0.3.4/salut.manager
@@ -0,0 +1,13 @@
+
+[ConnectionManager]
+Name=Salut
+BusName=org.freedesktop.Telepathy.ConnectionManager.salut
+ObjectPath=/org/freedesktop/Telepathy/ConnectionManager/salut
+
+[Protocol local-xmpp]
+param-nickname=s
+param-first-name=s required
+param-last-name=s required
+param-jid=s
+param-email=s
+param-published-name=s
diff --git a/recipes/telepathy/telepathy-salut_0.3.4.bb b/recipes/telepathy/telepathy-salut_0.3.4.bb
new file mode 100644
index 0000000000..c8b9edaee1
--- /dev/null
+++ b/recipes/telepathy/telepathy-salut_0.3.4.bb
@@ -0,0 +1,18 @@
+DESCRIPTION = "Salut: Link-local XMPP connection manager for the Telepathy framework"
+HOMEPAGE = "http://telepathy.freedesktop.org/wiki/"
+DEPENDS = "telepathy-glib avahi telepathy-gabble"
+LICENSE = "LGPL"
+
+#salut.manager changes every release, don't copy it over blindly!
+SRC_URI = "http://telepathy.freedesktop.org/releases/${PN}/${P}.tar.gz \
+ file://keep-manager-file.diff;patch=1 \
+ file://salut.manager"
+
+inherit autotools pkgconfig
+
+do_compile_prepend() {
+ cp ${WORKDIR}/salut.manager ${S}/data/
+}
+
+FILES_${PN} += "${datadir}/telepathy \
+ ${datadir}/dbus-1"