aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/thc
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/thc
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/thc')
-rw-r--r--recipes/thc/hydra_4.4.bb25
-rw-r--r--recipes/thc/hydra_4.5.bb26
-rw-r--r--recipes/thc/thcrut-1.2.5/configure_in.patch11
-rw-r--r--recipes/thc/thcrut_1.2.5.bb16
4 files changed, 78 insertions, 0 deletions
diff --git a/recipes/thc/hydra_4.4.bb b/recipes/thc/hydra_4.4.bb
new file mode 100644
index 0000000000..4794027f2b
--- /dev/null
+++ b/recipes/thc/hydra_4.4.bb
@@ -0,0 +1,25 @@
+DESCRIPTION = "A very fast network logon cracker which support many different services"
+SECTION = "console/network"
+DEPENDS = "openssl"
+LICENSE = "GPL"
+PR = "r0"
+
+SRC_URI = "http://thc.org/releases/hydra-${PV}-src.tar.gz"
+S = "${WORKDIR}/hydra-${PV}-src"
+
+inherit autotools
+
+do_configure() {
+ echo "Now that's a sucky build system..."
+ cp -f Makefile.am Makefile
+}
+
+BINARIES = "pw-inspector hydra"
+
+do_install() {
+ install -d ${D}${bindir}
+ for f in ${BINARIES}
+ do
+ install -m 0755 $f ${D}${bindir}
+ done
+}
diff --git a/recipes/thc/hydra_4.5.bb b/recipes/thc/hydra_4.5.bb
new file mode 100644
index 0000000000..fa7063687c
--- /dev/null
+++ b/recipes/thc/hydra_4.5.bb
@@ -0,0 +1,26 @@
+DESCRIPTION = "A very fast network logon cracker which support many different services"
+HOMEPAGE = "http://thc.org/thc-hydra/"
+SECTION = "console/network"
+DEPENDS = "openssl"
+LICENSE = "GPL"
+PR = "r0"
+
+SRC_URI = "http://thc.org/releases/hydra-${PV}-src.tar.gz"
+S = "${WORKDIR}/hydra-${PV}-src"
+
+inherit autotools
+
+do_configure() {
+ echo "Now that's a sucky build system..."
+ cp -f Makefile.am Makefile
+}
+
+BINARIES = "pw-inspector hydra"
+
+do_install() {
+ install -d ${D}${bindir}
+ for f in ${BINARIES}
+ do
+ install -m 0755 $f ${D}${bindir}
+ done
+}
diff --git a/recipes/thc/thcrut-1.2.5/configure_in.patch b/recipes/thc/thcrut-1.2.5/configure_in.patch
new file mode 100644
index 0000000000..d85681555c
--- /dev/null
+++ b/recipes/thc/thcrut-1.2.5/configure_in.patch
@@ -0,0 +1,11 @@
+--- configure.in 2005-02-02 11:05:04.000000000 -0500
++++ configure.in.new 2005-02-02 11:41:23.000000000 -0500
+@@ -37,7 +37,7 @@
+ trydir_l="${trydir_l} /usr/local/lib"
+ fi
+
+-trydir_i="${trydir_i} ${prefix}/include/pcap ${prefix}/include/pcre /usr/include/pcre /usr/include/pcap"
++trydir_i="${prefix}/include/pcap ${prefix}/include/pcre /usr/include/pcre /usr/include/pcap"
+ AC_ARG_WITH(includes,
+ [ --with-includes=DIR Space-seperated list of include directories],
+ [
diff --git a/recipes/thc/thcrut_1.2.5.bb b/recipes/thc/thcrut_1.2.5.bb
new file mode 100644
index 0000000000..f4e2b5bd7c
--- /dev/null
+++ b/recipes/thc/thcrut_1.2.5.bb
@@ -0,0 +1,16 @@
+DESCRIPTION = "RUT (aRe-yoU-There) RUT gathers informations from local and remote networks"
+SECTION = "console/network"
+DEPENDS = "libpcre openssl libnet libpcap"
+HOMEPAGE = "http://thc.org/thc-rut/"
+LICENSE = "GPL"
+PR = "r1"
+
+SRC_URI = "http://packetstorm.linuxsecurity.com/groups/thc/thcrut-1.2.5.tar.gz \
+ file://configure_in.patch;patch=1;pnum=0"
+
+S = "${WORKDIR}/thcrut-${PV}"
+
+inherit autotools
+
+EXTRA_OECONF = "--with-ssl=${STAGING_LIBDIR}/.."
+