aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/ti/ti-dm355mm-module_1.13.bb
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2009-08-26 11:35:14 +0200
committerKoen Kooi <koen@openembedded.org>2009-08-26 11:35:14 +0200
commit172cb63ce5e91d489993590ec09e418aba019b4e (patch)
treee10d322895620ec0c96c2ab0efcd296bfc93b6b9 /recipes/ti/ti-dm355mm-module_1.13.bb
parentbac5eef9c8a73672ee114926011addabb36610eb (diff)
downloadopenembedded-172cb63ce5e91d489993590ec09e418aba019b4e.tar.gz
dvsdk: rename to ti now that other things like bitblit live in that dir now
Diffstat (limited to 'recipes/ti/ti-dm355mm-module_1.13.bb')
-rw-r--r--recipes/ti/ti-dm355mm-module_1.13.bb57
1 files changed, 57 insertions, 0 deletions
diff --git a/recipes/ti/ti-dm355mm-module_1.13.bb b/recipes/ti/ti-dm355mm-module_1.13.bb
new file mode 100644
index 0000000000..59cbd69e10
--- /dev/null
+++ b/recipes/ti/ti-dm355mm-module_1.13.bb
@@ -0,0 +1,57 @@
+DESCRIPTION = "User space DMA module for DM355"
+
+require ti-codec-combo-dm355.inc
+inherit module
+
+# compile and run time dependencies
+DEPENDS = "virtual/kernel perl-native"
+RDEPENDS = "update-modules"
+
+SRC_URI = "http://software-dl.ti.com/dsps/dsps_public_sw/sdo_sb/targetcontent/dvsdk/codecs/dm355_codecs_setuplinux_1_13_000.bin \
+ file://dm355mm_1_30.patch;patch=1 \
+ "
+
+S = "${WORKDIR}/dm355_codecs_1_13_000"
+BINFILE = "dm355_codecs_setuplinux_1_13_000.bin"
+
+# Yes, the xdc stuff still breaks with a '.' in PWD
+PV = "113"
+#This is a kernel module, don't set PR directly
+MACHINE_KERNEL_PR_append = "a"
+
+
+do_configure() {
+ find ${S} -name "*.ko" -exec rm {} \; || true
+ sed -i -e s:include:#include:g ${S}/dm355mm/Rules.make
+}
+
+do_compile() {
+ unset CFLAGS CPPFLAGS CXXFLAGS LDFLAGS
+
+ cd ${S}/dm355mm/module
+ make \
+ LINUXKERNEL_INSTALL_DIR="${STAGING_KERNEL_DIR}" \
+ MVTOOL_PREFIX="${TARGET_PREFIX}";
+}
+
+do_install () {
+ install -d ${D}/lib/modules/${KERNEL_VERSION}/kernel/drivers/dsp
+ install -m 0755 ${S}/dm355mm/module/dm350mmap.ko ${D}/lib/modules/${KERNEL_VERSION}/kernel/drivers/dsp
+}
+
+pkg_postinst () {
+ if [ -n "$D" ]; then
+ exit 1
+ fi
+ depmod -a
+ update-modules || true
+}
+
+pkg_postrm () {
+ update-modules || true
+}
+
+INHIBIT_PACKAGE_STRIP = "1"
+FILES_${PN} = "/lib/modules/${KERNEL_VERSION}/kernel/drivers/dsp/dm350mmap.ko"
+
+