aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/ti/ti-dm355mm-module_1.13.bb
diff options
context:
space:
mode:
authorKoen Kooi <k-kooi@ti.com>2009-11-16 10:17:24 +0100
committerKoen Kooi <koen@openembedded.org>2009-12-04 19:46:02 +0100
commitb788499815bfc1974d4277c0a261b9a7c24aa816 (patch)
tree6c0546c0891d884f835355d851ec07147165ddd2 /recipes/ti/ti-dm355mm-module_1.13.bb
parent08dcecdc77ceb6a3673605216493905859f11982 (diff)
downloadopenembedded-b788499815bfc1974d4277c0a261b9a7c24aa816.tar.gz
recipes/ti: merge in updates
* New codec recipes from Arago team in Germantown * Updated dm6446 and dm355 from Brijesh Singh * cmem, gst-ti and dmai fixes from Brijesh Singh angstrom: introduce SOC_FAMILY and start using it TI recipes as a testing ground * SOC_FAMILY tells you which system on chip is used in the MACHINE, e.g. omap3, dm355, pxa25x, s3c24xx. This avoids having to duplicate lots of overrides in machine specific recipes. This is *NOT* intended to be used as a package arch.
Diffstat (limited to 'recipes/ti/ti-dm355mm-module_1.13.bb')
-rw-r--r--recipes/ti/ti-dm355mm-module_1.13.bb33
1 files changed, 6 insertions, 27 deletions
diff --git a/recipes/ti/ti-dm355mm-module_1.13.bb b/recipes/ti/ti-dm355mm-module_1.13.bb
index 59cbd69e10..6941d0c741 100644
--- a/recipes/ti/ti-dm355mm-module_1.13.bb
+++ b/recipes/ti/ti-dm355mm-module_1.13.bb
@@ -1,25 +1,19 @@
DESCRIPTION = "User space DMA module for DM355"
-require ti-codec-combo-dm355.inc
+require ti-codecs-dm355.inc
inherit module
-# compile and run time dependencies
-DEPENDS = "virtual/kernel perl-native"
-RDEPENDS = "update-modules"
+PV = "1_13_000"
-SRC_URI = "http://software-dl.ti.com/dsps/dsps_public_sw/sdo_sb/targetcontent/dvsdk/codecs/dm355_codecs_setuplinux_1_13_000.bin \
- file://dm355mm_1_30.patch;patch=1 \
+SRC_URI = "http://software-dl.ti.com/dsps/dsps_public_sw/sdo_sb/targetcontent/dvsdk/codecs/dm355_codecs_setuplinux_${PV}.bin \
+ file://dm355mm.patch;patch=1 \
"
+S = "${WORKDIR}/dm355_codecs_${PV}"
+BINFILE="dm355_codecs_setuplinux_${PV}.bin"
-S = "${WORKDIR}/dm355_codecs_1_13_000"
-BINFILE = "dm355_codecs_setuplinux_1_13_000.bin"
-
-# Yes, the xdc stuff still breaks with a '.' in PWD
-PV = "113"
#This is a kernel module, don't set PR directly
MACHINE_KERNEL_PR_append = "a"
-
do_configure() {
find ${S} -name "*.ko" -exec rm {} \; || true
sed -i -e s:include:#include:g ${S}/dm355mm/Rules.make
@@ -39,19 +33,4 @@ do_install () {
install -m 0755 ${S}/dm355mm/module/dm350mmap.ko ${D}/lib/modules/${KERNEL_VERSION}/kernel/drivers/dsp
}
-pkg_postinst () {
- if [ -n "$D" ]; then
- exit 1
- fi
- depmod -a
- update-modules || true
-}
-
-pkg_postrm () {
- update-modules || true
-}
-
INHIBIT_PACKAGE_STRIP = "1"
-FILES_${PN} = "/lib/modules/${KERNEL_VERSION}/kernel/drivers/dsp/dm350mmap.ko"
-
-