aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/ti
diff options
context:
space:
mode:
authorKoen Kooi <k-kooi@ti.com>2010-02-01 16:12:14 +0100
committerKoen Kooi <koen@openembedded.org>2010-04-12 19:43:16 +0200
commit0936f5d12cdbc9ce76c01ff843ab002172af9bbe (patch)
tree05d929135f0a5c3b8a63ef1b65b9db5a39c5fa89 /recipes/ti
parent88f198bb5ff7cfe1e87f822071d89aa966519a20 (diff)
downloadopenembedded-0936f5d12cdbc9ce76c01ff843ab002172af9bbe.tar.gz
ti-dmai: convert to new style staging ti-linux-utils: ditto
Signed-off-by: Koen Kooi <k-kooi@ti.com>
Diffstat (limited to 'recipes/ti')
-rw-r--r--recipes/ti/ti-dmai_svn.bb19
-rw-r--r--recipes/ti/ti-linuxutils.inc14
2 files changed, 17 insertions, 16 deletions
diff --git a/recipes/ti/ti-dmai_svn.bb b/recipes/ti/ti-dmai_svn.bb
index a04f4ddd1e..897eac36b7 100644
--- a/recipes/ti/ti-dmai_svn.bb
+++ b/recipes/ti/ti-dmai_svn.bb
@@ -1,10 +1,11 @@
DESCRIPTION = "DMAI for TI ARM/DSP processors"
require ti-paths.inc
+require ti-staging.inc
inherit module-base
#This is a kernel module, don't set PR directly
-MACHINE_KERNEL_PR_append = "d"
+MACHINE_KERNEL_PR_append = "e"
# Yes, the xdc stuff still breaks with a '.' in PWD
PE = "1"
@@ -106,28 +107,26 @@ do_compile () {
}
do_install () {
- unset DMAI_INSTALL_DIR
- # install dmai apps on target
+ unset DMAI_INSTALL_DIR
+ # install dmai apps on target
install -d ${D}/${installdir}/dmai-apps
cd ${S}/dmai
make PLATFORM="${TARGET}" EXEC_DIR=${D}/${installdir}/dmai-apps install
- install -m 0755 ${WORKDIR}/loadmodules-ti-dmai-${TARGET}.sh ${D}/${installdir}/dmai-apps/loadmodule.sh
+ install -m 0755 ${WORKDIR}/loadmodules-ti-dmai-${TARGET}.sh ${D}/${installdir}/dmai-apps/loadmodule.sh
install -d ${D}/${installdir}/dmai-tests
cd ${S}/tests
make PLATFORM="${TARGET}" EXEC_DIR=${D}/${installdir}/dmai-tests install
- install -m 0755 ${WORKDIR}/loadmodules-ti-dmai-${TARGET}.sh ${D}/${installdir}/dmai-tests/loadmodule.sh
+ install -m 0755 ${WORKDIR}/loadmodules-ti-dmai-${TARGET}.sh ${D}/${installdir}/dmai-tests/loadmodule.sh
+
+ install -d ${D}${DMAI_INSTALL_DIR_RECIPE}
+ cp -pPrf ${S}/dmai/* ${D}${DMAI_INSTALL_DIR_RECIPE}
}
pkg_postinst_ti-dmai-apps () {
ln -sf ${installdir}/codec-combo/* ${installdir}/dmai-apps/
}
-do_stage () {
- install -d ${DMAI_INSTALL_DIR}
- cp -pPrf ${S}/dmai/* ${DMAI_INSTALL_DIR}
-}
-
# Disable QA check untils we figure out how to pass LDFLAGS in build
INSANE_SKIP_${PN} = True
INSANE_SKIP_ti-dmai-apps = True
diff --git a/recipes/ti/ti-linuxutils.inc b/recipes/ti/ti-linuxutils.inc
index d96477d741..ae48f8e740 100644
--- a/recipes/ti/ti-linuxutils.inc
+++ b/recipes/ti/ti-linuxutils.inc
@@ -6,9 +6,10 @@ SRC_URI = "${BASE_SRC_URI}/linuxutils_${PV}.tar.gz "
S = "${WORKDIR}/linuxutils_${PV}"
require ti-multimedia-common.inc
+require ti-staging.inc
#This is a kernel module, don't set PR directly
-MACHINE_KERNEL_PR_append = "a"
+MACHINE_KERNEL_PR_append = "b"
inherit module
@@ -57,14 +58,15 @@ do_install () {
EXEC_DIR="${D}${installdir}/ti-linuxutils-app/edma-app" \
install
fi
-}
-# stage tree - other packages may need this
-do_stage() {
- install -d ${LINUXUTILS_INSTALL_DIR}
- cp -pPrf ${S}/* ${LINUXUTILS_INSTALL_DIR}
+ # stage tree - other packages may need this
+ install -d ${D}${LINUXUTILS_INSTALL_DIR_RECIPE}
+ cp -pPrf ${S}/* ${D}${LINUXUTILS_INSTALL_DIR_RECIPE}
}
+
+
+
PACKAGES =+ " ti-cmem-module \
ti-sdma-module \
ti-edma-module \