aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/ti
diff options
context:
space:
mode:
authorRoger Monk <r-monk@ti.com>2010-03-01 11:27:58 +0000
committerKoen Kooi <koen@openembedded.org>2010-04-12 19:43:20 +0200
commit3c0cffcb2c8eae9defb49e4f4acc40b97116df78 (patch)
treed96c853c2219207dd821981b4fc21fec778cc5fb /recipes/ti
parent720aca750c67d359124feea30d8e3b50b343c42d (diff)
downloadopenembedded-3c0cffcb2c8eae9defb49e4f4acc40b97116df78.tar.gz
gstreamer_ti: Patch dm6467 config to remove multiple cs servers
* dm6467 uses single cs server in latest codecs drop * patch ticodecplugin to match Signed-off-by: Roger Monk <r-monk@ti.com> Signed-off-by: Koen Kooi <k-kooi@ti.com>
Diffstat (limited to 'recipes/ti')
-rw-r--r--recipes/ti/gstreamer-ti/gstreamer-ti-dm6467-usesinglecsserver.patch36
-rw-r--r--recipes/ti/gstreamer-ti_svn.bb7
2 files changed, 43 insertions, 0 deletions
diff --git a/recipes/ti/gstreamer-ti/gstreamer-ti-dm6467-usesinglecsserver.patch b/recipes/ti/gstreamer-ti/gstreamer-ti-dm6467-usesinglecsserver.patch
new file mode 100644
index 0000000000..3fb34cf744
--- /dev/null
+++ b/recipes/ti/gstreamer-ti/gstreamer-ti-dm6467-usesinglecsserver.patch
@@ -0,0 +1,36 @@
+diff -uNr ticodecplugin/src/gstticodecplugin_dm6467.cfg ticodecplugin/src/gstticodecplugin_dm6467.cfg
+--- ticodecplugin/src/gstticodecplugin_dm6467.cfg 2010-03-01 10:31:05.000000000 +0000
++++ ticodecplugin/src/gstticodecplugin_dm6467.cfg 2010-03-01 11:12:14.000000000 +0000
+@@ -29,25 +29,15 @@
+ * ======== Engine Configuration ========
+ */
+ var Engine = xdc.useModule('ti.sdo.ce.Engine');
+-var decodeEngine = Engine.createFromServer(
+- "decode",
+- "./decodeCombo.x64P",
+- "ti.sdo.servers.decode"
++var demoEngine = Engine.createFromServer(
++ "codecServer",
++ "./bin/cs.x64P",
++ "ti.sdo.server.cs"
+ );
+-var encodeEngine = Engine.createFromServer(
+- "encode",
+- "./encodeCombo.x64P",
+- "ti.sdo.servers.encode"
+- );
+-
+-var encpath = "" + java.lang.System.getenv("ENCODE_COMBO");
+-if (encpath != "" && encpath != "null") {
+- encodeEngine.server = java.lang.System.getenv("ENCODE_COMBO");
+-}
+
+-var decpath = "" + java.lang.System.getenv("DECODE_COMBO");
+-if (decpath != "" && decpath != "null") {
+- decodeEngine.server = java.lang.System.getenv("DECODE_COMBO");
++var combopath = "" + java.lang.System.getenv("CODEC_SERVER");
++if (combopath != "" && combopath != "null") {
++ demoEngine.server = java.lang.System.getenv("CODEC_SERVER");
+ }
+
+ /* Load support for the 'Davinci Multimedia Application Interface' modules */
diff --git a/recipes/ti/gstreamer-ti_svn.bb b/recipes/ti/gstreamer-ti_svn.bb
index 1ac37166c7..cdf1f06577 100644
--- a/recipes/ti/gstreamer-ti_svn.bb
+++ b/recipes/ti/gstreamer-ti_svn.bb
@@ -6,6 +6,7 @@ SECTION = "multimedia"
# TODO :: Codec Server Environment Variables shouldn't be required
# TODO :: Add (and check) rc scripts for all targets (just copied for now) (365,6467,omapl137)
# TODO :: Check if CPPFLAGS_append is still required
+# TODO :: Remove ENCODE/DECODE combo exports - these are not used anymore (check?)
inherit autotools
inherit update-rc.d
@@ -48,6 +49,10 @@ SRC_URI_append_omapl138 = " \
file://gstreamer-ti-omapl138.patch;patch=1 \
"
+SRC_URI_append_dm6467 = " \
+ file://gstreamer-ti-dm6467-usesinglecsserver.patch;patch=1 \
+"
+
DEPENDS = "ti-dmai gstreamer gst-plugins-base gst-plugins-good gst-plugins-ugly"
# gstreamer_ti picks up some config variables from the environment
@@ -90,6 +95,8 @@ export LINUXKERNEL_INSTALL_DIR = ${STAGING_KERNEL_DIR}
export HMJCP_COMBO = "${installdir}/ti-codecs-server/hmjcp.accel"
export CODEC_SERVER = "${installdir}/ti-codecs-server/cs.x64P"
+
+# TODO :: These 2 can be removed now since dm6467 uses single CS server (like omap/omapl)
export ENCODE_COMBO = "${installdir}/ti-codecs-server/encodeCombo.x64P"
export DECODE_COMBO = "${installdir}/ti-codecs-server/decodeCombo.x64P"