aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/ti
diff options
context:
space:
mode:
authorRoger Monk <r-monk@ti.com>2010-03-20 10:52:18 +0000
committerKoen Kooi <koen@openembedded.org>2010-04-12 19:43:27 +0200
commitd851b22811173569fc145bf8f9eb4c2ab95d7a0e (patch)
tree897e1e9fe6dd7a383e971dd91eb681ebec3a51c4 /recipes/ti
parent91f4c88f233c26f434d182e0c00c22709a8496fb (diff)
downloadopenembedded-d851b22811173569fc145bf8f9eb4c2ab95d7a0e.tar.gz
gstd/freondemo: Align with arago file locations
* Move gstd and freondemo recipes to recipes/gstd /freondemo * Prepare for recipe sync * Later needs renaming and finding new (more appropriate) home Signed-off-by: Roger Monk <r-monk@ti.com> Signed-off-by: Koen Kooi <k-kooi@ti.com>
Diffstat (limited to 'recipes/ti')
-rw-r--r--recipes/ti/freondemo/freondemo20
-rw-r--r--recipes/ti/freondemo/freondemo.init58
-rw-r--r--recipes/ti/freondemo_git.bb36
-rwxr-xr-xrecipes/ti/gst-ipcsink_git.bb25
-rw-r--r--recipes/ti/gstd_git.bb31
5 files changed, 0 insertions, 170 deletions
diff --git a/recipes/ti/freondemo/freondemo b/recipes/ti/freondemo/freondemo
deleted file mode 100644
index 80dd36e132..0000000000
--- a/recipes/ti/freondemo/freondemo
+++ /dev/null
@@ -1,20 +0,0 @@
-#!/bin/sh
-
-# We start a system wide gstd daemon
-gstd &
-
-amixer -q sset 'HP DAC' 127
-
-#If we detect a mouse, use it, otherwise configure the touchcreen
-if [ ! -c /dev/input/mice ] && [ ! -c /dev/input/mouse0 ] ; then
- if [ -c /dev/input/touchscreen0 ] ; then
- export TSLIB_TSDEVICE=/dev/input/touchscreen0
- if [ ! -f /etc/pointercal ] ; then
- # We need to calibrate the screen
- ts_calibrate
- fi
- export QWS_MOUSE_PROTO=tslib
- fi
-fi
-
-/usr/libexec/FreonDemo -qws &
diff --git a/recipes/ti/freondemo/freondemo.init b/recipes/ti/freondemo/freondemo.init
deleted file mode 100644
index 5cb5281245..0000000000
--- a/recipes/ti/freondemo/freondemo.init
+++ /dev/null
@@ -1,58 +0,0 @@
-#! /bin/sh
-
-set -e
-
-DAEMON=/usr/bin/freondemo
-NAME=freondemo
-PIDFILE=/var/run/freondemo/pid
-DESC="Freon Demo"
-PARAMS=""
-
-test -x $DAEMON || exit 0
-
-start_it_up()
-{
- if [ -e $PIDFILE ]; then
- PIDDIR=/proc/$(cat $PIDFILE)
- if [ -d ${PIDDIR} -a "$(readlink -f ${PIDDIR}/exe)" = "${DAEMON}" ]; then
- echo "$DESC already started; not starting."
- else
- echo "Removing stale PID file $PIDFILE."
- rm -f $PIDFILE
- fi
- fi
-
- source $SESSIONFILE
- echo -n "Starting $DESC: "
- start-stop-daemon --start --pidfile $PIDFILE \
- --exec $DAEMON -- $PARAMS
- echo "$NAME."
-}
-
-shut_it_down()
-{
- echo -n "Stopping $DESC: "
- start-stop-daemon --stop --oknodo --pidfile $PIDFILE
- echo "$NAME."
- rm -f $PIDFILE
-}
-
-case "$1" in
- start)
- start_it_up
- ;;
- stop)
- shut_it_down
- ;;
- restart)
- shut_it_down
- sleep 1
- start_it_up
- ;;
- *)
- echo "Usage: /etc/init.d/$NAME {start|stop|restart}" >&2
- exit 1
- ;;
-esac
-
-exit 0
diff --git a/recipes/ti/freondemo_git.bb b/recipes/ti/freondemo_git.bb
deleted file mode 100644
index ae943a7149..0000000000
--- a/recipes/ti/freondemo_git.bb
+++ /dev/null
@@ -1,36 +0,0 @@
-DESCRIPTION = "FreonDemo: a QT based demo for OMAP L138 EVM board"
-HOMEPAGE = "http://sourceforge.net/projects/freondemo"
-MAINTAINER = "http://sourceforge.net/projects/freondemo"
-LICENSE = "BSD"
-SECTION = "multimedia"
-PRIORITY = "optional"
-
-DEPENDS = "dbus gstd"
-RDEPENDS_${PN} = "gstd alsa-utils-amixer gst-ipcsink"
-RRECOMMENDS_${PN} = "qt4-embedded-plugin-mousedriver-tslib gstreamer-ti"
-
-SRCREV = "19c4e201aa978d2b40793b9fa76cc4ddbff50016"
-
-PV = "1.0"
-PR = "r7"
-PR_append = "+gitr${SRCREV}"
-
-SRC_URI = "git://freondemo.git.sourceforge.net/gitroot/freondemo/freondemo;protocol=git \
- file://freondemo \
- file://freondemo.init \
- "
-S = "${WORKDIR}/git"
-
-inherit qt4e update-rc.d
-
-do_install() {
- install -d ${D}/${libexecdir}
- install -d ${D}/${bindir}
- install -m 0755 ${S}/FreonDemo ${D}/${libexecdir}
- install -m 0755 ${WORKDIR}/freondemo ${D}/${bindir}
- install -d ${D}${sysconfdir}/init.d
- install -m 0755 ${WORKDIR}/freondemo.init ${D}${sysconfdir}/init.d/freondemo
-}
-
-INITSCRIPT_NAME = "freondemo"
-INITSCRIPT_PARAMS = "defaults 99"
diff --git a/recipes/ti/gst-ipcsink_git.bb b/recipes/ti/gst-ipcsink_git.bb
deleted file mode 100755
index e8a184ccd6..0000000000
--- a/recipes/ti/gst-ipcsink_git.bb
+++ /dev/null
@@ -1,25 +0,0 @@
-DESCRIPTION = "gst-ipcsink: custom gstreamer element for IPC video sink"
-HOMEPAGE = "http://sourceforge.net/projects/freondemo"
-MAINTAINER = "http://sourceforge.net/projects/freondemo"
-LICENSE = "BSD"
-SECTION = "multimedia"
-PRIORITY = "optional"
-
-DEPENDS = "gstreamer gst-plugins-base"
-
-SRCREV=7e38d82d1207bb75f235f5643c4c2d15591e9b3c
-
-PV = "1.0"
-PR = "r0"
-PR_append= "+gitr${SRCREV}"
-
-inherit autotools
-
-SRC_URI = "git://freondemo.git.sourceforge.net/gitroot/freondemo/gst-ipcsink;protocol=git"
-S = "${WORKDIR}/git"
-
-FILES_${PN} += "${libdir}/gstreamer-0.10/*.so ${sysconfdir}"
-FILES_${PN}-dev += "${libdir}/gstreamer-0.10/*.a ${libdir}/gstreamer-0.10/*.la"
-FILES_${PN}-dbg += "${libdir}/gstreamer-0.10/.debug"
-
-
diff --git a/recipes/ti/gstd_git.bb b/recipes/ti/gstd_git.bb
deleted file mode 100644
index 143b4b60d5..0000000000
--- a/recipes/ti/gstd_git.bb
+++ /dev/null
@@ -1,31 +0,0 @@
-DESCRIPTION = "Gstd: a Gstreamer-based streaming server"
-HOMEPAGE = "http://sourceforge.net/projects/harrier/"
-MAINTAINER = "harrier-devel@lists.sourceforge.net"
-LICENSE = "BSD"
-SECTION = "multimedia"
-PRIORITY = "optional"
-
-DEPENDS = "dbus dbus-glib gstreamer"
-RDEPENDS = "gst-plugins-base"
-
-SRCREV = "7ba92f30db6f72531554a7b0335e757182c60020"
-
-PV = "1.0"
-PR = "r7"
-PR_append = "+gitr${SRCREV}"
-
-SRC_URI = "git://gstd.git.sourceforge.net/gitroot/gstd/gstd;protocol=git \
- "
-
-S = "${WORKDIR}/git"
-
-inherit autotools pkgconfig
-
-# We don't want to run autoconf or automake, unless you have
-# automake > 1.11 with vala support
-do_configure() {
- oe_runconf
-}
-
-FILES_${PN} += "${datadir}/dbus-1/*/*.service"
-FILES_${PN}-dev += "${datadir}/dbus-1/interfaces/*.xml"