aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/ti
diff options
context:
space:
mode:
authorRoger Monk <r-monk@ti.com>2010-01-16 10:49:54 +0000
committerKoen Kooi <koen@openembedded.org>2010-04-12 19:43:11 +0200
commitdc72be68dda9e67c81ab65d8f1cd1bda25e1bf76 (patch)
tree9aa7471c3112ab5ad998b7d2c5ee51966f1f56a8 /recipes/ti
parentb828469f5906a0f35896c521880db9cc3812fa26 (diff)
downloadopenembedded-dc72be68dda9e67c81ab65d8f1cd1bda25e1bf76.tar.gz
ti-codec-engine: Move version specific code into versioned part + add devices
Signed-off-by: Koen Kooi <k-kooi@ti.com>
Diffstat (limited to 'recipes/ti')
-rw-r--r--recipes/ti/ti-codec-engine.inc30
-rw-r--r--recipes/ti/ti-codec-engine_2.25.00.05.bb30
-rw-r--r--recipes/ti/ti-paths.inc16
3 files changed, 38 insertions, 38 deletions
diff --git a/recipes/ti/ti-codec-engine.inc b/recipes/ti/ti-codec-engine.inc
index 6f415c51c8..c2a6e8e004 100644
--- a/recipes/ti/ti-codec-engine.inc
+++ b/recipes/ti/ti-codec-engine.inc
@@ -15,15 +15,20 @@ SRC_URI = "http://software-dl.ti.com/dsps/dsps_public_sw/sdo_sb/targetcontent/ce
S = "${WORKDIR}/codec_engine_${PV}"
# Define Device variable
-DEVICES_dm6446 ?= "DM6446"
-DEVICES_omap3 ?= "OMAP3530"
-DEVICES_dm355 ?= "DM355"
+DEVICES = ""
+DEVICES_dm6446 ?= "DM6446"
+DEVICES_dm6467 ?= "DM6467"
+DEVICES_omap3 ?= "OMAP3530"
+DEVICES_dm355 ?= "DM355"
+DEVICES_dm365 ?= "DM365"
DEVICES_omapl137 ?= "OMAPL137"
DEVICES_omapl138 ?= "OMAPL138"
#define PROGRAM variables
-PROGRAMS ?= "APP_CLIENT DSP_SERVER"
-PROGRAMS_dm355 = "APP_LOCAL"
+#TODO - should we build APP_LOCAL for SOCs as well?? - probably?
+PROGRAMS ?= "APP_CLIENT DSP_SERVER"
+PROGRAMS_dm355 = "APP_LOCAL"
+PROGRAMS_dm365 = "APP_LOCAL"
CGT6x_DIR = "${CODEGEN_INSTALL_DIR}"
XDCTOOLS_DIR = "${XDC_INSTALL_DIR}"
@@ -36,15 +41,6 @@ do_compile () {
-e s:arm-none-linux-gnueabi-:${TARGET_PREFIX}:g \
${S}/examples/xdcpaths.mak
- #only for ce 2.25.00.05
- sed -i \
- -e 's/# figure out what categories of devices we are to build for/ \
-# figure out what categories of devices we are to build for \
-ifneq (,$(findstring OMAPL138,$(DEVICES))) \
- DEVICES_DUALCPU := 1 \
-endif/g' \
- ${S}/examples/xdcpaths.mak
-
for i in codecs extensions servers apps ; do
cd ${S}/examples/ti/sdo/ce/examples/$i
make DEVICES="${DEVICES}" \
@@ -72,12 +68,6 @@ do_install() {
install -d ${D}/${installdir}/codec-engine-apps
cp ${S}/examples/apps/system_files/${DEVICES}/loadmodules.sh ${D}/${installdir}/codec-engine-apps
- # Only for 2.25.00.05
- sed -i \
- -e 's/insmod/modprobe/g' \
- -e 's/.ko//g' \
- ${D}/${installdir}/codec-engine-apps/loadmodules.sh
-
cd ${S}/examples/ti/sdo/ce/examples
# Install the apps, servers and test data, mirroring the source directory structure
diff --git a/recipes/ti/ti-codec-engine_2.25.00.05.bb b/recipes/ti/ti-codec-engine_2.25.00.05.bb
index 6e67fd5b75..e903df359c 100644
--- a/recipes/ti/ti-codec-engine_2.25.00.05.bb
+++ b/recipes/ti/ti-codec-engine_2.25.00.05.bb
@@ -1,10 +1,5 @@
require ti-codec-engine.inc
-DEFAULT_PREFERENCE = "-1"
-DEFAULT_PREFERENCE_omapl138 = "1"
-
-
-# tconf from xdctools dislikes '.' in pwd :/
PV = "2_25_00_05"
# Full-CE
@@ -15,6 +10,31 @@ PV = "2_25_00_05"
SRC_URI[cetarball.md5sum] = "618f027c4a471a0658ed999621ac190b"
SRC_URI[cetarball.sha256sum] = "81acdf9236f3062c26356db502837ae13addb35f03c02a847f9b0face9657b51"
+do_compile_prepend() {
+
+ # Add OMAPL138 target build configuration
+ sed -i \
+ -e 's/# figure out what categories of devices we are to build for/ \
+# figure out what categories of devices we are to build for \
+ifneq (,$(findstring OMAPL138,$(DEVICES))) \
+ DEVICES_DUALCPU := 1 \
+endif/g' \
+ ${S}/examples/xdcpaths.mak
+
+}
+
do_install_prepend() {
+
+ # Re-use OMAPL137 system files for OMAPL138
ln -sf ${S}/examples/apps/system_files/OMAPL137 ${S}/examples/apps/system_files/OMAPL138 || true
}
+
+do_install_append() {
+
+ # Fix-up loadmodules to use modprobe instead of insmod
+ sed -i \
+ -e 's/insmod/modprobe/g' \
+ -e 's/.ko//g' \
+ ${D}/${installdir}/codec-engine-apps/loadmodules.sh
+}
+
diff --git a/recipes/ti/ti-paths.inc b/recipes/ti/ti-paths.inc
index e330c73d48..a6413fcc0f 100644
--- a/recipes/ti/ti-paths.inc
+++ b/recipes/ti/ti-paths.inc
@@ -1,13 +1,3 @@
-# To build the DSP applications you need to have DSP/BIOS, xdctools and codegen installed. Get these from:
-# https://www-a.ti.com/downloads/sds_support/targetcontent/bios/bios_5_33/sabios-j05/bios_setuplinux_5_33_02.bin
-# https://www-a.ti.com/downloads/sds_support/targetcontent/rtsc/xdctools_3_10_03/exports/xdctools_setuplinux_3_10_03.bin
-# https://www-a.ti.com/downloads/sds_support/targetcontent/LinuxDspTools/download.html
-# Back link for above:
-# https://www-a.ti.com/downloads/sds_support/targetcontent/index.html
-
-# export some more variable to point to external TI tools
-# information is duplicated between the js and make based tools
-
require ti-multimedia-common.inc
export PLATFORM
@@ -15,9 +5,9 @@ export PLATFORM
export CROSS_COMPILE = "${TOOLCHAIN_PATH}/bin/${TARGET_PREFIX}"
# This tells codec engine which targets to build
-DEVICES ?= "DM6446"
-DEVICES_omap3 = "OMAP3530"
-DEVICES_dm6446 = "DM6446"
+#DEVICES ?= "DM6446"
+#DEVICES_omap3 = "OMAP3530"
+#DEVICES_dm6446 = "DM6446"
DSPLINKPLATFORM ?= "DAVINCI"
DSPLINKPLATFORM_dm6446 = "DAVINCI"