aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/tickypip
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/tickypip
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/tickypip')
-rw-r--r--recipes/tickypip/tickypip-levels_1.1.bb35
-rw-r--r--recipes/tickypip/tickypip/path_fix.patch11
-rw-r--r--recipes/tickypip/tickypip/tickypip.desktop10
-rw-r--r--recipes/tickypip/tickypip/tickypip.pngbin0 -> 1093 bytes
-rw-r--r--recipes/tickypip/tickypip_0.1.2.bb33
5 files changed, 89 insertions, 0 deletions
diff --git a/recipes/tickypip/tickypip-levels_1.1.bb b/recipes/tickypip/tickypip-levels_1.1.bb
new file mode 100644
index 0000000000..91938cf2e6
--- /dev/null
+++ b/recipes/tickypip/tickypip-levels_1.1.bb
@@ -0,0 +1,35 @@
+DESCRIPTION = "Tickypip levels from NetWalk Group"
+SECTION = "opie/games"
+PRIORITY = "optional"
+LICENSE = "${PN}"
+SRC_DISTRIBUTE_LICENSES += "${PN}"
+AUTHOR = "NetWalk Group <netwalkgroup@hotmail.com>"
+RDEPENDS = "tickypip"
+PACKAGE_ARCH = "all"
+PR = "r1"
+
+SRC_URI = "http://www.openzaurus.org/download/3.5.4/sources/tickypip-levels_${PV}.tar.bz2"
+
+S = "${WORKDIR}/"
+
+#
+# Authors response to LICENSE question:
+#
+# You may distribute them for free provide that you have links to our level
+# packs in PalmGear.
+#
+# Packs available on PalmGear: Pak1, Pak3, Pak8, Pak9, Pak10
+#
+# URL: http://palmgear.com/index.cfm?fuseaction=software.developer&userID=862314499
+#
+# I also got permission to distribute rest of levelpacks which was available
+# from Palm Gaming World:
+# http://www.palmgamingworld.com/add-in/netwalk.shtml
+#
+
+do_install () {
+ install -d ${D}${palmtopdir}/share/tickypip/levels
+ install -m 0644 levels/* ${D}${palmtopdir}/share/tickypip/levels/
+}
+
+FILES_${PN} = "${palmtopdir}/"
diff --git a/recipes/tickypip/tickypip/path_fix.patch b/recipes/tickypip/tickypip/path_fix.patch
new file mode 100644
index 0000000000..c6e0b32f43
--- /dev/null
+++ b/recipes/tickypip/tickypip/path_fix.patch
@@ -0,0 +1,11 @@
+--- tickypip/src/base.h 2008-11-18 21:49:58.000000000 +0000
++++ tickypip/src/base.h 2008-11-18 21:54:00.000000000 +0000
+@@ -7,7 +7,7 @@
+ #ifdef LOCAL_COMPILE
+ # define DATA_PREFIX "./"
+ #else
+-# define DATA_PREFIX "/opt/QtPalmtop/share/tickypip/"
++# define DATA_PREFIX DATA_BASEDIR "/share/tickypip/"
+ #endif
+
+ #include "BorderLayout.h"
diff --git a/recipes/tickypip/tickypip/tickypip.desktop b/recipes/tickypip/tickypip/tickypip.desktop
new file mode 100644
index 0000000000..40ec2c2e0f
--- /dev/null
+++ b/recipes/tickypip/tickypip/tickypip.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Name=Tickypip
+Name[de]=Tickypip
+Icon=tickypip/tickypip
+Exec=tickypip
+Comment=Connect the computers together to form an active network.
+Comment[de]=Verbinde die Computer zu einem Netzwerk.
+Type=Application
+Type[de]=Anwendung
+CanFastLoad=0
diff --git a/recipes/tickypip/tickypip/tickypip.png b/recipes/tickypip/tickypip/tickypip.png
new file mode 100644
index 0000000000..8b64a9ee0e
--- /dev/null
+++ b/recipes/tickypip/tickypip/tickypip.png
Binary files differ
diff --git a/recipes/tickypip/tickypip_0.1.2.bb b/recipes/tickypip/tickypip_0.1.2.bb
new file mode 100644
index 0000000000..558828e919
--- /dev/null
+++ b/recipes/tickypip/tickypip_0.1.2.bb
@@ -0,0 +1,33 @@
+DESCRIPTION = "Tickypip"
+SECTION = "opie/games"
+PRIORITY = "optional"
+LICENSE = "GPL"
+AUTHOR = "Christian Hammond"
+HOMEPAGE = "http://www.chipx86.com/projects/tickypip/"
+RRECOMMENDS = "tickypip-levels"
+PR = "r5"
+
+SRC_URI = "http://www.openzaurus.org/download/3.5.4/sources/tickypip-0.1.2.tar.gz \
+ file://path_fix.patch;patch=1 \
+ file://tickypip.desktop \
+ file://tickypip.png"
+
+APPNAME = "tickypip"
+APPTYPE = "binary"
+APPDESKTOP = "${WORKDIR}"
+
+QMAKE_PROFILES = "tickypip.pro"
+EXTRA_QMAKEVARS_POST += "DEFINES-=LOCAL_COMPILE DEFINES+=DATA_BASEDIR='\"${palmtopdir}\"'"
+
+do_install () {
+ install -d ${D}${palmtopdir}/pics/${APPNAME}/
+ install -m 0644 ${WORKDIR}/*.png ${D}${palmtopdir}/pics/${APPNAME}/
+ install -m 0644 ${S}/images/*.png ${D}${palmtopdir}/pics/${APPNAME}/
+
+# copy share
+ install -d ${D}${palmtopdir}/share/${APPNAME}/levels
+ install -m 0644 ${S}/levels/* ${D}${palmtopdir}/share/${APPNAME}/levels/
+}
+
+
+inherit opie