aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/tiobench
diff options
context:
space:
mode:
authorTom Rini <tom_rini@mentor.com>2011-06-15 11:25:28 -0700
committerTom Rini <tom_rini@mentor.com>2011-06-15 11:31:34 -0700
commit821f47e170dddabaef3925fd62c5423210dcb363 (patch)
treeeb69512998dddc43b21cebcc907eb3161ae0a8d9 /recipes/tiobench
parent6c2736280a94cbdd5c4ffe683073e790a290a567 (diff)
downloadopenembedded-821f47e170dddabaef3925fd62c5423210dcb363.tar.gz
tiobench: Rework tiobench-makefile patch, update install rule
We need to pass in PREFIX=${D}/usr in order to have apps installed where expected (/usr/bin) and we need to move the docs over into /usr/share/docs as that's where they belong. Signed-off-by: Tom Rini <tom_rini@mentor.com>
Diffstat (limited to 'recipes/tiobench')
-rw-r--r--recipes/tiobench/tiobench-0.3.3/tiobench-makefile.patch2
-rw-r--r--recipes/tiobench/tiobench_0.3.3.bb4
2 files changed, 3 insertions, 3 deletions
diff --git a/recipes/tiobench/tiobench-0.3.3/tiobench-makefile.patch b/recipes/tiobench/tiobench-0.3.3/tiobench-makefile.patch
index f924c1bd66..66f5a7d9e9 100644
--- a/recipes/tiobench/tiobench-0.3.3/tiobench-makefile.patch
+++ b/recipes/tiobench/tiobench-0.3.3/tiobench-makefile.patch
@@ -32,7 +32,7 @@ Index: Makefile
+PREFIX?=/usr/local
BINDIR=$(PREFIX)/bin
-DOCDIR=/usr/local/doc/$(DISTNAME)
-+DOCDIR=$(PREFIX)/doc/$(DISTNAME)
++DOCDIR=$(PREFIX)/share/doc/$(DISTNAME)
all: $(EXE)
diff --git a/recipes/tiobench/tiobench_0.3.3.bb b/recipes/tiobench/tiobench_0.3.3.bb
index 55894e3875..7e0d1b5b35 100644
--- a/recipes/tiobench/tiobench_0.3.3.bb
+++ b/recipes/tiobench/tiobench_0.3.3.bb
@@ -8,7 +8,7 @@ RDEPENDS = "\
perl-module-overload \
perl-module-strict \
"
-PR = "r0"
+PR = "r1"
SRC_URI = "\
http://sourceforge.net/projects/tiobench/files/tiobench/${PV}/${P}.tar.gz \
@@ -17,7 +17,7 @@ SRC_URI = "\
SRC_URI[md5sum] = "bf485bf820e693c79e6bd2a38702a128"
SRC_URI[sha256sum] = "8ad011059a35ac70cdb5e3d3999ceee44a8e8e9078926844b0685b7ea9db2bcc"
-EXTRA_OEMAKE = "PREFIX=${D}"
+EXTRA_OEMAKE = "PREFIX=${D}/usr"
do_install() {
oe_runmake install