aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/tmdns
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/tmdns
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/tmdns')
-rw-r--r--recipes/tmdns/tmdns-20030116/busybox-init.d.patch61
-rw-r--r--recipes/tmdns/tmdns-20030116/char-signed-idiocy.patch16
-rw-r--r--recipes/tmdns/tmdns-20030116/install-init.d.patch28
-rw-r--r--recipes/tmdns/tmdns_20030116.bb15
4 files changed, 120 insertions, 0 deletions
diff --git a/recipes/tmdns/tmdns-20030116/busybox-init.d.patch b/recipes/tmdns/tmdns-20030116/busybox-init.d.patch
new file mode 100644
index 0000000000..cb7c24369c
--- /dev/null
+++ b/recipes/tmdns/tmdns-20030116/busybox-init.d.patch
@@ -0,0 +1,61 @@
+
+#
+# Patch managed by http://www.mn-logistik.de/unsupported/pxa250/patcher
+#
+
+--- tmdns/init.d/initscript~busybox-init.d
++++ tmdns/init.d/initscript
+@@ -2,34 +2,31 @@
+ #
+
+ PATH=/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin
+-DAEMON=/usr/local/sbin/tmdns
++DAEMON=`which tmdns 2>/dev/null`
+ NAME=tmdns
+ DESC="tmdns multicast DNS responder version 0.1"
+
+-test -f $DAEMON || exit 0
++test -n "$DAEMON" || exit 0
+
+ set -e
+
+ case "$1" in
+ start)
+ echo -n "Starting $DESC: "
+- start-stop-daemon --start --quiet --pidfile /var/run/tmdns.pid \
+- --exec $DAEMON
++ start-stop-daemon -S -x $DAEMON
+ echo "$NAME."
+ ;;
+
+ stop)
+ echo -n "Stopping $DESC: "
+- start-stop-daemon --stop --quiet --pidfile /var/run/tmdns.pid \
+- --exec $DAEMON
++ start-stop-daemon -X -x $DAEMON
+ rm -f /var/run/tmdns.pid
+ echo "$NAME."
+ ;;
+
+ reload)
+ echo "Reloading $DESC configuration files."
+- start-stop-daemon --stop --signal 1 --quiet --pidfile \
+- /var/run/tmdns.pid --exec $DAEMON
++ start-stop-daemon -X -s 1 -x $DAEMON
+ ;;
+
+ restart|force-reload)
+@@ -39,11 +36,9 @@
+ # just the same as "restart".
+ #
+ echo -n "Restarting $DESC: "
+- start-stop-daemon --stop --quiet --pidfile \
+- /var/run/$NAME.pid --exec $DAEMON
++ start-stop-daemon -X -x $DAEMON
+ sleep 1
+- start-stop-daemon --start --quiet --pidfile \
+- /var/run/$NAME.pid --exec $DAEMON
++ start-stop-daemon -S -x $DAEMON
+ echo "$NAME."
+ ;;
+
diff --git a/recipes/tmdns/tmdns-20030116/char-signed-idiocy.patch b/recipes/tmdns/tmdns-20030116/char-signed-idiocy.patch
new file mode 100644
index 0000000000..d2856e07f6
--- /dev/null
+++ b/recipes/tmdns/tmdns-20030116/char-signed-idiocy.patch
@@ -0,0 +1,16 @@
+
+#
+# Patch managed by http://www.mn-logistik.de/unsupported/pxa250/patcher
+#
+
+--- tmdns/server/tmdns.c~char-signed-idiocy
++++ tmdns/server/tmdns.c
+@@ -87,7 +87,7 @@
+ *****************************************************************************/
+ int get_options( int argc, char ** argv ) {
+
+- char c = 0;
++ int c = 0;
+ int dns_bridge = 0;
+ int not_daemon = 0;
+ int no_fork = 0;
diff --git a/recipes/tmdns/tmdns-20030116/install-init.d.patch b/recipes/tmdns/tmdns-20030116/install-init.d.patch
new file mode 100644
index 0000000000..7941df1d42
--- /dev/null
+++ b/recipes/tmdns/tmdns-20030116/install-init.d.patch
@@ -0,0 +1,28 @@
+
+#
+# Patch managed by http://www.mn-logistik.de/unsupported/pxa250/patcher
+#
+
+--- tmdns/init.d/Makefile.am~install-init.d
++++ tmdns/init.d/Makefile.am
+@@ -23,6 +23,7 @@
+ install:
+ if [ -f initscript ] ;\
+ then \
+- install -m 755 initscript $(DESTDIR)$(INIT_DIR)/tmdns ;\
++ install -d $(DESTDIR)$(INIT_DIR); \
++ install -m 755 initscript $(DESTDIR)$(INIT_DIR)/tmdns; \
+ fi
+
+--- tmdns/init.d/Makefile.in~install-init.d
++++ tmdns/init.d/Makefile.in
+@@ -274,7 +274,8 @@
+ install:
+ if [ -f initscript ] ;\
+ then \
+- install -m 755 initscript $(DESTDIR)$(INIT_DIR)/tmdns ;\
++ install -d $(DESTDIR)$(INIT_DIR); \
++ install -m 755 initscript $(DESTDIR)$(INIT_DIR)/tmdns; \
+ fi
+ # Tell versions [3.59,3.63) of GNU make to not export all variables.
+ # Otherwise a system limit (for SysV at least) may be exceeded.
diff --git a/recipes/tmdns/tmdns_20030116.bb b/recipes/tmdns/tmdns_20030116.bb
new file mode 100644
index 0000000000..4833adaac0
--- /dev/null
+++ b/recipes/tmdns/tmdns_20030116.bb
@@ -0,0 +1,15 @@
+LICENSE = "GPL"
+SECTION = "console/network"
+DESCRIPTION = "tmdns is a multicast DNS server."
+
+SRC_URI = "cvs://anonymous:@zeroconf.cvs.sourceforge.net/cvsroot/zeroconf;module=tmdns;date=${PV} \
+ file://install-init.d.patch;patch=1 \
+ file://busybox-init.d.patch;patch=1 \
+ file://char-signed-idiocy.patch;patch=1"
+S = "${WORKDIR}/tmdns"
+
+inherit autotools
+
+do_install () {
+ oe_runmake 'DESTDIR=${D}' 'INIT_DIR=${sysconfdir}/init.d' install
+}